deprecated comment in mcrypt.ini

Bug #540208 reported by Thomas on 2010-03-17
146
This bug affects 30 people
Affects Status Importance Assigned to Milestone
php-mcrypt (Ubuntu)
Wishlist
Unassigned
Lucid
Undecided
Unassigned

Bug Description

When start PHP on the command line, I get:

PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/mcrypt.ini on line 1 in Unknown on line 0

Please replace it with ; to avoid the message.

Thanks,
Thomas

ProblemType: Bug
Architecture: amd64
Date: Wed Mar 17 12:00:54 2010
DistroRelease: Ubuntu 10.04
Package: php5-mcrypt 5.3.1-0ubuntu1
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: php-mcrypt
Uname: Linux 2.6.32-16-generic x86_64

==

SRU process update:

Error messages are printed on stderr when running the php command line interface, as well as in the apache error logs when mod_php is used.

This bug has been fixed in Maverick by replacing comments using the deprecated '#' notation by the new ';' notation.

PATCH: http://launchpadlibrarian.net/48021734/mcrypt_ini_comments.debdiff

TEST CASE: run the "php" command in a terminal. The following message is printed on stderr:
PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/mcrypt.ini on line 1 in Unknown on line 0"

Chances of a regression are null.

Thomas (t.c) wrote :
Changed in php-mcrypt (Ubuntu):
status: New → Confirmed
status: Confirmed → In Progress
Changed in php-mcrypt (Ubuntu):
assignee: nobody → Mirsal Ennaime (mirsal-ennaime)
Mirsal Ennaime (mirsal-ennaime) wrote :

This debdiff fixes the issue

Changed in php-mcrypt (Ubuntu):
status: In Progress → Confirmed
assignee: Mirsal Ennaime (mirsal-ennaime) → nobody
Chuck Short (zulcss) wrote :

Thanks for the patch I have uploaded this.

Regards
chuck

Changed in php-mcrypt (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package php-mcrypt - 5.3.1-0ubuntu2

---------------
php-mcrypt (5.3.1-0ubuntu2) lucid; urgency=low

  * debian/mcrypt.ini Use the correct comment notation (LP: #540208)
 -- Mirsal Ennaime <email address hidden> Wed, 17 Mar 2010 20:24:53 +0100

Changed in php-mcrypt (Ubuntu):
status: Fix Committed → Fix Released

Updated the system, the bug is still there...
The patch can't be applied.
Thanks.

The temp. solution for those who encountered this (oh silly me!)
Just go to this file, and replace "#" with ";".

Mirsal Ennaime (mirsal-ennaime) wrote :

Here it is (again)

:)

Changed in php-mcrypt (Ubuntu):
status: Fix Released → Confirmed
Luke Faraone (lfaraone) on 2010-05-16
Changed in php-mcrypt (Ubuntu):
assignee: nobody → Luke Faraone (lfaraone)
importance: Undecided → Wishlist
Luke Faraone (lfaraone) on 2010-05-17
Changed in php-mcrypt (Ubuntu):
status: Confirmed → Fix Committed
assignee: Luke Faraone (lfaraone) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package php-mcrypt - 5.3.2-0ubuntu2

---------------
php-mcrypt (5.3.2-0ubuntu2) maverick; urgency=low

  * debian/mcrypt.ini Use the correct comment notation (LP: #540208)
 -- Mirsal Ennaime <email address hidden> Fri, 07 May 2010 22:28:57 +0200

Changed in php-mcrypt (Ubuntu):
status: Fix Committed → Fix Released
description: updated
description: updated
Fabrice Coutadeur (fabricesp) wrote :

Not worth a SRU. Invalidating the Lucid task. If you disagree, please reopen the task.

Thanks,
Fabrice

Changed in php-mcrypt (Ubuntu Lucid):
status: New → Won't Fix
Alexander Pas (alexanderpas) wrote :

could we get an update for lucid too, as lucid is still on 5.3.2-0ubuntu1

remember, lucid is an LTS release, and is supported for 5 years on servers.

Luke Faraone (lfaraone) wrote :

This was rejected as an SRU since it is a trivial bug that only generates a deprecation notice.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am 29.05.2010 17:03, schrieb Alexander Pas:
> could we get an update for lucid too, as lucid is still on
> 5.3.2-0ubuntu1

just replace the comment for yourself
on your installation and you will be happy.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkwDa6gACgkQAOHgX6771lQ2MQCgjBW9qFiwQTbJuxEx8o6dD2j4
6/4AoJCNLyI2MQClQpHSMUbfH/MgdWQU
=BiwI
-----END PGP SIGNATURE-----

Mark Schouten (mark-prevented) wrote :

Isn't this an ideal bug to fix in 10.04.1? Indeed, the fix is trivial, but it's kinda clueless to release stuff like this. I agree it's not worth an SRU, but let's just try and make Ubuntu work at once, instead of 'after manually fixing these bugs, Ubuntu is great!' :)

Elijah Osborne (elijahosborne) wrote :

With 10.04 I fixed with:

sudo gedit /etc/php5/cli/conf.d/mcrypt.ini

remove the # character and save file and the message goes away.

PeGa! (reparaciones) wrote :

Just wanted to add that removing comments is not a solution. New comment standards are semicolons, like those in php5.ini file.

thus, replacing # for a ; will do the trick without breaking anything.

I encounter this problem just today, thanks for the info mates.

I was wondering why they did not replace it?

anyway thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers