phpmyadmin does not recognize php5-mcrypt

Bug #1236035 reported by Sasa Paporovic on 2013-10-06
This bug report is a duplicate of:  Bug #1379309: Missing maintainer scripts. Edit Remove
102
This bug affects 21 people
Affects Status Importance Assigned to Milestone
php-mcrypt (Ubuntu)
Undecided
Unassigned

Bug Description

phpmyadmin do not recognize the php5-mcrypt module. On the phpmyadmin webpage(after login) phpmyadmin tells that mcrypt is still missing. This is incorrect.

Steps to reproduce:
1.Install phpmyadmin
2.Make sure that php5, especially php5-mcrypt is installed into the system
3.Login in the phpmyadmin webpage
4.See on the bottom of the main page that phpmyadmin miss mcrypt

Additional: Also the program mcrypt is installed even it should not be necessary.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: phpmyadmin 4:4.0.6-1
ProcVersionSignature: Ubuntu 3.11.0-11.17-generic 3.11.3
Uname: Linux 3.11.0-11-generic x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
Date: Sun Oct 6 19:13:52 2013
InstallationDate: Installed on 2013-05-03 (156 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: phpmyadmin
UpgradeStatus: Upgraded to saucy on 2013-10-05 (1 days ago)

Sasa Paporovic (melchiaros) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in phpmyadmin (Ubuntu):
status: New → Confirmed
Richard Ayotte (rich-ayotte) wrote :

The problem is with the php5-mcrypt package. It puts the mcrypt.ini file in the /etc/php5/conf.d directory which is no longer correct because apache2 and cli have their own conf.d directory.

Here's the fix.

mv -i /etc/php5/conf.d/mcrypt.ini /etc/php5/mods-available/
sudo php5enmod mcrypt
sudo service apache2 restart

Richard Ayotte (rich-ayotte) wrote :

New bug filed for php5-mcrypt #1240590

Whatts (tomklaverblad) wrote :

I can confirm Richard's solution.
I was also affected by the bug but moving (or copying) the mcrypt.ini file, php5enmod and apache restart and no more error in phpmyadmin.

David Roper (ebonhand09) wrote :

Confirmed both the problem and solution here too - thanks

Vivien GUEANT (vivienfr) wrote :

I can confirm Richard's solution.

proligde (proligde) wrote :

Confirmed both, too - thanks!

Sig (sigma-avro) wrote :

yeah! worked too. Thank you !

Michal Čihař (nijel) wrote :

Reassigning to php5-mcrypt, where it actually belongs.

affects: phpmyadmin (Ubuntu) → php-mcrypt (Ubuntu)
Joe Mooring (toomanypets) wrote :

This appears to be fixed. With a fresh install of Ubuntu 14.04 Beta 2:

$ sudo apt-get install apache2
$ sudo apt-get install mysql-server
$ sudo apt-get install php5 php5-dev php5-gd php5-mcrypt php5-memcached php5-mysql
$ sudo php5enmod mcrypt
$ service apache2 restart

A directory listing of /etc/php5/mods-available shows mcrypt.ini.

phpinfo() shows:
mcrypt support enabled
mcrypt_filter support enabled

summary: - phpmyadmin do not recognize php5-mcrypt
+ phpmyadmin does not recognize php5-mcrypt
chrone (chrone81) wrote :

my site -running ubuntu 14.04 lts server 64bit edition- uses the mcrypt too. somehow the default installation did not enable the mcrypt.

so we do have to enable it manually by doing "sudo php5enmod mcrypt", restart the apache, and voila!

sudo php5enmod mcrypt
sudo service apache2 restart
cd /etc/php5/apache2/conf.d
ls -la | grep mcrypt
lrwxrwxrwx 1 root root 31 May 13 14:37 20-mcrypt.ini -> ../../mods-available/mcrypt.ini

Ben Stanley (ben-stanley) wrote :

I am running a Joomla site. I tried to enable two factor authentication, but when I pressed "Save & Close", the page blanked and would not load again. This is running on Ubuntu 14.04.4 LTS x86_64.

I had the php5-mcrypt package installed. I was not able to verify the phpmyadmin reproduction, as I don't have phpmyadmin installed.

However, after running the fix described in comment #12, I have enabled two factor authentication. Furthermore, after pressing "Save & Close", Joomla administrator returns me to the list of users page (instead of showing a blank page that fails to load).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers