php-elisp 1.21.0-1 source package in Ubuntu

Changelog

php-elisp (1.21.0-1) unstable; urgency=medium

  * Adopt package (Closes: #902633).
    - Add Emacsen team VCs links.
    - Set Maintainer to Debian Emacsen Team.
    - Add Ola Lundqvist and myself to Uploaders.
  * New upstream release (Closes: #895743).
  * Elpafy php-elisp:
    - Implicitly drops support for xemacs (Closes: #665314).
    - Add dh-elpa to Build-Depends.
    - Add new package: elpa-php-mode.
    - Convert php-elisp to dummy transitional package.
    - Rewrite debian/rules.
    - Enable autopkgtests.
    - Drop obsolete emacsen packaging directives: php-elisp.dirs,
      php-elisp.emacsen-install, php-elisp.emacsen-remove,
      php-elisp.emacsen-startup, php-elisp.emacsen-startup.new
      (Closes: #827827).
  * Declare compat level 11.
  * Switch to debhelper 11.
  * Declare Standards-Version: 4.3.0.
  * Update watchfile to v4, and update upstream project's location.
  * Suggest php and php-cli rather than php5 and php5-cli.
  * Add gbp.conf.
  * Add patch to disable php-project-root selftest.
  * Add upstream README.
  * Update Homepage, because php-mode has a new upstream maintainer.
    The project's transfer of ownership is documented here:
    https://github.com/emacs-php/php-mode/issues/387
  * Drop out-of-date php-elisp.README.Debian.  The upstream README contains
    this information.
  * Add debian/NEWS to notify users of depreciated PHP 2 support, and show
    how to restore the behaviour of past php-elisp releases.

 -- Nicholas D Steeves <email address hidden>  Fri, 01 Feb 2019 14:43:45 -0700

Upload details

Uploaded by:
Debian Emacsen team on 2019-02-04
Uploaded to:
Sid
Original maintainer:
Debian Emacsen team
Architectures:
all
Section:
lisp
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Disco release on 2019-02-04 universe text

Builds

Disco: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
php-elisp_1.21.0-1.dsc 1.7 KiB bdc6a4897bd897e2eb6ad678897ec1c9c0f6e7ea57dc10a560dab925f6c05173
php-elisp_1.21.0.orig.tar.xz 79.4 KiB 6b6c95203e44cb3b38e808c9919acdbce7b6ce973027d7961b73c5eb451adc7e
php-elisp_1.21.0-1.debian.tar.xz 4.9 KiB 1267b058b37b8932edf5cee169d311241b9c913f8fb46514137f09d89e17ac12

Available diffs

No changes file available.

Binary packages built by this source

elpa-php-mode: PHP Mode for GNU Emacs

 This project updates PHP Mode for GNU Emacs with features that make
 it more friendly to use with PHP 5.4 and later. Web Mode should be
 used in preference to PHP Mode when one needs to work with PHP
 scripts that contain HTML and other markup. Supports:
  * Highlighting for keywords, for all official PHP magic and
    predefined constants, for PHPDoc tags and annotations, and for
    customised user-defined lists of frequently used constants.
  * Imenu listings for traits, interfaces, namespaces, and anonymous
    functions.
  * Syntax highlighting, including fontification of namespaces.
  * Chained Method Calls that align method calls over multiple lines
    anchored around the '->' operator.
  * Prettified formatting of arrays and nested function calls.
  * Flymake on-the-fly syntax checking.
  * Searching PHP documentation using key at point (under cursor).
  * Executing Regions of PHP. Output appears in the *PHP* buffer.
  * Multiple coding styles. In addition to its default style, this
    mode supports Drupal, WordPress, Symfony2, and PEAR/PSR-2.
  * Amaka. PHP Mode activates when editing build scripts.
  * Most of PSR-5: PHPDoc (Draft).

php-elisp: transitional package, php-elisp to elpa-php-mode

 PHP Mode for GNU Emacs has been elpafied. This dummy transitional
 package facilitates the transition from php-elisp to elpa-php-mode
 and is safe to remove.