apcu_entry hangs, freezes php

Bug #1786205 reported by Peter Bosch on 2018-08-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
php-apcu (Debian)
Fix Released
Unknown
php-apcu (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading our testing server to bionic, our web application stopped responding entirely
after the second request. We traced this to a problem in php-apcu where it would block upon the second
call to apcu_entry and completely lock up the php processes causing the server to become unresponsive to any further requests.

This issue was already reported and fixed upstream (release 5.1.11) and I have attached the diff for the corresponding commit, though I would like to note that there have been 3 bugfix releases since the packaged version (5.1.9).

Upstream issue: https://github.com/krakjoe/apcu/issues/246

Affected systems: anything running either php-fpm or apache with mod-php

The attachment "Upstream commit a409cc5473d186500fdafcfada40a154b8786957 "Fix #246 - apcu_entry hangs"" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in php-apcu (Debian):
status: Unknown → Confirmed
Changed in php-apcu (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.