Apache hangs/crash while running OwnCloud 8.0.0

Bug #1422484 reported by Johannes Hessellund
This bug affects 11 people
Affects Status Importance Assigned to Milestone
php-apcu (Ubuntu)

Bug Description

Upgraded to OwnCloud 8.0.0, every few hours apache and all sites becomes inaccessible. The apache service is running and I don't see any errors in the apache log or the system logs.

See https://github.com/owncloud/core/issues/14175

This is running on ubuntu 14.04. This was running with no issues on Owncloud 7.

When I try to access any site it just sits like the page is loading but never loads. It will sit there like that until I close the browser. No error or connection timeout.

The solution was to purge php5-apcu from the system and restart apache.

While there might be bugs in OwnCloud, no php website should ever be able to hang/crash the whole apache process, and it seems that there is an issue with apcu.

Revision history for this message
Paul Broadhead (pjbroad) wrote :

I've been having the same issue and am now waiting to see if purging php5-apcu helps.

When apache stops responding, it has maxed out on threads and I get this message in error.log:

[mpm_prefork:error] [pid 7628] AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting

I also have seen a apc related error:
PHP Warning: apc_store(): GC cache entry 'oc558dd98d33/AutoloaderOC_User_Interface' was on gc-list for 3602 seconds in /var/www/owncloud/lib/private/memcache/apc.php on line 21

Killing a few threads allowed me to get to /server-status on the server which showed the threads were all in "Sending Reply" states responding to owncloud/status.php requests.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in php-apcu (Ubuntu):
status: New → Confirmed
Revision history for this message
Gerard van Dijnsen (gerard-openbizz) wrote :

I have exactly the same problem. Actions taken so far (to no avail):

- Switched from apache default to mpm_prefork
- Removed php-apc

Now checking if removing php5-apcu does indeed work. It crashes rather often so I should know within a day or so...

Revision history for this message
Paul Broadhead (pjbroad) wrote :

sudo apt-get purge php5-apcu
sudo service apache2 restart

This fixed it for me.

Revision history for this message
Jean-Sébastien Frerot (jsfrerot) wrote :

php5-apcu removal fixed it for me too.

Revision history for this message
Johannes Hessellund (osos) wrote :

Did you try updating to php-apcu version 4.0.6?

It is available in a ppa: https://launchpad.net/~ondrej/+archive/ubuntu/php5

This fixes it for me.

Revision history for this message
Jonas Pedersen (jonasped) wrote :

Seems that upgrading to php-apcu version 4.0.6 solved the issue for me as well.

Revision history for this message
Joan Maspons (jmaspons) wrote :
Revision history for this message
samat (somyqk) wrote :

Thanks, I had the same issue. Updating to version 4.0.6 has solved the issue.

Revision history for this message
Dan (daniel-scharon) wrote :

the upgrade should be done via SRU or backports, not via PPA or manual installation of a .deb, see #1374892

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.