[Karmic] "phoronix-test-suite gui" doesn't work

Bug #430946 reported by Loïc Martin on 2009-09-16
106
This bug affects 20 people
Affects Status Importance Assigned to Milestone
phoronix-test-suite (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: phoronix-test-suite

When launching the phoronix-test-suite with a GUI (from a terminal: "phoronix-test-suite gui"), the following error appears:

Fatal error: Class 'GtkWindow' not found in /usr/share/phoronix-test-suite/pts-core/objects/gtk/pts_gtk_window.php on line 23

It might be a missing dependency, or the packaging has forgotten to build the GUI.

Changed in phoronix-test-suite (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Dustin Kirkland  (kirkland) wrote :

Michael confirms that phoronix-test-suite GUI needs php-gtk to work, which isn't packaged for Ubuntu yet.

It looks to me like this package used to exist in Debian, but has since been removed:
 * http://packages.qa.debian.org/p/php-gtk.html

:-Dustin

Kip Warner (kip) wrote :

I can confirm the same observation under amd64 Karmic. The package should suggest installation of php5-gtk. Even though that package isn't found in the universe/multiverse right now, at least the user will have a better chance of knowing why the GUI doesn't work.

bbordwell (benbordwell) wrote :

This bug is still present in Lucid, perhaps since it is still in development now would be a good time to look at adding the required package to the repositories?

Kip Warner (kip) wrote :

I agree.

It's http://gtk.php.net/ that needs to be packaged up. It's not too bad to package but there hasn't been a new release in two years so you'd probably be best off using a CVS snapshot.

For those users in the mean time I do have a 64-bit Debian package at http://phoronix-test-suite.com/misc/php5-gtk2_2.0.1-0_amd64.deb (also need to add extension=php_gtk2.so to your php.ini file afterwards), but I received a report that due to Lucid's recent PHP5.3 upgrade that it's no longer compatible with that binary module.

MIchael

bbordwell (benbordwell) wrote :

I would have to disagree about it being easy to package (for a normal user) because of bug 430946.

I tried downloading a pre-made .deb and it did not work, most likely due to what you said abut lucid's changes to php.

Oh well the CLI is easy enough.

Fabián Rodríguez (magicfab) wrote :

Tested again in Ubuntu 10.04 LTS, same problem:

$ phoronix-test-suite gui
PHP Notice: Use of undefined constant IS_NVIDIA_LINUX - assumed 'IS_NVIDIA_LINUX' in /usr/share/phoronix-test-suite/pts-core/objects/phodevi/components/phodevi_system.php on line 1052
PHP Fatal error: Class 'GtkWindow' not found in /usr/share/phoronix-test-suite/pts-core/objects/gtk/pts_gtk_window.php on line 24

There's a needs-packaging bug here:
https://bugs.edge.launchpad.net/debian/+bug/260235

@michaellarabel perhaps you'd be able to contribute upstream ?:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=473396

I will be offering up a independent php5-gtk Ubuntu/Debian package that's compatible with Lucid's PHP5 installation soon in the Phoronix-Test-Suite.com Debian repository.

Karmo Rosental (karmux) wrote :

I have never been able to use Phoronix Test Suite in Ubuntu. In every version had been different fatal errors.

Ubuntu 10.04 LTS and Phoronix 2.4 & 2.6:

PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/imagick.ini on line 1 in Unknown on line 0
PHP Fatal error: Class 'GtkWindow' not found in /usr/share/phoronix-test-suite/pts-core/objects/gtk/pts_gtk_window.php on line 24

@Karmo: Yes, unfortunately PHP5-GTK still is not available in Ubuntu's package repositories.

If you are running 32-bit Lucid though, I have a package for PHP5-GTK at http://www.phoronix-test-suite.com/misc/php5-gtk-2.0.1~2010-05-11_i386.deb but I haven't gotten around to spinning a x86_64 version yet.

Dylan Coakley (dylan-coakley) wrote :

This problem also affects me... its really annoying. I successfully ran the suite with the GUI only once. Any version now fails to run the GUI even after installing the php5-gtk and adding to php.ini.

Please make a 64bit version of php5-gtk that works with PTS!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.