Phonon default capture device preferences are not saved

Bug #769274 reported by Vilian Atmadzhov on 2011-04-22
94
This bug affects 20 people
Affects Status Importance Assigned to Milestone
phonon (Ubuntu)
Undecided
Unassigned

Bug Description

UPDATE: This also affects the official Kubuntu 11.04 release.

Binary package hint: phonon

I own a Logitech Pro 9000 Webcam with a built-in microphone.

The bug: The Audio Capture Preferences in "Phonon - KDE Control Module" are not saved.

How to recreate the bug:
Change the order of the capture devices and click Apply/OK. Upon reopening Phonon, the device order is the old one and not the changed one.

I'm trying to set "QuickCam Pro 9000 Analog Mono" as my first capture device, but after applying the settings and reopening Phonon Control Module, the "Internal Audio Analog Stereo" device is first.

Whatever changes I make in the device order preferences, they are not saved.

This bug is only present in Kubuntu 11.04 both BETA 1 and 2. Only amd64 has been tested.
Tests have been performed on fresh installs and from a Live session.

The bug is NOT present in Kubuntu 10.10 or any Ubuntu version.

System Information:
Release: Kubuntu 11.04 Beta 2
Architecture: amd64
Phonon version: 4:4.7.0really4.5.0-0ubuntu3

The above is from the Kubuntu 11.04 Beta 2 LiveCD with no updates.
All package versions are the same as in the Beta 2 CD.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: phonon 4:4.7.0really4.5.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Fri Apr 22 23:31:17 2011
LiveMediaBuild: Kubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: phonon
UpgradeStatus: No upgrade log present (probably fresh install)

Furthermore, under the Speaker Setup tab, clicking on "Front Left/Right" Speaker Testing produces no sound, however applications such as Skype, Amarok and system notifications produce sounds without any issues.

I have tried both GStreamer and VLC backends.

tags: added: audio capture kubuntu phonon
Dmitry Verkhoturov (paskal-07) wrote :

This bug completly affects me. Phonon won't save capture devices order and clicking "Front Left/Right" won't produce any sound but any apps sound works right.
Let me know if it necessary to upload any data.
I have clean just installed Kubuntu 11.04 system.

Peter Lemieux (seijisensei) wrote :

It doesn't appear that saving the settings changes anything in ~/.kde/share/config/phonondevices. When I save a different ordering of devices, the datestamp on the file doesn't change, and the only file whose datestamp changes is ~/.kde/share/config/systemsettingsrc which has no information about sound devices.

There are also two files in ~/.config/kde.org/, but neither of them are relevant as well. I've looked in a couple of other likely spots and cannot find any configuration file that is changed when I save settings in this dialog.

As the poster of https://bugs.launchpad.net/ubuntu/+source/phonon/+bug/638965, I can confirm that it has nothing to do with that report. (In fact, I later determined that I had missed the prefer/defer buttons.)

I found a workaround of the problem that persists even after reboot.

I installed pavucontrol and manually set Skype (and any other desired application) to use my USB microphone, instead of the Internal Device. Now I can finally start enjoying KDE...

The original bug still exists. Any changes in the Phonon Module are not saved. This is also tested on a fresh Kubuntu 11.04 (NOT beta) with all updates.

If it wasn't for the workaround above, I would have gone back to GNOME.

Changed in phonon (Ubuntu):
status: New → Confirmed
description: updated
molecule-eye (niburu1) wrote :

I am observing this as well using a mikomi "Gateway" usb webcam. Highly annoying.

Jukka (jukka-parviainen) wrote :

This is a workaround, too: in Phonon Speaker Setup
- select Sound Card: Internal Audio
- change from profile Analog Stereo Duplex -> Analog Stereo Output

This seems to disable the microphone from the Internal Audio sound card. After this the USB microphone is next on the list and it works. Also internal audio works as output.

I did try the workaround suggested by Jukka, but my motherboard comes with a 7.1 sound card and the microphone jack is always that, a microphone jack.

As for my workaround with pavucontrol: the application for which you want to change the input/output device, must be active and playing/recording sound.

In the case of Skype, calling the nice lady from "Skype Test Call" and changing the input device at the same time does the trick.
Once you change it, it is remembered, so you don't have to do it again.

This is not a major bug, but it can be a real show-stopper especially for newcomers.

Thank you so much! pavucontrol did the trick. And you are right- I had to switch back to gnome so that my wifes parents could skype the grandkids. Now I can switch back =)

Interestingly, audio device preferences for playback streams *are* correctly persisted, it's just the capture device ordering that isn't saved.

Lorenzo Bettini (bettini) wrote :

installing pavucontrol also solved my problem!
Now skype works in kubuntu natty!

Mark Fraser (launchpad-mfraz) wrote :

Not sure if this is related to this bug, but when I first enter Phonon in Multimedia, speaker setup shows my webcam as the output device. If I change it to internal audio, click Apply, and go back to the main window, when I go back it is showing nothing under speaker setup and the menus are empty.

Also, I only have to click on Phonon for the Apply button to light up and for it to tell me that the settings haven't been saved.

Sorush.Nazari (s-nazari) wrote :

I had to follow the combination of Jukka instructions and the installation of pavucontrol to solve the problem but the sound quality is not good at all.

piccobello (piccobello) wrote :

installing pavucontrol did not solve my problem.
I have a 5.1 setting but the subwoofer is disabled every time.
It disables somehow from one song to the next in Amarok!!!!
I have to change settings in Configuration panel of pavucontrol, then
change it back to 5.1, but it resets again to some sort of 5.0 with
the next song.
Sound used to work so well, I never had a problem with Kubuntu sound
before. In 10.4 I could set everything via the mixer with no problem.
I'm getting seriously tired of having to reinvent the wheel everytime I do an upgrade.
:s

problem is still present:
Linux wks002 2.6.38-10-generic-pae #46-Ubuntu SMP Tue Jun 28 16:54:49 UTC 2011 i686 i686 i386 GNU/Linux

and pavucontrol workaround works:
start skype test call, go to pavucontrol -> recording, associate skype with your capture device.

piccobello (piccobello) wrote :

In the end my problem was solved removing pulseaudio completely and relying on alsa instead.
This page was quite useful for me:
http://alsa.opensrc.org/MultipleCards

Harald Sitter (apachelogger) wrote :

Still present? Sounds like the PulseAudio config interception is doing a bad job. Also FWIW: the interception is why the timestamp of the config file you found is not changing (it does not do for any config change with PA support enabled).

Changed in phonon (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for phonon (Ubuntu) because there has been no activity for 60 days.]

Changed in phonon (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers