Amarok stops after playing 1 song in playlist

Bug #565674 reported by btilford on 2010-04-17
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Phonon
Unknown
Medium
phonon (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: amarok

This seems to be inconsistent in when it happens. Sometimes it will continue playing after a song ends but others it will just stop playing after a song ends.

ProblemType: Bug
Architecture: amd64
Date: Sat Apr 17 19:45:46 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/amarok
NonfreeKernelModules: nvidia
Package: amarok 2:2.2.0-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SourcePackage: amarok
Uname: Linux 2.6.31-20-generic x86_64
XsessionErrors:
 (polkit-gnome-authentication-agent-1:31413): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (npviewer.bin:32298): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64
 (npviewer.bin:32298): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64
 (npviewer.bin:1448): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64
 (npviewer.bin:1448): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64

btilford (bentilford) wrote :
Qadmium (qadmium) wrote :

also affects me, but only with FLAC files

Andrew Terekhov (ultraata) wrote :

Also happens on 32-bit 9.10.
What debug do I need to gather?

Ken Sharp (kennybobs) wrote :

Same on Lucid. Also the pause button causes the same song to start again!

tags: added: i386 karmic lucid
summary: - Amorok stops after playing 1 song in playlist
+ Amarok stops after playing 1 song in playlist
Ken Sharp (kennybobs) on 2010-07-05
Changed in amarok (Ubuntu):
status: New → Confirmed

Same Problem here. I'm using Ubuntu 10.04, the problem is occuring since I upgraded to kernel 2.6.32-24, but that could be a coincidence.

Only a restart helps to get it playing again. Is the the same with your systems?

Myriam Schweingruber (myriam) wrote :

This is a phonon bug, sound output is handled by Phonon only

affects: amarok (Ubuntu) → phonon (Ubuntu)
Changed in phonon:
status: Unknown → New
Changed in phonon:
status: New → Confirmed
Changed in phonon:
importance: Unknown → Medium
Changed in phonon:
status: Confirmed → Unknown
Changed in phonon (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.