kalarm crash with signal 11 SIGSEGV

Bug #383321 reported by Thomas Winteler (Win-Soft) on 2009-06-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Phonon
Fix Released
High
phonon (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdepim

hi

i saw that there are kalarm bugs erlier, but i think mine isn't the same.

on boot, kde start i get all the kalarm popup's and then the crash.
i can simulate it if i start kalarm from konsole:

thomi@hercules:~$ kalarm &
[1] 20933
thomi@hercules:~$ <unknown program name>(20934)/ main: initialising
<unknown program name>(20941)/ main: Unknown resource type: "alarms"
QObject: Cannot create children for a parent that is in a different thread.
(Parent is Phonon::Xine::MediaObject(0xb2c289a8), parent's thread is AudioThread(0xa27cbb0), current thread is QThread(0x9ed3348)
KCrash: Application 'kalarm' crashing...
sock_file=/home/thomi/.kde/socket-hercules/kdeinit4__0

[1]+ Done kalarm
thomi@hercules:~$

Backtrace is attached..

often, if i try to start kalarm from konsole then i get also this:
thomi@hercules:~$ kalarm
<unknown program name>(20896)/ main: initialising
<unknown program name>(20898)/ main: Unknown resource type: "alarms"
ASSERT: "s_instance == 0" in file /build/buildd/phonon-4.3.1/xine/backend.cpp, line 74
KCrash: Application 'kalarm' crashing...
sock_file=/home/thomi/.kde/socket-hercules/kdeinit4__0
<unknown program name>(20895)/: Communication problem with "kalarm" , it probably crashed.
Error message was: "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

thomi@hercules:~$ kalarm: Fatal IO error: client killed
Unable to start Dr. Konqi

thanks for help

thomi

by the way, my system info's:

Linux hercules 2.6.28-12-generic #43-Ubuntu SMP Fri May 1 19:27:06 UTC 2009 i686 GNU/Linux
Qt: 4.5.0
KDE: 4.2.4 (KDE 4.2.4)

Jonathan Thomas (echidnaman) wrote :

Hi,
This crash seems to be caused by a bug in the xine backend for phonon. If you could, could you please install phonon-dbg and re-obtain the backtrace? Thank in advance.

affects: kdepim (Ubuntu) → phonon (Ubuntu)
Changed in phonon (Ubuntu):
status: New → Incomplete

Hey..

Thanks for fast Feedback.

Here are the new output's and backtrace:

thomi@hercules:~$ kalarm &
[1] 6354
thomi@hercules:~$ <unknown program name>(6355)/ main: initialising
<unknown program name>(6359)/ main: Unknown resource type: "alarms"
ASSERT: "that->m_newStream == 0" in file /build/buildd/phonon-4.3.1/xine/xinethread.cpp, line 76
KCrash: Application 'kalarm' crashing...
sock_file=/home/thomi/.kde/socket-hercules/kdeinit4__0
system call fstat: Bad file descriptor
system call fstat: Bad file descriptor
system call fstat: Bad file descriptor
system call fstat: Bad file descriptor

[1]+ Done kalarm
thomi@hercules:~$

thanks
thomi

hi

my system is now on kde 4.2.90 (4.3 beta 2) and kalarm always crashes..

see new attached crashlog.

thanks
thomi

PascalC (p92) wrote :

I can confirm this too

PascalC (p92) wrote :

To reproduce, just setup an alarm with a reminder including sound
wait for the reminder to pop up
kalarm crashes as soon as sound has finished playing

PascalC (p92) wrote :
Download full text (6.6 KiB)

attached backtrace with the following software levels :

$ dpkg -l *phonon* *kalarm* kdelibs* *qt* *xine* | grep ^ii | sort | cut -c1-95
ii apport-qt 1.0-0ubuntu5.2
ii gtk2-engines-qtcurve 0.62.8-0ubuntu1
ii gtk-qt-engine 1:1.1+svn20080816-0ubuntu7
ii gtk-qt-engine-kde4 1:1.1+svn20080816-0ubuntu7
ii kalarm 4:4.2.4-0ubuntu1~jaunty1~ppa2
ii kdelibs4c2a 4:3.5.10.dfsg.1-1ubuntu8
ii kdelibs5 4:4.2.4-0ubuntu1~jaunty1~ppa2
ii kdelibs5-data 4:4.2.4-0ubuntu1~jaunty1~ppa2
ii kdelibs5-dbg 4:4.2.4-0ubuntu1~jaunty1~ppa2
ii kdelibs-bin 4:4.2.4-0ubuntu1~jaunty1~ppa2
ii kdelibs-data 4:3.5.10.dfsg.1-1ubuntu8
ii kdelibs-dbg 4:3.5.10.dfsg.1-1ubuntu8
ii language-selector-qt 0.4.2.3
ii libaqbanking20-plugins-qt 3.7.2-1
ii libavahi-qt3-1 0.6.23-4ubuntu4
ii libdbus-1-qt3 0.9-0ubuntu1
ii libdbus-qt-1-1c2 0.62.git.20060814-2build1
ii libpackagekit-qt11 0.3.14-0ubuntu5
ii libphonon4 4:4.3.1-0ubuntu3
ii libpoppler-qt4-3 0.10.5-1ubuntu2.2
ii libqt3-mt 3:3.3.8-b-5ubuntu1
ii libqt4-assistant 4.5.0-0ubuntu4.1
ii libqt4-core 4.5.0-0ubuntu4.1
ii libqt4-dbg 4.5.0-0ubuntu4.1
ii libqt4-dbus 4.5.0-0ubuntu4.1
ii libqt4-designer 4.5.0-0ubuntu4.1
ii libqt4-dev ...

Read more...

Jonathan Thomas (echidnaman) wrote :

This should be fixed in KDE 4.3.10.

Changed in phonon (Ubuntu):
status: Incomplete → Fix Released
Changed in phonon:
status: Unknown → Fix Released
Changed in phonon:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.