[GStreamer] Amarok doesn't advance to the next track

Bug #359542 reported by Tim Holy on 2009-04-11
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Phonon
Fix Released
Medium
phonon (Fedora)
Incomplete
Undecided
Unassigned
phonon (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: amarok

Kubuntu Jaunty beta. If I double-click on an album in my collection, the first track gets played, but then amarok stops playing. Also, the bug "next track" and "previous track" buttons at the top left don't do anything (and neither do the ones in the "Amarok" menu). I can double-click on each track in the playlist in turn and get it to play, but when done it always stops and never goes on to the next track.

I've looked for a setting "stop after current track" and can't find anything except a context menu when I right-click on a given playlist item. However, selecting that menu item (hoping to un-select something...) doesn't do anything, as far as I can tell.

One hint about what's going on: on the command line, when the current track finishes I get the following output:
QString::arg: Argument missing: Amarok - No track playing., 0:00
QString::arg: Argument missing: Amarok - No track playing., 0:00
amarok(12437) CurrentTrack::dataUpdated: CurrentTrack::dataUpdated
QString::arg: Argument missing: Amarok - No track playing., 0:00
QString::arg: Argument missing: Amarok - No track playing., 0:00
QString::arg: Argument missing: Amarok - No track playing., 0:00
QString::arg: Argument missing: Amarok - No track playing., 0:00
amarok(12437) CurrentTrack::dataUpdated: CurrentTrack::dataUpdated
amarok(12437) CurrentTrack::dataUpdated: CurrentTrack::dataUpdated
amarok(12437) CurrentTrack::dataUpdated: CurrentTrack::dataUpdated

Starting a new track (by double-clicking) also yields output, but far fewer:
QString::arg: Argument missing: Amarok - No track playing., 0:00
amarok(12437) CurrentTrack::dataUpdated: CurrentTrack::dataUpdated

I have a hard time believing that this is broken for everyone, because it's such an obvious bug; I'm wondering whether it could be setup-specific. Note I reported a K-menu bug with amarok also, leading me to wonder whether there is some package error that is only affecting my machine. Here are amarok-related packages on my machine:
tim@diva:~/personal$ dpkg -l amarok*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-====================================-====================================-========================================================================================
ii amarok 2:2.0.2mysql5.1.30-0ubuntu2 easy to use media player based on the KDE 4 technology platform
ii amarok-common 2:2.0.2mysql5.1.30-0ubuntu2 architecture independent files for Amarok
un amarok-engine <none> (no description available)
pn amarok-engine-xine <none> (no description available)
un amarok-kde4 <none> (no description available)
pn amarok-xine <none> (no description available)

Alternatively, perhaps it has something to do with a bug in the string handling, and there's something unusual about how my files are named? I simply ripped with K3b...

7penselen (zienszo) wrote :

Sometimes Amarok2 springs a few tracks without any reason. I don't have any output.

I have a temporary solution for this problem. Installing Amarok 1.4.10 from a external repos on your (K)Ubuntu system.
http://nomad.ca/blog/2009/apr/3/amarok-14-jaunty-ubuntu-904/

Salvation (jjmatt) wrote :

I'm getting the same error. I wasn't when I was running amarok 2.0.2 but I upgraded to 2.0.90 so the last.fm scrobbler would work, and now it'll play one song, then stop, even if a song is queued after it. Exactly as you described.

Salvation (jjmatt) wrote :

Just as an update -- I was just messing around with my amarok, testing this and that and I got it to work. Not sure exactly which tweak it was that did it, but I'm assuming that it was this one: after changing one of the backends (from xine to gstreamer) I tried playing a track, but first made the next track "stop playing after this track". It didn't play immediately because I guess there were issues with gstreamer, so I restarted, everything went back to xine, and playback was continuous.

autofyrsto (autofyrsto) wrote :

Same problem, same solution, running Amarok 2.1 on Ubuntu 9.04.

Settings-->Configure Amarok-->Playback-->Click "Configure"-->"Backend" Tab
Select the "GStreamer" backend and click OK. Then restart Amarok.
Everything goes back to Xine and playback is continuous.

This solution also cured my ailing "currently playing" widget. The widget had always indicated that no track was playing, even if a track was playing. After the switch & restart, the widget now correctly displays information about the currently playing track.

Thanks, Salvation.

Tim Holy (holy-wustl) wrote :

When I promote Gstreamer to the first-choice engine, click Apply, click OK, and then quit Amarok, it crashes. When I start it again, it's still on the Gstreamer engine (i.e., doesn't revert to Xine as you describe). And, I'm still stuck with it playing one track and then stopping.

This is now with Amarok 2.1.1 from backports on KDE 4.2.2.

Sahil Ahuja (sahilahuja) wrote :

Also facing the same issue with Amarok 2.1.1 with KDE 4.3 in Fedora 11

Clicking on "Next" button plays the same track again. Repeat track also doesn't work.

Myriam Schweingruber (myriam) wrote :

Please, people, Amarok is a KDE application, you should use the phonon-backend-xine. This is not an Amarok problem, but a problem with the phonon-backend-gstreamer. Using the xine backend solves that.

affects: amarok (Ubuntu) → phonon (Ubuntu)
Myriam Schweingruber (myriam) wrote :

Please use the xine backend for phonon, this is a bug in the gstreamer backend. Not an Amarok bug.

affects: amarok (Fedora) → phonon (Fedora)
7penselen (zienszo) wrote :

Never use the music play plasmoid when you use Amarok 2.x This caused bad handling of the playlists.

Changed in phonon (Ubuntu):
status: New → Triaged
importance: Undecided → Low
summary: - amarok2 doesn't advance to next track
+ [GStreamer] Amarok doesn't advance to the next track
Tim Holy (holy-wustl) wrote :

My backend _is_ listed as being Xine (K menu -> System settings -> Multimedia -> backend tab, Xine is the first entry). And, to the best of my knowledge I'm not using the music play plasmoid. This is nevertheless still a problem for me.

James Kaelin (jkaelin) wrote :

I am also having this issue: Bug #470619

But I don't have phonon-backend-gstreamer installed

Tim Holy (holy-wustl) wrote :

For me, this problem was finally fixed by upgrading to Kubuntu 9.10. Yay!

Jonathan Thomas (echidnaman) wrote :

Great! I cannot reproduce the bug here either with Phonon/GStreamer/Kubuntu 9.10

Changed in phonon (Ubuntu):
status: Triaged → Fix Released
Kevin Guertin (leonivek) wrote :

Deleting the .xine folder in my Home folder and restarting Amarok seems to have fixed the problem for me.

Andrew Ash (ash211) wrote :

Sahil, you reported that you were seeing this problem on Fedora. Is it still a problem there? Can we close the Fedora task in Launchpad?

Changed in phonon (Fedora):
status: New → Incomplete
Changed in phonon:
status: Unknown → Confirmed
Changed in phonon:
status: Confirmed → Fix Released
Jade Falcon (jadefalcon1) wrote :

Deleting my ~/.xine folder solved this behavior for me.

I'm running Amarok on Kubuntu 9.10, without ever having installed or run Gnome on this install. I only recently switched from Amarok 1.4 to Amarok 2.

Changed in phonon:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.