folder name contain "#" sign - amarok does not play media files

Bug #502127 reported by adamjn on 2010-01-01
38
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Phonon
Fix Released
Medium
phonon-backends (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: amarok

If folder name contains '#' (hash) sign amarok does not play media files which are inside that folder. For example my folder names are: '# minimall', '# ambient', etc...

My system:
Ubuntu 9.10
Amarok 2.2.2.0-0ubuntu2

ProblemType: Bug
Architecture: i386
Date: Fri Jan 1 18:59:31 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/amarok
NonfreeKernelModules: nvidia
Package: amarok 2:2.2.0-0ubuntu2
ProcEnviron:
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: amarok
Uname: Linux 2.6.31-16-generic i686
XsessionErrors:
 (firefox:2593): GLib-WARNING **: g_set_prgname() called multiple times
 (polkit-gnome-authentication-agent-1:2599): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

adamjn (adamjn) wrote :
Andrew Ash (ash211) wrote :

Thanks for reporting this bug, Adam. It turns out that it was just recently reported to the Amarok devs on their mailing list too[1], so they talked about it a bit there. The bug appears to be one in the phonon backends, specifically the gstreamer backend. Try switching to the xine backend, which seems to work better anyway. It's the one that Amarok devs recommend.

For a more long-term solution, we need a new version of Phonon pulled into Ubuntu 10.04, which should be happening automatically anyway. The bugfix was included there, and the patch was committed to SVN on 2009-06-18 [2]. To ensure that this happens smoothly, please give one of the later lucid alphas a shot (live CD should be fine) and see if the bug is still around then.

[1] http://mail.kde.org/pipermail/amarok/2009-December/009782.html
[2] https://bugs.kde.org/show_bug.cgi?id=194889#c10

affects: amarok (Ubuntu) → phonon-backends (Ubuntu)
Changed in phonon-backends (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Jonathan Thomas (echidnaman) wrote :

Already in 10.04

Changed in phonon-backends (Ubuntu):
status: Fix Committed → Fix Released
Changed in phonon:
status: Unknown → Fix Released
Changed in phonon:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.