amarok crashed with SIGSEGV in xine_get_autoplay_mrls() while playing audiocd

Bug #464656 reported by Zedd on 2009-10-30
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Phonon
Unknown
High
phonon-backends (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: amarok

Just playing an audio CD. While track-skipping from 5 to 6, Amarok crashed.
Amarok was playing in the background btw.

Regards,
- Joris

[ lsb_release -rd ]
Description: Ubuntu 9.10
Release: 9.10

[ apt-cache policy amarok ]
amarok:
  Installed: 2:2.2.0-0ubuntu2
  Candidate: 2:2.2.0-0ubuntu2
  Version table:
 *** 2:2.2.0-0ubuntu2 0
        500 http://ubuntuarchive.eweka.nl karmic/main Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
Architecture: i386
Date: Fri Oct 30 12:09:14 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/amarok
Package: amarok 2:2.2.0-0ubuntu2
ProcCmdline: /usr/bin/amarok
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SegvAnalysis:
 Segfault happened at: 0x5c5a985: mov %eax,0x80(%edx)
 PC (0x05c5a985) ok
 source "%eax" ok
 destination "0x80(%edx)" (0xab8ea088) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: amarok
StacktraceTop:
 ?? () from /usr/lib/xine/plugins/1.26/xineplug_inp_cdda.so
 xine_get_autoplay_mrls () from /usr/lib/libxine.so.1
 ?? ()
 ?? ()
 ?? ()
Title: amarok crashed with SIGSEGV in xine_get_autoplay_mrls()
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm cdrom dialout lpadmin plugdev sambashare
XsessionErrors: (polkit-gnome-authentication-agent-1:2739): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

Zedd (ubuntubugs-zedd) wrote :

StacktraceTop:cdda_class_get_autoplay_list (this_gen=0x93e23e8,
xine_get_autoplay_mrls (this=0x93d71e0,
Phonon::Xine::MediaObject::autoplayMrlsToTitles (
Phonon::Xine::MediaObject::setSourceInternal (
Phonon::Xine::MediaObject::setSource (this=0x9387e28,

Changed in amarok (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
affects: amarok (Ubuntu) → phonon-backends (Ubuntu)
visibility: private → public
Changed in phonon-backends (Ubuntu):
importance: Medium → Low
status: New → Triaged
Changed in phonon:
status: Unknown → Confirmed
Changed in phonon:
status: Confirmed → Unknown
Changed in phonon:
status: Unknown → Confirmed
Changed in phonon:
importance: Unknown → High
Changed in phonon:
status: Confirmed → Unknown
Jonathan Thomas (echidnaman) wrote :

Upstream has deprecated the Xine backend, so this won't be fixed.

Changed in phonon-backends (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.