phonon-backend-gstreamer seems to have issues playing from http

Bug #918688 reported by Jonas Obrist on 2012-01-19
42
This bug affects 10 people
Affects Status Importance Assigned to Milestone
phonon-backend-gstreamer (Ubuntu)
Medium
Harald Sitter
Precise
Medium
Harald Sitter
Quantal
Medium
Harald Sitter
Raring
Medium
Harald Sitter

Bug Description

[Impact]
Whenever an application that uses Phonon also uses a webkit that uses gstreamer, webkit will install its own webkit based http source. This source is then expoed to Phonon which tries to set a user-agent on it, which is not supported and the webkit source decides that it does not want to work when someone tries to do that. As a result http streaming is broken in any such setup.
https://bugs.kde.org/show_bug.cgi?id=310763

[Test Case]
* Install tomahawk and phonon-backend-gstreamer 4.6.2
* Activate a couple of http resolvers (e.g. soundcloud and youtube)
* Search for random tracks and try to play ones coming from resolvers
* Obesrve that streaming does not work a lot of times (not always).

[Regression Potential]
The proposed fix disables user-agent setting if the source has no user-agent property, so there is no regression potential as there would not be a phonon user-agent set at any rate.

-- Original Report ----------------------------------
I was trying to use tomahawk from https://launchpad.net/~tomahawk/+archive/ppa using phonon and phonon-backend-gstreamer. Unfortunately that didn't work with the audio sources in tomahawk that are streamed over HTTP. According to users in the tomahawk IRC channel this issue is in phonon-backend-gstreamer, as the phonon-backend-vlc works fine.

muesli (muesli) wrote :

I should also note, that it works fine with gstreamer's backend on other distributions, Mint and Arch come to mind.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in phonon-backend-gstreamer (Ubuntu):
status: New → Confirmed
vootey (vootey) wrote :

Comment #1 is not true for me. I use gentoo (kde-4.9.1 phonon-4.6.0 phonon-gstreamer 4.6.2) and streaming music doesn't work for me either (while it works with local files or the phonon-vlc-backend).

Changed in phonon-backend-gstreamer (Ubuntu Quantal):
status: New → Confirmed
Changed in phonon-backend-gstreamer (Ubuntu Precise):
status: New → Confirmed
Changed in phonon-backend-gstreamer (Ubuntu Raring):
status: Confirmed → Fix Committed
Changed in phonon-backend-gstreamer (Ubuntu Quantal):
status: Confirmed → In Progress
Changed in phonon-backend-gstreamer (Ubuntu Precise):
status: Confirmed → Triaged
Changed in phonon-backend-gstreamer (Ubuntu Quantal):
status: In Progress → Triaged
Changed in phonon-backend-gstreamer (Ubuntu Precise):
importance: Undecided → Medium
Changed in phonon-backend-gstreamer (Ubuntu Quantal):
importance: Undecided → Medium
Changed in phonon-backend-gstreamer (Ubuntu Raring):
importance: Undecided → Medium
assignee: nobody → Harald Sitter (apachelogger)
Changed in phonon-backend-gstreamer (Ubuntu Quantal):
assignee: nobody → Harald Sitter (apachelogger)
Changed in phonon-backend-gstreamer (Ubuntu Precise):
assignee: nobody → Harald Sitter (apachelogger)
description: updated
Changed in phonon-backend-gstreamer (Ubuntu Raring):
status: Fix Committed → Fix Released
Changed in phonon-backend-gstreamer (Ubuntu Quantal):
status: Triaged → In Progress
Changed in phonon-backend-gstreamer (Ubuntu Precise):
status: Triaged → In Progress

Hello Jonas, or anyone else affected,

Accepted into quantal-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in phonon-backend-gstreamer (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
affects: phonon-backend-gstreamer (Ubuntu Precise) → openshot (Ubuntu Precise)
Andy Finch (fincha) wrote :

openshot doesn't use phonon or gstreamer, so not sure why it's been set as being affected by this bug.

Scott Kitterman (kitterman) wrote :

Because someone changed it that shouldn't have. Fixing.

affects: openshot (Ubuntu Precise) → phonon-backend-gstreamer (Ubuntu Precise)
lordievader (oliviervdtoorn) wrote :

Tested the proposed version, it doesn't fix the bug. Tomahawk cannot play things from Soundcloud.

tags: added: verification-failed
removed: verification-needed
Harald Sitter (apachelogger) wrote :

As discussed on IRC the testing was not based on .3

tags: added: verification-needed
removed: verification-failed
Steve Langasek (vorlon) wrote :

This SRU has remained unverified after 239 days in the -proposed queue. I've removed it now from quantal-proposed and am marking the task 'wontfix'.

Changed in phonon-backend-gstreamer (Ubuntu Quantal):
status: Fix Committed → Won't Fix
Rolf Leggewie (r0lf) on 2014-03-06
Changed in phonon-backend-gstreamer (Ubuntu Precise):
status: In Progress → Won't Fix

The fix for this bug has been awaiting testing feedback in the -proposed repository for precise for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers