phonon-backend-gstreamer version 4:4.7.0really4.5.1-1ubuntu2 failed to build on armel

Bug #841450 reported by Ricardo Salveti on 2011-09-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
phonon-backend-gstreamer (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

phonon-backend-gstreamer version 4:4.7.0really4.5.1-1ubuntu2 failed to build on armel
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110819/+build/2728575

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110819/+build/2728575/+files/buildlog_ubuntu-oneiric-armel.phonon-backend-gstreamer_4%3A4.7.0really4.5.1-1ubuntu2_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 888 lines into the build log:

Call Stack (most recent call first):
  /usr/share/phonon-buildsystem/FindQt4.cmake:1430 (FIND_PACKAGE)
  /usr/share/phonon-buildsystem/FindPhononInternal.cmake:167 (find_package)
  cmake/FindPhonon.cmake:42 (find_package)
  CMakeLists.txt:7 (find_package)

-- Configuring incomplete, errors occurred!
dh_auto_configure: cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Debian -DCMAKE_USE_RELATIVE_PATHS=ON -DPLUGIN_INSTALL_DIR=/usr/lib/qt4/ returned exit code 1
make[2]: *** [override_dh_auto_configure] Error 2
make[2]: Leaving directory `/build/buildd/phonon-backend-gstreamer-4.7.0really4.5.1'
make[1]: *** [pre_configure_dh_auto_configure] Error 2
make[1]: Leaving directory `/build/buildd/phonon-backend-gstreamer-4.7.0really4.5.1'
make: *** [debian/dhmk_configure] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110827-0807
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/phonon-backend-gstreamer-4.7.0really4.5.1

Ricardo Salveti (rsalveti) wrote :

Logs:
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.7.3 (using /usr/bin/qmake)
CMake Error at /usr/share/cmake-2.8/Modules/FindX11.cmake:381 (MESSAGE):
  Could not find X11
Call Stack (most recent call first):
  /usr/share/phonon-buildsystem/FindQt4.cmake:1430 (FIND_PACKAGE)
  /usr/share/phonon-buildsystem/FindPhononInternal.cmake:167 (find_package)
  cmake/FindPhonon.cmake:42 (find_package)
  CMakeLists.txt:7 (find_package)

Probably a side effect of removing libqt4-opengl for armel.

Changed in phonon-backend-gstreamer (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phonon-backend-gstreamer - 4:4.7.0really4.5.1-1ubuntu3

---------------
phonon-backend-gstreamer (4:4.7.0really4.5.1-1ubuntu3) oneiric; urgency=low

  * Build-depend on libx11-dev since it isn't pulled in on armel. (LP: #841450)
 -- Felix Geyer <email address hidden> Wed, 14 Sep 2011 08:45:52 +0200

Changed in phonon-backend-gstreamer (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers