metadata emission broken for web streams

Bug #1028890 reported by Harald Sitter on 2012-07-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Phonon
Fix Released
Medium
phonon-backend-gstreamer (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Harald Sitter

Bug Description

SRU
-----

[Impact]
Every Phonon based application that allows the user to stream HTTP urls gets bogus metadata information from Phonon.

[Test Case]
* Play http://tuner.classical102.com/ in Amarok
* Observe bogus metadata displayed

[Regression Potential]
* none, there was special handling code removed that would artificially create the bogus metadata for streams, so at worst there would be no meta data which is not that far from the current fake "Streaming Data" info.

------

Phonon gstreamer reports metadata "Streaming Data" for every thing when streaming from shoutcast for example.

Version: 2.4.0 (using KDE 4.6.2)
OS: Linux

after upgrading from kubuntu 10.10 to 11.04 amarok no longer displays song info. where before title, artist and album were displayed now the words "Streaming Data" appear s for all three entries. if lyrics are available they are not displayed. Wikipedia is not functional as well.

Reproducible: Always

Steps to Reproduce:
restart amarok, reboot, searched for updates.

Actual Results:
same results

Expected Results:
it should perform properly as it did before upgrades

Shoutcast Streams is a 3rd-party script, please report this to the script author on http://www.kde-apps.org

Trying out 2.4.1 on Ubuntu Natty. Bug is still there and it is extremely annoying...

Please see comment #1, there is nothing we can do about that, please report this to the script author.

This bug is not related to the Shoutcast script. Amarok behaves as described also if you add a stream to the playlist, for example the following one:
http://tuner.classical102.com:80
It's rather connected to the GStreamer Phonon backend, because if you use the VLC backend, all comes back working.

Albert,

Excellent! Thank you so much. I installed the vlc backend and
uninstalled the gstreamer backend and now I have my song title and
artist names.

Thanks again,
Robert

On 5/20/2011 6:12 AM, albert wrote:
> https://bugs.kde.org/show_bug.cgi?id=272243
>
>
> albert<email address hidden> changed:
>
> What |Removed |Added
> ----------------------------------------------------------------------------
> CC| |<email address hidden>
>
>
>
>
> --- Comment #4 from albert<alberthilbert gmail com> 2011-05-20 13:11:32 ---
> This bug is not related to the Shoutcast script. Amarok behaves as described
> also if you add a stream to the playlist, for example the following one:
> http://tuner.classical102.com:80
> It's rather connected to the GStreamer Phonon backend, because if you use the
> VLC backend, all comes back working.
>

Good to know, reassigning to Phonon-backend-gstreamer then

*** Bug 276236 has been marked as a duplicate of this bug. ***

Think you can test this with the latest pgst 4.5.90? Lots of things were fixed in that release.

Forgot to update status, pardon the noise.

*** Bug 272929 has been marked as a duplicate of this bug. ***

*** This bug has been confirmed by popular vote. ***

I am now running Fedora 15, Gnome 3. Nothing has changed with Amarok, I
still have to use the vlc backend to get song titles and wikipedia info,
etc. How do I get the latest pgst 4.5.90 in order to test it? Thanks for
your help, Robert Rogers.

On 9/19/2011 7:32 AM, Trever Fischer wrote:
> https://bugs.kde.org/show_bug.cgi?id=272243
>
>
> Trever Fischer<email address hidden> changed:
>
> What |Removed |Added
> ----------------------------------------------------------------------------
> CC| |<email address hidden>
>
>
>
>
> --- Comment #8 from Trever Fischer<tdfischer fedoraproject org> 2011-09-19 12:32:54 ---
> Think you can test this with the latest pgst 4.5.90? Lots of things were fixed
> in that release.
>

Hey Trever,

This bug is not fixed in GIT and there is a patch waiting for your review. https://git.reviewboard.kde.org/r/101595/.

*** Bug 285448 has been marked as a duplicate of this bug. ***

Reminder: could some of you test with the latest Phonon-backend-gstreamer master branch?

(In reply to comment #14)
> *** Bug 285448 has been marked as a duplicate of this bug. ***

To not that my problem is a little different:
I DO get the info, those are just overwritten if I try to play the stream while offline.
Not sure the two issues are related.

Tested in Amarok Version 2.4.3 using KDE 4.6.5 on an HP G60 laptop
running Fedora 15, Gnome 3. Switched from phonon vlc backend to phonon
gstreamer backend 4.5.1. When playing Shoutcast streams song title is
displayed as "Streaming Data" or "New Age World", artist is displayed as
"http://www.skyfm/newage/", album displayed as "New Age-SKY.FM-soothing
sounds of new age and world music!". Equalizer is enabled when using the
gstreamer backend. Switching back to vlc backend shows song title and
artist correctly but does not support the equalizer. I hope that this is
helpful.

Thank you, Robert Rogers

On 11/2/2011 4:47 AM, Myriam Schweingruber wrote:
> https://bugs.kde.org/show_bug.cgi?id=272243
>
>
> Myriam Schweingruber<email address hidden> changed:
>
> What |Removed |Added
> ----------------------------------------------------------------------------
> Version|4.5.0 |4.5.1
>
>
>
>

Using amarok-2.6.0, phonon-4.6.0 and phonon-gstreamer-4.5.1 "Streaming Data" is still shown. Using another backend (like vlc) works but I would prefer gstreamer over vlc.

(In reply to comment #15)
> Reminder: could some of you test with the latest Phonon-backend-gstreamer
> master branch?

I just tried building from git sources but made no difference.

(In reply to comment #18)
> Using amarok-2.6.0, phonon-4.6.0 and phonon-gstreamer-4.5.1 "Streaming Data" is
> still shown. Using another backend (like vlc) works but I would prefer
> gstreamer over vlc.

There is no such thing as Amarok 2.6.0, I guess you mean 2.5, right?

(In reply to comment #20)
> (In reply to comment #18)
> > Using amarok-2.6.0, phonon-4.6.0 and phonon-gstreamer-4.5.1 "Streaming Data" is
> > still shown. Using another backend (like vlc) works but I would prefer
> > gstreamer over vlc.
>
> There is no such thing as Amarok 2.6.0, I guess you mean 2.5, right?

Yes, sorry about that, 2.5

To people who can try out GIT version of phonon-gstreamer, can you try this patch and see if you get the song info.
https://git.reviewboard.kde.org/r/101595/

If the patch works can you post here or on the review board. I am just trying to get the developers to fix this bug, but the patch has been ignored for more than 5 months now.

On Gentoo
media-libs/phonon-gstreamer-4.6.0 and
media-libs/phonon-4.6.0-r1
fix the issue.

The older (and stable) versions were buggy: phonon-gstreamer-4.5.0 and phonon-4.5.1-r1

I was too quick. That's NOT correct. The data appears at the first run of amarok, and is never updated.

(In reply to comment #23)
> On Gentoo
> media-libs/phonon-gstreamer-4.6.0 and
> media-libs/phonon-4.6.0-r1
> fix the issue.
>
> The older (and stable) versions were buggy: phonon-gstreamer-4.5.0 and
> phonon-4.5.1-r1

By applying the patch at https://git.reviewboard.kde.org/r/101595/ against 4.6.0, the data is updated at every song change.

Phonon-Xine removed because it's not maintained, if something with phonon-gstreamer is not working forcing them to use phonon-vlc... PLEASE PUSH THIS WORKING SOLUTION TO THE SOURCES! Thanks!

Setting status correctly.

Git commit c83093b7b57e3427878de12db905471e6b63cc6f by Trever Fischer, on behalf of Elbin Pallimalil.
Committed on 16/05/2012 at 19:54.
Pushed by tdfischer into branch 'master'.

Fix metadata emission for http urls.

REVIEWBOARD:101595
FIXED-IN:4.6.1

M +11 -10 gstreamer/pipeline.cpp
M +1 -0 gstreamer/pipeline.h

http://commits.kde.org/phonon-gstreamer/c83093b7b57e3427878de12db905471e6b63cc6f

Installed svn version on my gentoo box, seems to be working now. Thanks! :-)

Git commit ef4fc39dda56e7c37353771657ddee451f469eb1 by Trever Fischer, on behalf of Elbin Pallimalil.
Committed on 16/05/2012 at 19:54.
Pushed by tdfischer into branch '4.6'.

Fix metadata emission for http urls.

REVIEWBOARD:101595
FIXED-IN:4.6.1

Conflicts:

 gstreamer/pipeline.cpp

M +11 -5 gstreamer/pipeline.cpp
M +1 -0 gstreamer/pipeline.h

http://commits.kde.org/phonon-gstreamer/ef4fc39dda56e7c37353771657ddee451f469eb1

Changed in phonon-backend-gstreamer (Ubuntu Precise):
assignee: nobody → Harald Sitter (apachelogger)
Changed in phonon:
importance: Unknown → Medium
status: Unknown → Fix Released

Hello Harald, or anyone else affected,

Accepted into precise-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in phonon-backend-gstreamer (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Harald Sitter (apachelogger) wrote :

Outlined test case works.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phonon-backend-gstreamer - 4:4.7.0really4.6.2-0ubuntu0.1

---------------
phonon-backend-gstreamer (4:4.7.0really4.6.2-0ubuntu0.1) precise-proposed; urgency=low

  * SRU update (LP: #1028903)
    - Fix deadlock in aboutToFinish (LP: #1005262)
    - Fix crash on null pointer (LP: #1028887)
    - Fix metadata emission for http urls (LP: #1028890)
    - Fix memleaks (LP: #1028895)
    - Fix streamreader/AbstractMediaStream implementation (LP: #1028901)
 -- Harald Sitter <email address hidden> Wed, 25 Jul 2012 15:04:21 +0200

Changed in phonon-backend-gstreamer (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.