shisen-sho takes several seconds to register click on tiles

Bug #1005262 reported by wychwood on 2012-05-27
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
phonon-backend-gstreamer (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Harald Sitter

Bug Description

SRU
-----

[Impact]
Every Phonon enabled application (which is about any KDE application with sound) deadlocks on short audio tracks until a waitcondition inside phonon gstreamer times out. This particularly applies to games.

[Test Case]
* install ktuberling
* start it
* click on any item more than once within less than 3 seconds
* observe lock-ups

[Regression Potential]
* none

------

Since upgrading to 12.04, shisen-sho has become almost unplayably slow. If I click on a tile to select it, it takes two or three seconds for the game to register it; the in-game timer freezes while this happens. If I click on one tile and then a valid pair for it, it typically takes at least six seconds for the tiles to select, match, and disappear. An entire game on the easiest settings will usually take ten minutes or more, but be registered in-game as lasting two or three minutes.

Menus and toolbar options do not appear to be slowed down, and function as expected.

I am running Xubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: kshisen 4:4.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Sun May 27 20:49:57 2012
ExecutablePath: /usr/games/kshisen
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: kdegames
UpgradeStatus: Upgraded to precise on 2012-04-27 (30 days ago)

wychwood (wychwood) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdegames (Ubuntu):
status: New → Confirmed
Bob Wiegand (bob-stuffofmine) wrote :

Unchecking "Play Sounds" sems to fix it. Other people have reported the same thing.

affects: kdegames (Ubuntu) → phonon-backend-gstreamer (Ubuntu)
wychwood (wychwood) wrote :

Bob - that works for me; thanks.

Harald Sitter (apachelogger) wrote :

Fixed in 12.10 as per 4.6.1 update.

description: updated
Changed in phonon-backend-gstreamer (Ubuntu):
status: Confirmed → Fix Committed
Harald Sitter (apachelogger) wrote :
Harald Sitter (apachelogger) wrote :
Changed in phonon-backend-gstreamer (Ubuntu Precise):
assignee: nobody → Harald Sitter (apachelogger)
Changed in phonon-backend-gstreamer (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in phonon-backend-gstreamer (Ubuntu Precise):
status: New → Confirmed

Hello wychwood, or anyone else affected,

Accepted into precise-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in phonon-backend-gstreamer (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Harald Sitter (apachelogger) wrote :

Works with shisen and ktuberling now.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phonon-backend-gstreamer - 4:4.7.0really4.6.2-0ubuntu0.1

---------------
phonon-backend-gstreamer (4:4.7.0really4.6.2-0ubuntu0.1) precise-proposed; urgency=low

  * SRU update (LP: #1028903)
    - Fix deadlock in aboutToFinish (LP: #1005262)
    - Fix crash on null pointer (LP: #1028887)
    - Fix metadata emission for http urls (LP: #1028890)
    - Fix memleaks (LP: #1028895)
    - Fix streamreader/AbstractMediaStream implementation (LP: #1028901)
 -- Harald Sitter <email address hidden> Wed, 25 Jul 2012 15:04:21 +0200

Changed in phonon-backend-gstreamer (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers