Memory remains allocated when run from Nautilus

Bug #450693 reported by Vancouverite on 2009-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Phatch
Critical
Stani
phatch (Ubuntu)
Undecided
Stani

Bug Description

Binary package hint: phatch

Hi Phatch developers and users,
I have been using Phatch for about a year and think that it is the best tool for many of my photo needs, however, I currently have a problem. I'm running Phatch 0.2.2 and there seems to be a memory release issue. Here's the story:

I selected 13 jpg files in Nautilus, used "open with", and clicked Phatch. Back in 0.1 this didn't do anything, but with the improvements that have been made it actually opened a window to allow me to select the filter that I want. I selected resize, and viola! It resized them. It must have used the parameters that I had set last time that I ran resize from the console mode because it didn't give me any options and put the modified photos into that folder, resized to the same resolution. That was last night... Now when I look at "ps aux|grep phatch", I see:

USER@computer:~$ ps aux|grep phatch
USER 14003 0.0 15.2 874260 591740 ? S Oct12 0:21 /usr/bin/python /usr/bin/phatch [/file list]

It's now Oct13 22:06 and Phatch still has 15.2% of my memory tied up. I'm running Jaunty 64bit with 4 GB ram, so that is something like 500 MB+.

Any ideas? I haven't killed the process, and haven't shut down the computer in case there is something that I can do to provide debug info.

Thanks for the great program and active development.

Van

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/phatch
InterpreterPath: /usr/bin/python2.6
Package: phatch 0.2.2-0ubuntu1~9.04~ppa1
PackageArchitecture: all
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: phatch
Uname: Linux 2.6.28-14-generic x86_64
UnreportableReason: This is not a genuine Ubuntu package

Vancouverite (sethgilchrist) wrote :
Stani (stani) wrote :

I can't reproduce it. Can you do it again? After processing there should appear a dialog which reports the time spend on the proces. Maybe you forgot to press ok there?

Do you run Phatch from my PPA or in Ubuntu Karmic?

Changed in phatch (Ubuntu):
assignee: nobody → stani (stani)
status: New → Incomplete
Stani (stani) wrote :

@Vancouverite:

If possible react *now*, otherwise this can't be fixed before Ubuntu Karmic is released.

Thanks in advance!

Vancouverite (sethgilchrist) wrote :

Stani,
After some trial I was able to reliably reproduce the problem.

If I have focus on any other window (like the source or destination Nautilus windows or System Monitor) when the action list finishes execution, no "Ready!" dialog is produced and the memory is retained. This is very repeatable.

If focus is on the "Executing Action List" progress window when it finishes, the dialog is produced and closing it in any way will release the memory.

If I have one instance of changing focus when it finishes and no dialog is produced, then all subsequent actions fail to produce "Ready!" dialogs and my memory leaks until the system freezes. This can be rest by killing all instances of Phatch from the terminal.

Hopefully you can reproduce this. Note: I have now updated Phatch to 0.2.3, and the above behavior is in that release.

Cheers,
Vancouverite

Stani (stani) wrote :

Thanks a lot for your bug report. I can reproduce the error and to me it seems a pretty serious bug. I'll try to fix this as soon as possible and hopefully it is still possible to push it into Karmic.

Changed in phatch (Ubuntu):
status: Incomplete → In Progress
Changed in phatch:
assignee: nobody → stani (stani)
importance: Undecided → Critical
milestone: none → 0.2.4
status: New → In Progress
Stani (stani) on 2009-10-15
Changed in phatch:
status: In Progress → Fix Committed
Stani (stani) wrote :

The fix has been released to my PPA and will be available soon (in probably 10 minutes). Please test as quick as possible!

Changed in phatch:
status: Fix Committed → Fix Released
Vancouverite (sethgilchrist) wrote :

Hi stani,
This fix checks out for me! Thanks.

Also, I like the use of the Ubuntu bubbles notifications. Nice addition.

-Van

Stani (stani) wrote :

The bubble notification of course only appears if phatch is not the active application. It is a bit late, so I can't promise this fix will get in Karmic. Let's hope. Feel free to subscribe and to confirm this bug fix is important when necessary:
https://bugs.launchpad.net/ubuntu/+source/phatch/+bug/452430

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phatch - 0.2.4-1

---------------
phatch (0.2.4-1) unstable; urgency=low

  * Upstream bugfix release (Closes LP: #450693, #449404, #452261,
    #448993)

  * debian/control: added for phatch: Replaces: phatch-cli (<= 0.2.3-2)
    to fix file overwrite errors (LP: #450800)

 -- stani <email address hidden> Mon, 19 Oct 2009 15:24:58 +0100

Changed in phatch (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers