phablet-config writable-image spews lots of 'error: device offline' messages - but still seems to work

Bug #1369504 reported by Brendan Donegan on 2014-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
phablet-tools (Ubuntu)
Medium
Oliver Grawert

Bug Description

Running phablet-config writable image on the latest RTM image, it reboots the device, then spews a lot of 'error: device offline' messages until it's finished rebooting. After it is, then it seems to be writable so it looks like it worked in the end.

current build number: 40
device name: krillin
channel: ubuntu-touch/ubuntu-rtm/14.09-proposed
last update: 2014-09-15 10:10:07
version version: 40
version ubuntu: 20140915
version device: 20140908-d8c11f3
version custom: 1410739265

Related branches

description: updated
Oliver Grawert (ogra) wrote :

i belive there is a fix in devel-proposed (which did not make it into teh krillin or mako images due to a system-image server breakage and are supposed to enter rtm today ... please re-test once lxc-android-config 0.203 and android-tools-adbd 4.2.2+git20130218-3ubuntu35 are in the images)

Changed in phablet-tools (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Oliver Grawert (ogra) wrote :

researching more, there was an adb reboot call missing ... fix pending

Changed in phablet-tools (Ubuntu):
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phablet-tools - 1.1+14.10.20140916-0ubuntu1

---------------
phablet-tools (1.1+14.10.20140916-0ubuntu1) utopic; urgency=low

  [ Oliver Grawert ]
  * add proper adb.reboot() call to phablet-config writable-image, if we
    wait for the upstart shutdwon adb wait-for-device returns to early.
    (LP: #1369504) (LP: #1369504)
 -- Ubuntu daily release <email address hidden> Tue, 16 Sep 2014 12:55:06 +0000

Changed in phablet-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers