phablet-shell replaces authorized_keys

Bug #1326805 reported by Michał Sawicz
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
phablet-tools (Ubuntu)
Undecided
Michał Sawicz

Bug Description

phablet-shell seems to replace ~/.ssh/authorized_keys on the phone, without checking whether it's necessary at all.

I have my "private" (private as in my own, not private as in key pair) key set up on my devices, and phablet-shell needlessly touches stuff there (and for some reason selects my work ssh key with that...), causing me being unable to ssh in.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: phablet-tools 1.0+14.10.20140528.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.15.0-5.10-generic 3.15.0-rc8
Uname: Linux 3.15.0-5-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 2.14.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Jun 5 15:39:48 2014
PackageArchitecture: all
SourcePackage: phablet-tools
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Michał Sawicz (saviq) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in phablet-tools (Ubuntu):
status: New → Confirmed
Revision history for this message
Michał Sawicz (saviq) wrote :

Is this by design?

Michał Sawicz (saviq)
Changed in phablet-tools (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Michał Sawicz (saviq)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phablet-tools - 1.1+14.10.20140918-0ubuntu1

---------------
phablet-tools (1.1+14.10.20140918-0ubuntu1) utopic; urgency=low

  [ Oliver Grawert ]
  * 'phablet-shell: only start/stop ssh if it is not already running, do
    not wipe authorized_keys (breaks the SDK) and instead only append
    the key if it is not there yet. make sure ~/.ssh exists before
    trying to do anything with it (LP: #1355286) (LP: #1337289) (LP:
    #1326805) (LP: #1337289, #1326805, #1355286)

  [ nskaggs ]
  * Make phablet-test-run use only python3 and the autopilot3 binary.
    Fixes bug 1321463 and bug 1364369 (LP: #1364369, #1321463)
 -- Ubuntu daily release <email address hidden> Thu, 18 Sep 2014 11:52:02 +0000

Changed in phablet-tools (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers