package doc-base 0.10.3 failed to install/upgrade: ErrorMessage: /usr/bin/perl: symbol lookup error: /usr/lib/perl5/auto/UUID/UUID.so: undefined symbol: Perl_xs_apiversion_bootcheck

Bug #902553 reported by Martin Albisetti
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libuuid-perl (Debian)
Fix Released
Unknown
libuuid-perl (Ubuntu)
High
Martin Pitt
Precise
High
Martin Pitt
perl (Debian)
Fix Released
Unknown
perl (Ubuntu)
High
Martin Pitt
Precise
High
Martin Pitt

Bug Description

The package failed to upgrade from Oneiric to Precise.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: doc-base 0.10.3
ProcVersionSignature: Ubuntu 3.2.0-3.9-generic-pae 3.2.0-rc4
Uname: Linux 3.2.0-3-generic-pae i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Sat Dec 10 11:53:11 2011
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 127
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
SourcePackage: doc-base
Title: package doc-base 0.10.3 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 127
UpgradeStatus: Upgraded to precise on 2011-12-10 (0 days ago)

Revision history for this message
Martin Albisetti (beuno) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Here is what causes the error from the logs:
Processing triggers for doc-base ...
/usr/bin/perl: symbol lookup error: /usr/lib/perl5/auto/UUID/UUID.so: undefined symbol: Perl_xs_apiversion_bootcheck
dpkg: error processing doc-base (--unpack):
 subprocess installed post-installation script returned error exit status 127

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

According to bug 897880, this was fixed in perl 5.14.2-6 but this is the version you're system was upgrading to
Preparing to replace perl 5.12.4-4 (using .../perl_5.14.2-6_i386.deb) ...

Setting to triaged

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in doc-base (Ubuntu):
status: New → Confirmed
affects: doc-base (Ubuntu) → perl (Ubuntu)
Changed in perl (Ubuntu):
status: Confirmed → New
Changed in perl (Ubuntu Precise):
importance: Undecided → High
tags: added: rls-mgr-p-tracking
Changed in perl (Ubuntu Precise):
status: New → Triaged
summary: package doc-base 0.10.3 failed to install/upgrade: ErrorMessage:
- subprocess installed post-installation script returned error exit status
- 127
+ /usr/bin/perl: symbol lookup error: /usr/lib/perl5/auto/UUID/UUID.so:
+ undefined symbol: Perl_xs_apiversion_bootcheck
Martin Pitt (pitti)
Changed in perl (Ubuntu Precise):
assignee: nobody → Martin Pitt (pitti)
milestone: none → precise-alpha-2
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package perl - 5.14.2-6ubuntu1

---------------
perl (5.14.2-6ubuntu1) precise; urgency=low

  * debian/control: Add doc-base conflict also to perl, perl-modules, and
    libperl5.14. Otherwise they can get unpacked before upgrading perl-base
    and doc-base and thus still cause symbol lookup errors in the doc-base
    trigger. (Closes: #648954, LP: #902553)
 -- Martin Pitt <email address hidden> Fri, 16 Dec 2011 12:25:31 +0100

Changed in perl (Ubuntu Precise):
status: Triaged → Fix Released
Changed in perl (Debian):
status: Unknown → Fix Released
Changed in perl (Debian):
status: Fix Released → New
Martin Pitt (pitti)
Changed in libuuid-perl (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
milestone: none → precise-alpha-2
assignee: nobody → Martin Pitt (pitti)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libuuid-perl - 0.02-4ubuntu1

---------------
libuuid-perl (0.02-4ubuntu1) precise; urgency=low

  * debian/control: Conflict to doc-base << 0.10.3 to avoid package
    installation failure due to symbol lookup errors when perl 5.14 and
    libuuid-perl get unpacked and trigger the old doc-base.
    (LP: #902553, Closes: #652638)
 -- Martin Pitt <email address hidden> Mon, 19 Dec 2011 16:29:44 +0100

Changed in libuuid-perl (Ubuntu Precise):
status: In Progress → Fix Released
Changed in libuuid-perl (Debian):
status: Unknown → New
Changed in perl (Debian):
status: New → Fix Released
Changed in libuuid-perl (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.