CPAN version in lucid too old to use lib::local

Bug #843582 reported by jan on 2011-09-07
This bug affects 1 person
Affects Status Importance Assigned to Milestone
perl (Ubuntu)

Bug Description

I use Lucid with the packaged perl modules
Lucid-updates (5.10.1-8ubuntu2.1)
I'd like to add a cpan module for one user.
CPAN will want to override almost all modules from Ubuntu with newer versions; this is fortunately not allowed (no root privileges).

Fortunately, there exists a module lib::local to facilitate this
As of CPAN 1.9463, if you do not have permission to write the default perl library directories, CPAN's configuration process will ask you whether you want to bootstrap <local::lib>, which makes keeping a personal perl library directory easy.

Unfortunately, the cpan bundled in the latest lucid update is 1.9402
CPAN 1.9402 1.9800 ANDK/CPAN-1.9800.tar.gz

Is it possible to use a newer CPAN (>= 1.9463) in a forthcoming update ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers