perl 5.10 is broken & prevents the installation of many packages

Bug #521604 reported by stumpy on 2010-02-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
perl (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: perl

When I try to install Frozen-bubble 1.0.0-6

I get a dependency is not satisfied requires perlapi 5.8.7 (I have 5.10) perl 5.10 canot read perl scripts for 5.8.7 - no backwards compatibility therefore I cannot install & play...

then I install Frozen-bubble 2.2.0

it installs but when I attempt to run it I get this:

[[ Frozen-Bubble-2.2.0 ]]

  http://www.frozen-bubble.org/

  Copyright (c) 2000-2008 The Frozen-Bubble Team.

    Artwork: Alexis Younes
             Amaury Amblard-Ladurantie
    Soundtrack: Matthias Le Bidan
    Design & Programming: Guillaume Cottenceau
    Level Editor: Kim and David Joham
    Additional network programming: Mark Glines

  Originally sponsored by Mandriva <http://www.mandriva.com/>

  This program is free software; you can redistribute it and/or modify
  it under the terms of the GNU General Public License version 2, as
  published by the Free Software Foundation.

[SDL Init]

Warning: Program '/usr/bin/perl' crashed.

I assume this happens for the very same reason as although it's installed it then realises when you try to run it it can't run the perl script as it's incompatible, there needs to either be an option to downgrade perl or the perl script in frozen bubble needs to be updated in order to play, I need a fix please.

Mike Doherty (doherty) wrote :

Actually, backward compatibility does (should) exist. Can you please show the script which fails to run?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers