Confusing conflicts with CPAN and core perl

Bug #394481 reported by Evan Carroll on 2009-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libio-compress-zlib-perl (Ubuntu)
Undecided
Unassigned
perl (Debian)
Fix Released
Unknown
perl (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libio-compress-zlib-perl

Firstly, this same file is provided in two packages, perl, and libcompress-raw-zlib-perl

root@rda:/srv/DM/DM-Model# apt-file search Compress/Raw/Zlib.pm
libcompress-raw-zlib-perl: /usr/lib/perl5/Compress/Raw/Zlib.pm
perl: /usr/lib/perl/5.10.0/Compress/Raw/Zlib.pm

Ironically, if you use CPANPLUS to upgrade Compress::Raw::Zlib, it will dump over the perl file, this is because of an upstream bug I filed earlier with the way CPANPLUS is packaged in debian. Unlike CPAN, CPANPLUS is not yet configured properly by Debian. An upgrade to a core module will override any existing module packaged by perl. As if this wasn't bad enough, that module that was overriden will sit lower in the @INC stream.

So CPANPLUS will override a base-perl module with no means of brining it back, and perl won't be able to find it anyway because the perl module installed by libcompress-raw-zlib-perl will override it.

libcompress-raw-zlib-perl: /usr/lib/perl5/Compress/Raw/Zlib.pm
(version 2.011)
perl: /usr/lib/perl/5.10.0/Compress/Raw/Zlib.pm
(version 2.020)

Evan Carroll (evancarroll) wrote :
Changed in perl (Debian):
status: Unknown → Confirmed
Changed in perl (Debian):
status: Confirmed → Fix Released
Evan Carroll (evancarroll) wrote :

There is an non-issue very similar you can get if the distro updates these files to something newer than cpan. I had an old copy of Compress::Base::Common version (2.015) in /usr/local/lib/perl/5.10.0/IO/Compress/Base/Common.pm that I aparently installed (guessing here).

## A quick test to see if your affected by the issue
$ perl -MCompress::Zlib -e1
IO::Compress::Base::Common version 2.02 required--this is only version 2.015 at t line 11.
BEGIN failed--compilation aborted at /usr/share/perl5/Compress/Zlib.pm line 11.
Compilation failed in require.
BEGIN failed--compilation aborted.

Deleting /usr/local/lib/perl/5.10.0/IO/Compress/Base/Common.pm fixed this like-issue. (not the same one but it can return similar errors)

Evan Carroll (evancarroll) wrote :

If that above non-error happens just
rm -rf /usr/local/lib/perl/5.10.0/IO /usr/local/lib/perl/5.10.0/Compress

You will /have/ to do this if you upgrade to karmic and you have a version less than 2.020 installed on the time you upgrade.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.