Ubuntu

cpan lacks readline support, YAML, and asks questions before starting

Reported by mättu on 2009-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
perl (Ubuntu)
Undecided
Unassigned

Bug Description

When starting cpan (installing perl modules) on a fresh debian lenny system, I immedieately get a shell with read-line support enabled.
On ubuntu ("any" version, it seems), I have to answer many questions and install read-line support manually.
It seems that cpan preconfiguration from debian got lost somewhere on the way from debian to ubuntu.

affects: ubuntu → perl (Ubuntu)
Mike Doherty (doherty) wrote :

Please note that the default install also lacks YAML (or better yet, YAML::XS), and readline support (`sudo apt-get install libreadline-dev && sudo cpan Term::ReadLine::Gnu` or something). These should obviously Just Work without the user lifting a finger.

summary: - cpan asks questions before starting
+ cpan lacks readline support, YAML, and asks questions before starting
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers