package perl 5.14.2-6ubuntu2.2 failed to install/upgrade: ErrorMessage: »./usr/lib/perl/5.14.2/auto/mro« (was gerade installiert werden sollte) konnte nicht mit stat abgefragt werden: Eingabe-/Ausgabefehler

Bug #1159279 reported by Frank Hohmann on 2013-03-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
perl (Ubuntu)
Undecided
Unassigned

Bug Description

While trying to update and upgrade for patches, received the following error messages. Apparently similar to an earlier incident, but even the measures to resolved described. Did not know how to do the etc./apt/sources.list thing or what to do. I am a rookie with ubuntu.

startup under Recovery Mode (Wiederherstellungsmode dpk did not work) perl-base(=5.142-6ubuntu 2.3) but 5.142-6ubuntu 2.2 is already installed , apparently something with the dependencies...whatever this means.
I am a freshy, sudo apt-get update && sudo apt-get upgrade and afterwards sudo apt-get install - f did not work.

Package broken was the message. archive could also not be reinstalled. Somehow received a error message code (1).
I am a bit lost now

See messages below :

frank@frank-ThinkPad-X40:~$ sudo apt-get update && sudo apt-get upgrade
[sudo] password for frank:
Sorry, try again.
[sudo] password for frank:
Ign http://security.ubuntu.com precise-security InRelease
Ign http://archive.canonical.com precise InRelease
Ign http://de.archive.ubuntu.com precise InRelease
Ign http://extras.ubuntu.com precise InRelease
Ign http://de.archive.ubuntu.com precise-updates InRelease
OK http://security.ubuntu.com precise-security Release.gpg
OK http://archive.canonical.com precise Release.gpg
OK http://extras.ubuntu.com precise Release.gpg
OK http://de.archive.ubuntu.com precise Release.gpg
OK http://security.ubuntu.com precise-security Release
OK http://extras.ubuntu.com precise Release
OK http://archive.canonical.com precise Release
OK http://de.archive.ubuntu.com precise-updates Release.gpg
OK http://de.archive.ubuntu.com precise Release
OK http://de.archive.ubuntu.com precise-updates Release
OK http://security.ubuntu.com precise-security/main Sources
OK http://extras.ubuntu.com precise/main Sources
OK http://archive.canonical.com precise/partner i386 Packages
OK http://security.ubuntu.com precise-security/restricted Sources
OK http://security.ubuntu.com precise-security/universe Sources
OK http://security.ubuntu.com precise-security/multiverse Sources
OK http://security.ubuntu.com precise-security/main i386 Packages
OK http://security.ubuntu.com precise-security/restricted i386 Packages
OK http://security.ubuntu.com precise-security/universe i386 Packages
OK http://security.ubuntu.com precise-security/multiverse i386 Packages
OK http://security.ubuntu.com precise-security/main TranslationIndex
OK http://de.archive.ubuntu.com precise/main Sources
OK http://security.ubuntu.com precise-security/multiverse TranslationIndex
OK http://security.ubuntu.com precise-security/restricted TranslationIndex
OK http://extras.ubuntu.com precise/main i386 Packages
Ign http://extras.ubuntu.com precise/main TranslationIndex
Ign http://archive.canonical.com precise/partner TranslationIndex
OK http://security.ubuntu.com precise-security/universe TranslationIndex
OK http://de.archive.ubuntu.com precise/restricted Sources
OK http://de.archive.ubuntu.com precise/universe Sources
OK http://de.archive.ubuntu.com precise/multiverse Sources
OK http://de.archive.ubuntu.com precise/main i386 Packages
OK http://de.archive.ubuntu.com precise/restricted i386 Packages
OK http://de.archive.ubuntu.com precise/universe i386 Packages
OK http://de.archive.ubuntu.com precise/multiverse i386 Packages
OK http://de.archive.ubuntu.com precise/main TranslationIndex
OK http://de.archive.ubuntu.com precise/multiverse TranslationIndex
OK http://security.ubuntu.com precise-security/main Translation-en
OK http://security.ubuntu.com precise-security/multiverse Translation-en
OK http://de.archive.ubuntu.com precise/restricted TranslationIndex
OK http://de.archive.ubuntu.com precise/universe TranslationIndex
OK http://de.archive.ubuntu.com precise-updates/main Sources
OK http://de.archive.ubuntu.com precise-updates/restricted Sources
OK http://de.archive.ubuntu.com precise-updates/universe Sources
OK http://de.archive.ubuntu.com precise-updates/multiverse Sources
OK http://security.ubuntu.com precise-security/restricted Translation-en
OK http://de.archive.ubuntu.com precise-updates/main i386 Packages
OK http://de.archive.ubuntu.com precise-updates/restricted i386 Packages
OK http://de.archive.ubuntu.com precise-updates/universe i386 Packages
OK http://de.archive.ubuntu.com precise-updates/multiverse i386 Packages
OK http://de.archive.ubuntu.com precise-updates/main TranslationIndex
OK http://de.archive.ubuntu.com precise-updates/multiverse TranslationIndex
OK http://de.archive.ubuntu.com precise-updates/restricted TranslationIndex
OK http://de.archive.ubuntu.com precise-updates/universe TranslationIndex
OK http://de.archive.ubuntu.com precise/main Translation-de
OK http://security.ubuntu.com precise-security/universe Translation-en
OK http://de.archive.ubuntu.com precise/main Translation-en
OK http://de.archive.ubuntu.com precise/multiverse Translation-de
OK http://de.archive.ubuntu.com precise/multiverse Translation-en
OK http://de.archive.ubuntu.com precise/restricted Translation-de
OK http://de.archive.ubuntu.com precise/restricted Translation-en
OK http://de.archive.ubuntu.com precise/universe Translation-de
OK http://de.archive.ubuntu.com precise/universe Translation-en
OK http://de.archive.ubuntu.com precise-updates/main Translation-de
OK http://de.archive.ubuntu.com precise-updates/main Translation-en
OK http://de.archive.ubuntu.com precise-updates/multiverse Translation-de
OK http://de.archive.ubuntu.com precise-updates/multiverse Translation-en
OK http://de.archive.ubuntu.com precise-updates/restricted Translation-de
OK http://de.archive.ubuntu.com precise-updates/restricted Translation-en
OK http://de.archive.ubuntu.com precise-updates/universe Translation-de
OK http://de.archive.ubuntu.com precise-updates/universe Translation-en
Ign http://extras.ubuntu.com precise/main Translation-de_DE
Ign http://archive.canonical.com precise/partner Translation-de_DE
Ign http://extras.ubuntu.com precise/main Translation-de
Ign http://archive.canonical.com precise/partner Translation-de
Ign http://extras.ubuntu.com precise/main Translation-en
Ign http://archive.canonical.com precise/partner Translation-en
Paketlisten werden gelesen... Fertig
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libperl5.14 : Hängt ab von: perl-base (= 5.14.2-6ubuntu2.3) aber 5.14.2-6ubuntu2.2 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
frank@frank-ThinkPad-X40:~$ sudo apt- get install-f
sudo: apt-: Befehl nicht gefunden
frank@frank-ThinkPad-X40:~$ apt-get -f install
E: Sperrdatei /var/lib/dpkg/lock konnte nicht geöffnet werden - open (13: Keine Berechtigung)
E: Sperren des Administrationsverzeichnisses (/var/lib/dpkg/) nicht möglich, sind Sie root?
frank@frank-ThinkPad-X40:~$ y
y: Befehl nicht gefunden.
frank@frank-ThinkPad-X40:~$ sudo apt-get öf install
E: Ungültige Operation öf
frank@frank-ThinkPad-X40:~$ sudo apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Abhängigkeiten werden korrigiert... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  linux-headers-3.2.0-26-generic kde-l10n-de language-pack-kde-de
  language-pack-kde-en linux-headers-3.2.0-26 language-pack-kde-en-base
  kde-l10n-engb language-pack-kde-de-base linux-headers-3.2.0-26-generic-pae
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  perl perl-base perl-modules
Vorgeschlagene Pakete:
  perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl
Die folgenden Pakete werden aktualisiert (Upgrade):
  perl perl-base perl-modules
3 aktualisiert, 0 neu installiert, 0 zu entfernen und 302 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 8.557 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? j
debconf: Perl may be unconfigured (Can't locate IO/File.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/share/perl/5.14/FileHandle.pm line 9.
Compilation failed in require at (eval 1) line 3.
BEGIN failed--compilation aborted at (eval 1) line 3.
) -- aborting
(Lese Datenbank ... 340321 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Ersetzen von perl 5.14.2-6ubuntu2.2 (durch .../perl_5.14.2-6ubuntu2.3_i386.deb) ...
Ersatz für perl wird entpackt ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/perl_5.14.2-6ubuntu2.3_i386.deb (--unpack):
 »./usr/lib/perl/5.14.2/auto/mro« (was gerade installiert werden sollte) konnte nicht mit stat abgefragt werden: Eingabe-/Ausgabefehler
dpkg-deb: Fehler: Unterprozess einfügen wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
Vorbereitung zum Ersetzen von perl-base 5.14.2-6ubuntu2.2 (durch .../perl-base_5.14.2-6ubuntu2.3_i386.deb) ...
Ersatz für perl-base wird entpackt ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/perl-base_5.14.2-6ubuntu2.3_i386.deb (--unpack):
 »./usr/lib/perl/5.14.2/Hash« (was gerade installiert werden sollte) konnte nicht mit stat abgefragt werden: Eingabe-/Ausgabefehler
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/perl_5.14.2-6ubuntu2.3_i386.deb
 /var/cache/apt/archives/perl-base_5.14.2-6ubuntu2.3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
frank@frank-ThinkPad-X40:~$ ^C
frank@frank-ThinkPad-X40:~$

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: perl 5.14.2-6ubuntu2.2
ProcVersionSignature: Ubuntu 3.2.0-34.53-generic 3.2.33
Uname: Linux 3.2.0-34-generic i686
ApportVersion: 2.0.1-0ubuntu15
Architecture: i386
Date: Sun Mar 24 02:39:41 2013
ErrorMessage: ErrorMessage: »./usr/lib/perl/5.14.2/auto/mro« (was gerade installiert werden sollte) konnte nicht mit stat abgefragt werden: Eingabe-/Ausgabefehler
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MarkForUpload: True
SourcePackage: perl
Title: package perl 5.14.2-6ubuntu2.2 failed to install/upgrade: ErrorMessage: »./usr/lib/perl/5.14.2/auto/mro« (was gerade installiert werden sollte) konnte nicht mit stat abgefragt werden: Eingabe-/Ausgabefehler
UpgradeStatus: No upgrade log present (probably fresh install)

Wiederherstellungsmodus Recovery modus did not work , cannot uninstall or deinstall other packages. Will tr to reinstall the entire OS fresh.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers