[SRU] apt purge/remove percona-xtradb-cluster-server-5.7 postrm fails

Bug #1771869 reported by Corey Bryant on 2018-05-17
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
percona-xtradb-cluster-5.7 (Ubuntu)
High
Unassigned
Bionic
High
Unassigned

Bug Description

[Impact]

Both of the following commands fail:

apt remove percona-xtradb-cluster-server-5.7
apt purge percona-xtradb-cluster-server-5.7

with:

Removing percona-xtradb-cluster-server-5.7 (5.7.20-29.24-0ubuntu2) ...
dpkg: error processing package percona-xtradb-cluster-server-5.7 (--remove):
 installed percona-xtradb-cluster-server-5.7 package post-removal script subprocess returned error exit status 1
Errors were encountered while processing:
 percona-xtradb-cluster-server-5.7
E: Sub-process /usr/bin/dpkg returned an error code (1)

The case statement in the postrm script has a 'purge)' case but no 'remove)' case. Therefore when called with the remove parameter (which occurs for both apt purge and apt remove), no match is found in the case statement, and the '*)' path is taken which calls 'exit 1'.

[Testcase]

apt remove/purge should be successful. See [Impact] section for failure that should no longer be encountered.

[Regression Potential]
Low. This just updates the postrm script to add a no-op 'remove' case.

summary: - apt purge/remove of percona-xtradb-cluster-server-5.7 postrm failure
+ apt purge/remove of percona-xtradb-cluster-server-5.7 postrm fails
summary: - apt purge/remove of percona-xtradb-cluster-server-5.7 postrm fails
+ [SRU] apt purge/remove of percona-xtradb-cluster-server-5.7 postrm fails
summary: - [SRU] apt purge/remove of percona-xtradb-cluster-server-5.7 postrm fails
+ [SRU] apt purge/remove percona-xtradb-cluster-server-5.7 postrm fails
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in percona-xtradb-cluster-5.7 (Ubuntu):
status: New → Confirmed
Changed in percona-xtradb-cluster-5.7 (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package percona-xtradb-cluster-5.7 - 5.7.20-29.24-0ubuntu3

---------------
percona-xtradb-cluster-5.7 (5.7.20-29.24-0ubuntu3) cosmic; urgency=medium

  * d/percona-xtradb-cluster-server-5.7.postrm: Add 'remove)' to case statment
    to prevent postrm failure when removing or purging package (LP: #1771869).
  * d/rules: Update based on previous renaming of d/bundle-boost.s to
    d/repack.sh.

 -- Corey Bryant <email address hidden> Thu, 17 May 2018 14:46:31 -0400

Changed in percona-xtradb-cluster-5.7 (Ubuntu):
status: Triaged → Fix Released
Changed in percona-xtradb-cluster-5.7 (Ubuntu Bionic):
importance: Undecided → High
status: New → Triaged
description: updated
description: updated
description: updated
Vincent Gerris (vgerris) wrote :

hi, when will the package be available ? I have the same issue :

dpkg: error processing package percona-xtradb-cluster-server-5.7 (--purge):
 installed percona-xtradb-cluster-server-5.7 package post-removal script subprocess returned error exit status 1
Processing triggers for man-db (2.8.3-2) ...
Errors were encountered while processing:
 percona-xtradb-cluster-server-5.7

I work around apt being stuck with:
sudo apt install --reinstall percona-xtradb-cluster-server-5.7

Corey Bryant (corey.bryant) wrote :

Hi Vincent,

It's just waiting on review by the SRU team and it's in queue for that at: https://launchpad.net/ubuntu/bionic/+queue?queue_state=1&queue_text=

Thanks,
Corey

Hello Corey, or anyone else affected,

Accepted percona-xtradb-cluster-5.7 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/percona-xtradb-cluster-5.7/5.7.20-29.24-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in percona-xtradb-cluster-5.7 (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
EvgeniyPatlan (evgeniy-patlan) wrote :

I wasn't able to enable proposed repo:
=======
Err:5 http://us.ports.ubuntu.com/ubuntu-ports bionic-proposed/main amd64 Packages
  404 Not Found [IP: 91.189.91.11 80]
Ign:7 http://us.ports.ubuntu.com/ubuntu-ports bionic-proposed/universe amd64 Packages
Fetched 242 kB in 2s (100 kB/s)
Reading package lists... Done
E: Failed to fetch http://us.ports.ubuntu.com/ubuntu-ports/dists/bionic-proposed/main/binary-amd64/Packages 404 Not Found [IP: 91.189.91.11 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
========

I have manually build package from sources provided on launchpad and tested it. Seems it works ok.

Download full text (3.2 KiB)

hi,

I tested the package by downloading and:
 - it upgrades the current version
 - is able to be removed : I guess that is the main factor
 - can be installed again
 - the database starts and is accessible

Seems like it works, thank you and I hope we see it in Release soon.

On Wed, Jun 6, 2018 at 4:39 PM, Robie Basak <email address hidden>
wrote:

> Hello Corey, or anyone else affected,
>
> Accepted percona-xtradb-cluster-5.7 into bionic-proposed. The package
> will build now and be available at https://launchpad.net/ubuntu/+source
> /percona-xtradb-cluster-5.7/5.7.20-29.24-0ubuntu2.1 in a few hours, and
> then in the -proposed repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
> to enable and use -proposed.Your feedback will aid us getting this
> update out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested and change the tag from
> verification-needed-bionic to verification-done-bionic. If it does not
> fix the bug for you, please add a comment stating that, and change the
> tag to verification-failed-bionic. In either case, details of your
> testing will help us make a better decision.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!
>
> ** Changed in: percona-xtradb-cluster-5.7 (Ubuntu Bionic)
> Status: Triaged => Fix Committed
>
> ** Tags added: verification-needed verification-needed-bionic
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1771869
>
> Title:
> [SRU] apt purge/remove percona-xtradb-cluster-server-5.7 postrm fails
>
> Status in percona-xtradb-cluster-5.7 package in Ubuntu:
> Fix Released
> Status in percona-xtradb-cluster-5.7 source package in Bionic:
> Fix Committed
>
> Bug description:
> [Impact]
>
> Both of the following commands fail:
>
> apt remove percona-xtradb-cluster-server-5.7
> apt purge percona-xtradb-cluster-server-5.7
>
> with:
>
> Removing percona-xtradb-cluster-server-5.7 (5.7.20-29.24-0ubuntu2) ...
> dpkg: error processing package percona-xtradb-cluster-server-5.7
> (--remove):
> installed percona-xtradb-cluster-server-5.7 package post-removal
> script subprocess returned error exit status 1
> Errors were encountered while processing:
> percona-xtradb-cluster-server-5.7
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> The case statement in the postrm script has a 'purge)' case but no
> 'remove)' case. Therefore when called with the remove parameter (which
> occurs for both apt purge and apt remove), no match is found in the
> case statement, and the '*)' path is taken which calls 'exit 1'.
>
> [Testcase]
>
> apt remove/purge should be successful. See [Impact] section for
> failure that should no longer be encountered.
>
> [Regression Potential]
> Low. This just updates the postrm script to add a no-op 'remove' case.
>
> To manage notifications about this bug...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers