update-pepperflashplugin-nonfree checks root incorrectly

Bug #1311936 reported by Ted Merrill on 2014-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pepperflashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 14.04 package pepperflashplugin-nonfree (version 1.3ubuntu1)
script /usr/sbin/update-pepperflashplugin-nonfree line 33 reads:
[ `whoami` = "root" ] || die_hard "must be root"
This is the wrong way to check for root permission.
It should read something like:
[ `id -u` = '0' ] || die_hard "must be root"

For security reasons, my root user account is not named "root". Almost all programs check for user id 0 but every now and then someone manages to get it wrong.
In this case, i cannot properly update package pepperflashplugin-nonfree except by hacking at the script.

Thanks to whoever will fix this...

-Ted Merrill

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pepperflashplugin-nonfree - 1.5ubuntu2

---------------
pepperflashplugin-nonfree (1.5ubuntu2) utopic; urgency=medium

  * Suggest chromium-browser instead of chromium, do not suggest
    hal (LP: #1273861).
  * Fix root permissions check (LP: #1311936).
 -- Dmitry Shachnev <email address hidden> Sun, 27 Jul 2014 09:47:05 +0400

Changed in pepperflashplugin-nonfree (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers