Suggested packages chromium and hal are not available

Bug #1273861 reported by glitsj16 on 2014-01-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pepperflashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

System information:

1) $ lsb_release -rd
     Description: Ubuntu Trusty Tahr (development branch)
     Release: 14.04

2) $ apt-cache policy pepperflashplugin-nonfree
     pepperflashplugin-nonfree:
     Installed: (none)
     Candidate: 1.3ubuntu1
     Version table:
        1.3ubuntu1 0
           500 http://archive.ubuntu.com/ubuntu/ trusty/multiverse amd64 Packages

Package pepperflashplugin-nonfree version 1.3ubuntu1 (trusty) suggests 2 packages that are not available in the trusty repositories as such. Output below shows 1) chromium and 2) hal as suggests:

$ apt-cache show pepperflashplugin-nonfree

Package: pepperflashplugin-nonfree
Priority: optional
Section: multiverse/web
Installed-Size: 65
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Bart Martens <email address hidden>
Architecture: amd64
Version: 1.3ubuntu1
Depends: debconf | debconf-2.0, wget, gnupg, libatk1.0-0, libcairo2, libfontconfig1, libfreetype6, libgcc1, libglib2.0-0, libgtk2.0-0 (>= 2.14), libnspr4, libnss3, libpango-1.0-0 | libpango1.0-0, libstdc++6, libx11-6, libxext6, libxt6, libcurl3-gnutls, binutils
Suggests: chromium, ttf-mscorefonts-installer, ttf-dejavu, ttf-xfree86-nonfree, hal
Conflicts: libflash-mozplugin
Filename: pool/multiverse/p/pepperflashplugin-nonfree/pepperflashplugin-nonfree_1.3ubuntu1_amd64.deb
Size: 10052
MD5sum: 99172937c43768b153fedcbb7cf36e26
SHA1: 60313ff75a9feb3adc02bcd2c5b5cac35ac824c3
SHA256: d9ccee6607dad3d7b1748ba0b1a9a1d5b71896eaa313d153796c1f708c07b923
Description-en: Pepper Flash Player - browser plugin
 This package will download Chrome from Google, and unpack it to make the
 included Pepper Flash Player available for use with Chromium. The end user
 license agreement is available at Google.
Description-md5: 308421c13180fc4cf682be0755dca66d
Homepage: http://wiki.debian.org/PepperFlashPlayer
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
---

Analysis:

For 1) chromium: it is likely an oversight that the chromium web browser users/ducumentation so often refers to as 'chromium' is in the Ubuntu repos as 'chromium-browser'. However, a user might confusingly get the below output when trying to install the suggested chromium package:

    $ sudo apt-get install chromium
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package chromium is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or is only available from another source
    However the following packages replace it:
    chromium-bsu

    E: Package 'chromium' has no installation candidate
    ---

    Installing chromium-bsu will work but leaves the user with an unrelated package installed...

For 2) hal we have a similar situation:

    $ sudo apt-get install hal
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package hal is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    hal-info

    E: Package 'hal' has no installation candidate
    ---

    Installing hal-info will work but leaves the user with an unrelated package installed...

A simple change to the pepperflashplugin-nonfree 'suggests' entree can correct both situations.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pepperflashplugin-nonfree (Ubuntu):
status: New → Confirmed
psl (slansky) wrote :

I guess package "chromium" is a mistake. Correct package name should be "chromium-browser"

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pepperflashplugin-nonfree - 1.5ubuntu2

---------------
pepperflashplugin-nonfree (1.5ubuntu2) utopic; urgency=medium

  * Suggest chromium-browser instead of chromium, do not suggest
    hal (LP: #1273861).
  * Fix root permissions check (LP: #1311936).
 -- Dmitry Shachnev <email address hidden> Sun, 27 Jul 2014 09:47:05 +0400

Changed in pepperflashplugin-nonfree (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers