PenguinTV segfaults with GtkWarning: gtk_window_resize: assertion `width > 0' failed

Bug #131958 reported by Eric Padman on 2007-08-12
28
Affects Status Importance Assigned to Milestone
firefox (Baltix)
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned
penguintv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: penguintv

Using version 3.0-0ubuntu1 on an up to date Gobuntu (Gutsy Gibbon).

Crashes as the GUI is loading.

$ PenguinTV
/bin/sh: /usr/bin/esd: not found
gecko proxy settings up to date
initializing mozilla in /usr/lib/firefox
/bin/sh: /usr/bin/esd: not found
/usr/lib/python2.5/site-packages/penguintv/MainWindow.py:301: GtkWarning: gtk_window_resize: assertion `width > 0' failed
  self.app_window.resize(w,h)
Segmentation fault (core dumped)

Justin M. Wray (wray-justin) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems. http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).

In addition please try to obtain the following:
1. backtrace (http://wiki.ubuntu.com/DebuggingProgramCrash)
2. strace (https://wiki.ubuntu.com/Strace)
3. valgrind (https://wiki.ubuntu.com/Valgrind)

This will all greatly help us in tracking down your problem.

Thanks,
Justin M. Wray

Changed in penguintv:
assignee: nobody → wray-justin
status: New → Incomplete
herbiehancock (hansds) wrote :

I also got this bug, just by installing PeguinTV from Adept Manager and run it in console like Justin did.
maybe this is a bug from PeguinTV and not from ubuntu.

Justin M. Wray (wray-justin) wrote :

herbiehancock, please review the following...

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems. http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).

In addition please try to obtain the following:
1. backtrace (http://wiki.ubuntu.com/DebuggingProgramCrash)
2. strace (https://wiki.ubuntu.com/Strace)
3. valgrind (https://wiki.ubuntu.com/Valgrind)

This will all greatly help us in tracking down your problem.

Thanks,
Justin M. Wray

Eric Padman (mentalnotes) wrote :

I ran PenguinTV from a terminal window. The GUI starts to load then it seqfaults. I've attached a screenshot.
When I try to use gdb with PenguinTV to get a backtrace gdb says "/usr/bin/PenguinTV": not in executable format: File format not recognized". I guess this is because PenguinTV is written in Python and so not a compiled program.

Eric Padman (mentalnotes) wrote :
Changed in penguintv:
assignee: wray-justin → nobody
status: Incomplete → Confirmed
Eric Padman (mentalnotes) wrote :
David Tomaschik (matir) wrote :

Running this (w/python) through gdb gave some interesting results (attached, irrelevant text snipped).

Looks like this might be a firefox bug? At least, FF should be checking for null.

David Tomaschik (matir) wrote :

Accidental change, sorry.

Changed in firefox:
status: New → Invalid
John Vivirito (gnomefreak) wrote :

Closing firefox task since i dont see anything in bug that relates it to a firefox bug.

Changed in firefox:
status: New → Invalid
Patrick Hetu (patrick-hetu) wrote :

The problem is that the penguintv gconf schema file wasn't install but even with the schema file it still crash after looking for the playlist

Shouldn't this be removed from the repositories for gutsy now?
Since it doesn't work _at all_ .. for _anybody_

I prefer Miro though, but completely broken apps shouldn't be in repositorty and add/remove.
They give people a bad experience. They might not try installing another application.

Vincen Collins (vincencollins) wrote :

I tried entering just some dummy values into line 301 of /usr/lib/python2.5/site-packages/penguintv/MainWindow.py to get past the resizing issue but then I got this error.

gecko proxy settings up to date
initializing mozilla in /usr/lib/firefox
no gstreamer player to get
Segmentation fault (core dumped)

Vincen Collins

Patrick Hetu (patrick-hetu) wrote :

The source of this bug come from the missing gconf schema file and this as been solve upstream. Maybe we should try to sync with the upstream code in cvs instead of the 3.0 release before we remove the package.

Eric Padman (mentalnotes) wrote :

I agree, the schema not being installed causes the GtkWarning.
I downloaded the schema from CVS and installed it with the following from setup.py from the original tarball - penguintv_3.0.orig.tar.gz

export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source) - Check
gconftool-2 --makefile-install-rule share/penguintv.schema

But the segfault seems to be caused by the bug here - https://bugs.launchpad.net/firefox/+bug/26436 which deals with gtkmozembed crashing with python.

I managed to work around this with the fix posted by plun in the bug comments https://bugs.launchpad.net/firefox/+bug/26436/comments/53.

$ export LD_LIBRARY_PATH=/usr/lib/firefox
$ export MOZILLA_FIVE_HOME=/usr/lib/firefox
$ PenguinTV

Christopher (captain-c) wrote :

EricPadman's work around has also worked for me.

Dave (zanthous) wrote :

Excuse me for my ignorance, but what is a schema, and where is CVS? Could someone provide a little more step by step guide for those of us who haven't been around the ubuntu world quite as long?

I'm having the same problem as above -

gecko proxy settings up to date
initializing mozilla in /usr/lib/firefox
/usr/lib/python2.5/site-packages/penguintv/MainWindow.py:301: GtkWarning: gtk_window_resize: assertion `width > 0' failed
  self.app_window.resize(w,h)
Segmentation fault (core dumped)

Vincen Collins (vincencollins) wrote :

Here is the schema file - http://penguintv.svn.sourceforge.net/viewvc/*checkout*/penguintv/trunk/share/penguintv.schema

The command below corrupted my gconf and theme

   export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
   gconftool-2 --makefile-install-rule share/penguintv.schema

I was able to restore my gconf and theme with the following command

   rm -rf .gnome .gnome2 .gconf .gconfd .metacity

I am going to try to go key by key with Gconf-editor to fix the gconf schema for penguin tv when I get home

Anke Kernbach (an-ke) wrote :

Thanks to plun and EricPadman.
...
$ export LD_LIBRARY_PATH=/usr/lib/firefox
$ export MOZILLA_FIVE_HOME=/usr/lib/firefox

works for me, too.

ubuntu_demon (ubuntu-demon) wrote :

I'm using Ubuntu Gutsy.

In my case this solution works :
https://bugs.launchpad.net/ubuntu/+source/penguintv/+bug/131958/comments/18

$ PenguinTV
gecko proxy settings up to date
initializing mozilla in /usr/lib/firefox
Segmentation fault (core dumped)

$ export LD_LIBRARY_PATH=/usr/lib/firefox
$ export MOZILLA_FIVE_HOME=/usr/lib/firefox

Now PenguinTV doesn't segfault anymore :

$ PenguinTV
gecko proxy settings up to date
initializing mozilla in /usr/lib/firefox
no gstreamer player to get

Dave (zanthous) wrote :

The solution worked for me too, mostly. I don't get the GTK warning anymore but now it seems to be segfaulting due to something else.

The output I get is...

$ PenguinTV
gecko proxy settings up to date
initializing mozilla in /usr/lib/firefox
initializing ajax server
error reading playlist
Segmentation fault (core dumped)

and the following fix that worked for the others doesn't work
$ export LD_LIBRARY_PATH=/usr/lib/firefox
$ export MOZILLA_FIVE_HOME=/usr/lib/firefox

Any ideas?

Eric Padman (mentalnotes) wrote :

Sorry if my suggestion about the schema file corrupted anyone's gconf database :( . Maybe a better idea would have been to suggest using the latest revision from before version 3.0 which is here: http://penguintv.svn.sourceforge.net/viewvc/*checkout*/penguintv/trunk/share/penguintv.schema?revision=292. 3.0 was released on the 30th of May 2007 and this version of the schema was released on the 13th of April 2007.

The current SVN has a fix for the segfault issue at https://penguintv.svn.sourceforge.net/svnroot/penguintv/trunk/postinst. This script confirms that the bug is the one at https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/26436. Could this please be reviewed and added to the current debian package?

Owen Williams (ywwg) wrote :

I would suggest rolling a new package based on version 3.65, which I've finally been able to upload. The postinst workaround is a hack, and is not the correct way of solving the problem. 3.65 uses a more robust method of correctly setting MOZILLA_FIVE_HOME.

Although 3.65 is tagged as "unstable," it's probably in better shape than 3.0 at this point. I'm planning to add just one more minor feature before I call it 4.0.

Dave (zanthous) wrote :

Owen you just made my day, possibly my life. Thank you so much, I hadn't been able to use PenguinTV for months and now I can. Compiled from the 3.65 tarball and it's running like a charm on Gutsy.

Dimitrios Symeonidis (azimout) wrote :

jaunty ships with 3.6.5-0ubuntu3, so I'm marking this as fix released.
please correct me if I'm wrong

Changed in penguintv (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers