pdns does not accept a "#" in the password.

Bug #31742 reported by HS-L on 2006-02-17
6
Affects Status Importance Assigned to Milestone
pdns (Ubuntu)
Medium
MOTU

Bug Description

I'm running dapper (flight3 cd) server install 64bit.
took me a while before i figured out the password was nog accepted.

got this error:
Feb 16 22:39:29 gmysql Connection failed: Unable to connect to database: Access denied for user 'pdns'@'localhost' (using password: YES)

thx.

Martijn vdS (martijn) wrote :

Isn't this a mysql bug?

Or does it work with the mysql tool?

HS-L (me-hs-l) wrote :

it works with the mysql tool.

I tried to do it with another mysql user with another password and that worked,
copied that user into a new one with the old password & tried it with a new password: login: pdns pass: pdns# and thatone also didn't work.

I flushed the user privileges, but that did not change anything.
after that i changed the password for user pdns and it works like a charm.

Carthik Sharma (carthik) on 2006-05-31
Changed in pdns:
assignee: nobody → motu
Martijn vdS (martijn) wrote :

Does this work yet?

Changed in pdns:
status: New → Incomplete
Daniel T Chen (crimsun) wrote :

Closing due to inactivity. Please reopen if reproducible in current 8.04 or 8.10 alpha.

Changed in pdns:
status: Incomplete → Invalid
Peter van Dijk (habbie) wrote :

Upstream bug is http://wiki.powerdns.com/trac/ticket/354. It has not been fixed yet.

Imre Gergely (cemc) wrote :

I guess we can mark this Confirmed then.

Changed in pdns (Ubuntu):
status: Invalid → Confirmed

 affects ubuntu/dapper/pdns

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers