[needs-packaging] pdftk missing in 18.04 (bionic) and later releases

Bug #1764450 reported by Felix Eckhofer on 2018-04-16
774
This bug affects 172 people
Affects Status Importance Assigned to Milestone
Pdftk
New
Undecided
Unassigned
pdftk (Ubuntu)
Wishlist
Unassigned
Bionic
Undecided
Unassigned

Bug Description

It seems that pdftk is no longer included in bionic. The package still is available in Debian sid and I did not find a hint why it was removed. Is this a bug?

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pdftk (Ubuntu):
status: New → Confirmed
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

I looked at the publishing history for this package (https://launchpad.net/ubuntu/+source/pdftk/+publishinghistory, available in the upper right corner on the overview page). Looks like it was removed from bionic due to bug 1757314. (There's a similar, release critical bug affecting the package in Debian, https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=892539)

Andrew Gee (ahg-e) wrote :

An effective workaround is to build Marc Vinyal's fork as described by David Foerster here
https://askubuntu.com/questions/1028522/how-can-i-install-pdftk-in-ubuntu-18-04-bionic-shell-version-no-gtk and then wrap the jar file into an executable called "pdftk" using the lovely trick described here https://coderwall.com/p/ssuaxa/how-to-make-a-jar-file-linux-executable. This works perfectly for me and could point the way to a maintainable way forward for pdftk under Ubuntu. Maybe somebody who understands packaging could create a deb with the right dependencies, and put it on a repository somewhere?

summary: - pdftk missing in bionic
+ pdftk missing in 18.04 (bionic)

Quick and easy workaround:

  wget http://archive.ubuntu.com/ubuntu/pool/universe/p/pdftk/pdftk_2.02-4build1_amd64.deb
  wget http://archive.ubuntu.com/ubuntu/pool/main/g/gcc-6/libgcj17_6.4.0-8ubuntu1_amd64.deb
  wget http://archive.ubuntu.com/ubuntu/pool/main/g/gcc-defaults/libgcj-common_6.4-3ubuntu1_all.deb
  sudo dpkg -i pdftk_2.02-4build1_amd64.deb libgcj17_6.4.0-8ubuntu1_amd64.deb libgcj-common_6.4-3ubuntu1_all.deb

Seems to work fine for now.

Victor Forberger (vforberger) wrote :

I have posted about this issue and the current possible solutions here and elsewhere at https://linuxatty.wordpress.com/2018/05/04/xubuntu-18-04-bionic-beaver-released/.

Felix's workaround works fine for me, even though it's a temporary solution, of course.
Thanks!
Michael

Cefn (6-launchpad-net-cefn-com) wrote :

I also needed to add

sudo apt install gcc-6-base

and after this, Felix' workaround was effective.

Rodrigo (crabbly) wrote :

Felix's workaround worked.
Thank you.

Tobias Frei (tobefree) wrote :

Confirmed: Bug & Felix' workaround (thank you!)

rloth (romain-loth) wrote :

See also the removal action from 18.04 here: https://bugs.launchpad.net/ubuntu/+source/pdftk/+bug/1757314

You can find more solution on https://askubuntu.com/questions/1028522/how-can-i-install-pdftk-in-ubuntu-18-04-bionic

User pgoetz's solution is ,in my opinion, the cleanest one: just

  sudo snap install pdftk-smoser

and then alias the pdftk-smoser.pdftk command to pdftk.

gene_wood (gene.wood) wrote :

To extend what @6-launchpad-net-cefn-com mentioned in Comment #7 I had to not only install gcc-6-base but also python. I ran

sudo apt install gcc-6-base libpython-stdlib python python-minimal python2.7 python2.7-minimal

before installing the packages @eckhofer listed in Comment #4

Sworddragon (sworddragon) wrote :

It seems nobody has contacted upstream so far and asked to fix this issue so I did this now and will see what happens. I guess the alternative would be just to wait until a fork makes it into the repositories or just to switch to another application that does a similar job.

Scott Moser (smoser) wrote :

I did request the pdftk namespace, so now you do not need pdftk-smoser, but just:

    snap install pdftk

Feel free to file issues at https://github.com/smoser/pdftk/tree/snap/snap

Johann Felix Soden (johfel) wrote :

There is pdftk-java ( https://launchpad.net/ubuntu/+source/pdftk-java ). It is an port of pdftk to pure java, therefore does no longer depend on gcj. The package provides a "pdftk" binary and is planned to be the replacement of the pdftk package. The package from cosmic should be backwards-compatible to 18.04.

summary: - pdftk missing in 18.04 (bionic)
+ pdftk missing in 18.04 (bionic) and later releases

@scott moser thanks a lot for the snap! This tool is really missing in the normal repository :/

tags: added: needs-packaging
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - pdftk missing in 18.04 (bionic) and later releases
+ [needs-packaging] pdftk missing in 18.04 (bionic) and later releases
Changed in pdftk (Ubuntu):
importance: Undecided → Wishlist
Johann Felix Soden (johfel) wrote :

Ubuntu Disco has now (again) pdftk 2.02-5 [1] as a pure transition package to pdftk-java [2].

pdftk-java is also already available in Ubuntu cosmic [3].

Therefore, I would consider this bug as done/won't-fix.

[1] https://bugs.launchpad.net/ubuntu/+source/pdftk/2.02-5
[2] https://bugs.launchpad.net/ubuntu/+source/pdftk-java/3.0.2-2
[3] https://bugs.launchpad.net/ubuntu/+source/pdftk-java/0.0.0+20180723.1-1

Ibrahim Awwal (ibrahim-awwal) wrote :

Is it possible to backport the fixed version (pdftk-java) to Bionic? If people are on the LTS release, having it available in Cosmic or Disco does not really help. It seems like it's possible to just install the Cosmic package on 18.04 but it'd be nice to not have to go that route. Thanks!

Johann Felix Soden (johfel) wrote :

Thanks for your suggestion to backport pdftk-java, Ibrahim Awwal. Please follow the procedure described on [1].

[1] https://wiki.ubuntu.com/UbuntuBackports

Dylan Aïssi (daissi) on 2019-05-15
Changed in pdftk (Ubuntu):
status: Confirmed → Fix Released

On 15/5/19 6:34 pm, Dylan Aïssi wrote:
> ** Also affects: pdftk (Ubuntu Bionic)
> Importance: Undecided
> Status: New
>
> ** Changed in: pdftk (Ubuntu)
> Status: Confirmed => Fix Released

Thanks, Dylan

I installed the pdftk package from the disco 19.04 repository and ran
one of my "stock" scripts against a pdf. It worked perfectly. This
doesn't constitute a full system test, but satisfies me.

Given the bug was for the package being missing, rather than any
specific broken behaviour when installed, I reckon you can close it as
fixed.

Regards,

Brian

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pdftk (Ubuntu Bionic):
status: New → Confirmed
HRJ (harshad-rj) wrote :

Just FYI, the issue for backporting of pdftk-java to bionic has been reported here:

https://bugs.launchpad.net/ubuntu/+source/pdftk-java/+bug/1818356

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.