java.lang.ClassNotFoundException: org.bouncycastle.jce.provider.BouncyCastleProvider (missing dependency)

Bug #173208 reported by Simone F. on 2007-12-01
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pdftk (Ubuntu)
Undecided
Unassigned

Bug Description

pdftk in Gutsy has missing dependencies; invoking it without installing them prints errors like:

WARNING: Error loading security provider org.bouncycastle.jce.provider.BouncyCastleProvider: java.lang.ClassNotFoundException: org.bouncycastle.jce.provider.BouncyCastleProvider not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
WARNING: Error loading security provider gnu.crypto.jce.GnuCrypto: java.lang.ClassNotFoundException: gnu.crypto.jce.GnuCrypto not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}

After installing these two packages it stopped complaining:

sudo apt-get install libgnucrypto-java libbcprov-java

Simone F. (fittabile) on 2007-12-01
description: updated
description: updated
Maxilian Bernöcker (ffeddekka) wrote :

It fails for me, too:

max@schleptop:/tmp/a$ pdftk 1.pdf 2.pdf cat output a.pdf
WARNING: Error loading security provider org.bouncycastle.jce.provider.BouncyCastleProvider: java.lang.ClassNotFoundException: org.bouncycastle.jce.provider.BouncyCastleProvider not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
WARNING: Error loading security provider gnu.crypto.jce.GnuCrypto: java.lang.ClassNotFoundException: gnu.crypto.jce.GnuCrypto not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
max@schleptop:/tmp/a$

Max

description: updated
Dennis Dirdjaja (dcd-ditsch) wrote :

I can confirm this, too.

Changed in pdftk:
status: New → Confirmed
Matt C (mvc1095) wrote :

I got the same error message as above, so I tried installing libgnucrypto-java and libbcprov-java. Now pdftk aborts with the following message:

libgcj failure: gcj linkage error.
Incorrect library ABI version detected. Aborting.

fowie (fowdawgg) wrote :

Using Intrepid on Intel x86, I was able to get around this by uninstalling libgcj9-0 and it's accompanying dependencies. Apparently pdftk uses libgcj8-1 and doesn't like 9-0.

Johann Felix Soden (johfel) wrote :

ClassNotFoundExceptions occurs if any java security package like libgnucrypto-java or libbcprov-java is removed but not purged. Then obsolete files in /etc/java/security/security.d remains which links to not available libraries. The java runtime, which is not aware of any package status, tries to load all in /etc/java/security/security.d listed libraries and produce then warnings for each unavailable library.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers