'%' symbol in filename causes error without user notice

Bug #1802394 reported by Andrew Conley on 2018-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pdfshuffler (Ubuntu)
Undecided
Unassigned

Bug Description

1)

Description: Ubuntu 18.04.1 LTS
Release: 18.04

2)

pdfshuffler:
  Installed: 0.6.0-8
  Candidate: 0.6.0-8
  Version table:
 *** 0.6.0-8 500
        500 http://ftp.iinet.net.au/pub/ubuntu bionic/universe amd64 Packages
        500 http://ftp.iinet.net.au/pub/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status

3)

A file that I wanted to import contained a '%' in the filename. I expected that if there was a problem with the filename that I would be given some useful report of that so that I could rectify it.

4)

When I tried to import the file, the open button did nothing, no notice was given (but the cancel and close window still worked).

Opening the program through terminal provided this:

x@y:~$ pdfshuffler
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py", line 604, in on_action_add_doc_activate
    self.add_pdf_pages(filename)
  File "/usr/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py", line 420, in add_pdf_pages
    pdfdoc = PDF_Doc(filename, self.nfile, self.tmp_dir)
  File "/usr/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py", line 1039, in __init__
    self.document = poppler.document_new_from_file (file_prefix + self.copyname, None)
glib.GError: The URI “file:///tmp/tmpUZil_8pdfshuffler/a%b.pdf” contains invalidly escaped characters

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers