PDFChain Segmentation Fault error on start

Bug #1685778 reported by florin on 2017-04-24
82
This bug affects 14 people
Affects Status Importance Assigned to Milestone
pdfchain (Debian)
Fix Released
Unknown
pdfchain (Ubuntu)
Medium
Unassigned

Bug Description

Error on starting pdfchain in Ubuntu 17.04 with error Segmentation fault (core dumped).

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: pdfchain 1:0.4.4.2-1
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
Uname: Linux 4.10.0-19-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
CurrentDesktop: Unity:Unity7
Date: Mon Apr 24 14:42:02 2017
SourcePackage: pdfchain
UpgradeStatus: No upgrade log present (probably fresh install)

florin (florin-arjocu) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pdfchain (Ubuntu):
status: New → Confirmed
Jacek Misiurewicz (jmisiure) wrote :

Maybe it helps:

Reading symbols from /usr/bin/pdfchain...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/pdfchain
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffea2ee700 (LWP 14109)]
[New Thread 0x7fffe9aed700 (LWP 14110)]
[New Thread 0x7fffe8ead700 (LWP 14111)]

PDF Chain 0.4.4.2 - A graphical user interface for the PDF Toolkit

[New Thread 0x7fffdb5a2700 (LWP 14113)]
[New Thread 0x7fffdada1700 (LWP 14114)]
[New Thread 0x7fffd95e8700 (LWP 14115)]
[New Thread 0x7fffd88f9700 (LWP 14117)]
[New Thread 0x7fffd2582700 (LWP 14118)]
[New Thread 0x7fffd1d81700 (LWP 14119)]

Thread 1 "pdfchain" received signal SIGSEGV, Segmentation fault.
0x00007ffff4adb360 in g_slist_find ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
(gdb) info stack
#0 0x00007ffff4adb360 in g_slist_find ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1 0x00007ffff5575a5b in gtk_radio_button_set_group ()
   from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#2 0x00007ffff79e3552 in Gtk::RadioButton::set_group(Gtk::RadioButtonGroup&)
    () from /usr/lib/x86_64-linux-gnu/libgtkmm-3.0.so.1
#3 0x00007ffff7a60447 in Gtk::RadioButtonGroup::add(Gtk::RadioButton&) ()
   from /usr/lib/x86_64-linux-gnu/libgtkmm-3.0.so.1
#4 0x00007ffff79e306a in Gtk::RadioButton::RadioButton(Gtk::RadioButtonGroup&, Glib::ustring const&, bool) () from /usr/lib/x86_64-linux-gnu/libgtkmm-3.0.so.1
#5 0x00005555555f86a2 in ?? ()
#6 0x000055555560bcc1 in ?? ()
#7 0x000055555560dd3a in ?? ()
#8 0x00005555555d492a in ?? ()
#9 0x00007ffff606e3f1 in __libc_start_main (main=0x5555555d4880, argc=1,
    argv=0x7fffffffdf18, init=<optimized out>, fini=<optimized out>,
    rtld_fini=<optimized out>, stack_end=0x7fffffffdf08)
    at ../csu/libc-start.c:291
#10 0x00005555555d49ba in ?? ()
(gdb)

Carlos Maddela (e7appew) wrote :

This is related to Debian Bug #725859, for which I have forwarded a patch. I have attached it here as well, in case you would like to release a fix before Debian does.

The attachment "fix_crash_on_startup.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
florin (florin-arjocu) wrote :

Is there something we can do on our devices to fix this until there is a general fix? Thanks!

Rolf Leggewie (r0lf) wrote :

https://launchpad.net/~wdaniau/+archive/ubuntu/custom/+packages has a fixed package with the patch applied.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pdfchain - 1:0.4.4.2-2

---------------
pdfchain (1:0.4.4.2-2) unstable; urgency=medium

  * Fix crash at startup. (Closes: #725859, LP: #1685778)
  * Set Vcs-* to salsa.debian.org.
  * Add pdftk-java as alternative dependency. (Closes: #946058)
  * Update year in copyright.
  * Remove MimeType from .desktop file (lintian warning).

 -- Johann Felix Soden <email address hidden> Wed, 15 Apr 2020 14:16:27 +0200

Changed in pdfchain (Ubuntu):
status: Confirmed → Fix Released
Mathew Hodson (mhodson) on 2020-05-02
Changed in pdfchain (Ubuntu):
importance: Undecided → Medium
Mathew Hodson (mhodson) on 2020-05-02
summary: - PDFChain Segmentation Fault error on start, Ubuntu 17.04
+ PDFChain Segmentation Fault error on start
Changed in pdfchain (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.