pdfarranger TypeError: only pages can be inserted

Bug #1926289 reported by Nizar Kerkeni on 2021-04-27
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pdfarranger (Ubuntu)
Undecided
Unassigned

Bug Description

Can not save an edited PDF file with pdfarranger

Error message :

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pdfarranger/pdfarranger.py", line 748, in choose_export_pdf_name
    self.save(only_selected, file_out)
  File "/usr/lib/python3/dist-packages/pdfarranger/pdfarranger.py", line 210, in wrapper
    func(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/pdfarranger/pdfarranger.py", line 796, in save
    exporter.export(self.pdfqueue, to_export, file_out, m)
  File "/usr/lib/python3/dist-packages/pdfarranger/exporter.py", line 78, in export
    pdf_output.pages.append(new_page)
TypeError: only pages can be inserted

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: pdfarranger 1.6.2-1
ProcVersionSignature: Ubuntu 5.11.0-16.17-generic 5.11.12
Uname: Linux 5.11.0-16-generic x86_64
ApportVersion: 2.20.11-0ubuntu65
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
Date: Tue Apr 27 12:37:37 2021
InstallationDate: Installed on 2019-09-27 (577 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
PackageArchitecture: all
SourcePackage: pdfarranger
UpgradeStatus: Upgraded to hirsute on 2021-04-21 (6 days ago)

Revision history for this message
Nizar Kerkeni (nizarus) wrote :
Revision history for this message
Nizar Kerkeni (nizarus) wrote :

Workaround :
I installed pdfarranger from this ppa : ppa:linuxuprising/apps
And the updated version (1.7.1-0~hirsute0) works fine.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pdfarranger (Ubuntu):
status: New → Confirmed
Revision history for this message
Tim Richardson (tim-richardson) wrote :

The flathub version is fixed too.
Please see upstream bug report
https://github.com/pdfarranger/pdfarranger/issues/478
which is closed as fixed in new release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.