pcsx assert failure: pcsx: ../libpcsxcore/ix86_64/ix86-64.c:158: MEMADDR_OP: Assertion `!isreg || reg != 0' failed.

Bug #1504834 reported by risyan on 2015-10-10
98
This bug affects 21 people
Affects Status Importance Assigned to Milestone
pcsxr (Debian)
Fix Released
Unknown
pcsxr (Ubuntu)
Medium
Unassigned

Bug Description

i cant open iso image

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: pcsxr 1.9.92-4
ProcVersionSignature: Ubuntu 4.2.0-15.18-generic 4.2.3
Uname: Linux 4.2.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.1-0ubuntu2
Architecture: amd64
AssertionMessage: pcsx: ../libpcsxcore/ix86_64/ix86-64.c:158: MEMADDR_OP: Assertion `!isreg || reg != 0' failed.
CrashCounter: 1
CurrentDesktop: GNOME
Date: Sun Oct 11 03:10:02 2015
ExecutablePath: /usr/games/pcsx
InstallationDate: Installed on 2015-10-09 (1 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150924)
ProcCmdline: pcsx
Signal: 6
SourcePackage: pcsxr
StacktraceTop:
 __assert_fail_base (fmt=0x7f8f3aebe028 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x55f044f2aba1 "!isreg || reg != 0", file=file@entry=0x55f044f2ab40 "../libpcsxcore/ix86_64/ix86-64.c", line=line@entry=158, function=function@entry=0x55f044f2abd0 "MEMADDR_OP") at assert.c:92
 __GI___assert_fail (assertion=0x55f044f2aba1 "!isreg || reg != 0", file=0x55f044f2ab40 "../libpcsxcore/ix86_64/ix86-64.c", line=158, function=0x55f044f2abd0 "MEMADDR_OP") at assert.c:101
 ?? ()
 ?? ()
 ?? ()
Title: pcsx assert failure: pcsx: ../libpcsxcore/ix86_64/ix86-64.c:158: MEMADDR_OP: Assertion `!isreg || reg != 0' failed.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

risyan (rrisyan) wrote :
information type: Private → Public

StacktraceTop:
 __assert_fail_base (fmt=0x7f8f3aebe028 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x55f044f2aba1 "!isreg || reg != 0", file=file@entry=0x55f044f2ab40 "../libpcsxcore/ix86_64/ix86-64.c", line=line@entry=158, function=function@entry=0x55f044f2abd0 <__PRETTY_FUNCTION__.8207> "MEMADDR_OP") at assert.c:92
 __GI___assert_fail (assertion=assertion@entry=0x55f044f2aba1 "!isreg || reg != 0", file=file@entry=0x55f044f2ab40 "../libpcsxcore/ix86_64/ix86-64.c", line=line@entry=158, function=function@entry=0x55f044f2abd0 <__PRETTY_FUNCTION__.8207> "MEMADDR_OP") at assert.c:101
 MEMADDR_OP (w=w@entry=false, opl=opl@entry=1, op=op@entry=43, isreg=isreg@entry=true, reg=reg@entry=0, p=<optimized out>, off=off@entry=0) at ../libpcsxcore/ix86_64/ix86-64.c:158
 SUB32MtoR (to=to@entry=0, from=<optimized out>) at ../libpcsxcore/ix86_64/ix86-64.c:1379
 recSUBU () at ../libpcsxcore/ix86_64/iR3000A-64.c:841

Changed in pcsxr (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pcsxr (Ubuntu):
status: New → Confirmed
Marcus Dean Adams (gerowen) wrote :

When running PCSX I cannot load ISOs or even real Playstation discs. I've tried changing between OpenGL and X11 graphics driver, as well as switching between the actual PSX BIOS and the "Simulated" BIOS that comes with PCSX. None of it makes a difference. Have ran these games on this hardware in older versions of Ubuntu and PCSX without issue.

PCSX Version: 1.9.92
OS: Ubuntu 15.10 64bit (amd64)

Terminal Output when trying to launch a game
RGB mode found. id: 18424752, depth: 24
pcsx: ../libpcsxcore/ix86_64/ix86-64.c:158: MEMADDR_OP: Assertion `!isreg || reg != 0' failed.
Aborted (core dumped)

Attached is a system summary generated by "hardinfo" in html format that lists all the dirty details of my system.

Brian Buchanan (nighthawk-uk) wrote :

Unsure if this should be on a separate bug report but here is my manual backtrace of PCSX.

Brian Buchanan (nighthawk-uk) wrote :

Here is my strace from the moment I try to open the Bin file which causes the crash.

Edwin Lee (leeed2001) wrote :

Same exact issue. Wiped my machine and put 15.10, now this won't run.

Tomi Hukkalainen (tpievila) wrote :

The Debian bug for this (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=795196) mentions a workaround:

"Upstream says that an appropriate workaround is to set Config.CPU = 1 in pcsx(r).cfg, which disables dynamic binary translation in favor of a pure interpreter."

Changed in pcsxr (Debian):
status: Unknown → Confirmed
Brian Buchanan (nighthawk-uk) wrote :

The workaround mentioned worked for me.

I edited '~/.pcsx/pcsx.cfg' and changed 'Cpu = 0' to 'Cpu = 1'
Now my games run again.

James Cowgill (jcowgill) on 2016-03-30
Changed in pcsxr (Ubuntu):
status: Confirmed → Fix Committed
Changed in pcsxr (Debian):
status: Confirmed → Fix Released
Mecanotox (aurelien-x) wrote :

"Brian Buchanan (nighthawk-uk) wrote on 2016-03-30: #12

The workaround mentioned worked for me.

I edited '~/.pcsx/pcsx.cfg' and changed 'Cpu = 0' to 'Cpu = 1'
Now my games run again.
"

This solution has resolved my issue.
My games also running again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pcsxr - 1.9.94-2

---------------
pcsxr (1.9.94-2) unstable; urgency=medium

  * Add patch to fix FTBFS on non-Linux architectures.
  * Add patch to remove use of __DATE__ to make the build reproducible.

 -- James Cowgill <email address hidden> Fri, 01 Apr 2016 23:07:11 +0100

Changed in pcsxr (Ubuntu):
status: Fix Committed → Fix Released

can you put the full path to the .cfg? i cant seem to find it anywhere.

Brian Buchanan (kehoroblade) wrote :

There should be a hidden folder called .pcsx in your home folder, the cfg file is in there.

/home/[USERNAME]/.pcsx

ctrl+H is a beautiful thing. thanks, fixed my issue as well.

aaronfranke (arnfranke) wrote :

The version of the package containing the problem is still in the Ubuntu 16.04 repos. pcsxr/xenial,now 1.9.92-4 amd64 [installed]

The workaround mentioned worked for me.

I edited '~/.pcsx/pcsx.cfg' and changed 'Cpu = 0' to 'Cpu = 1'
Now my games run again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.