[FFe] Please merge new upstream release 1.6.7-1 from Debian Unstable

Bug #723016 reported by Nicolas DERIVE on 2011-02-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ccid (Ubuntu)
High
Unassigned
Natty
High
Unassigned
pcsc-lite (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Thanks for merging new upstream to natty, as it's a new release which doesn't need to run as root (and has other enhancements upon the old one we have)

Related branches

Nicolas DERIVE (kalon33) on 2011-02-22
tags: added: merge
summary: - Please merge new upstream release 1.6.6-2 from debian Unstable
+ [merge] Please merge new upstream release 1.6.6-2 from debian Unstable
Nicolas DERIVE (kalon33) on 2011-03-06
summary: - [merge] Please merge new upstream release 1.6.6-2 from debian Unstable
+ [merge] Please merge new upstream release 1.6.7-1 from Debian Unstable
Nicolas DERIVE (kalon33) on 2011-03-06
description: updated
Nicolas DERIVE (kalon33) on 2011-03-06
summary: - [merge] Please merge new upstream release 1.6.7-1 from Debian Unstable
+ [FFe] Please merge new upstream release 1.6.7-1 from Debian Unstable
Nicolas DERIVE (kalon33) wrote :

Hello all,

I think this package should be synced because:

- It brings, together with new ccid (see LP: #723013) support for a lot of new stuff and recent hardware, including some currently involved in mass testing (test programs of electronic purses, for example in Bordeaux) and being not able to use them into Ubuntu leads users to use Win.

- It doesn't run as root anymore and runs on demand: better for security, and for computer load.

- It is today in natty under a really old version (which I think is important for developers): according to ChangeLog from source, the Natty version is from 24 June 2009.

Nicolas DERIVE (kalon33) wrote :
Nicolas DERIVE (kalon33) wrote :

Testing was done with USB PC/SC readers (Omnikey 5321 USB, Weneo SIM usb) and everything is fine.

Martin Pitt (pitti) wrote :

Doesn't change ABI, so that sounds okay for natty. Thanks for testing!

Changed in pcsc-lite (Ubuntu):
status: New → Confirmed
summary: - [FFe] Please merge new upstream release 1.6.7-1 from Debian Unstable
+ [FFe] Please sync new upstream release 1.6.7-1 from Debian Unstable

Could you please comment on the outstanding Ubuntu delta? Here's the most recent changelog entry:

pcsc-lite (1.5.5-4ubuntu1) natty; urgency=low

  * Merge from debian unstable. Remaining changes:
    - Move runtime libraries to /lib, for the benefit of wpasupplicant.
    - disable hal support. LP: #506908
    - add build-dep on libusb-dev, fixes FTBFS
  * debian/control: Drop libhal-dev build dependency, as we already configure
    with --disable-libhal. Using libusb instead.

 -- Martin Pitt <email address hidden> Thu, 27 Jan 2011 10:34:16 +0100

In particular, the most recent Debian version still has libpcsclite.so.1.0.0 in /usr/lib rather than /lib, and since wpa_supplicant is directly linked against it that means that WPA will be unusable until /usr is mounted, even if no smartcard is needed (we know that it won't be possible to do smartcard handling until /usr is mounted, but that isn't the whole story).

The HAL-related changes also need to be merged. pcsc-lite 1.6.7-1 still build-depends on libhal-dev.

So, nack from me - I think this needs to be a merge, not a sync. Unsubscribing ubuntu-archive.

Martin Pitt (pitti) on 2011-03-07
summary: - [FFe] Please sync new upstream release 1.6.7-1 from Debian Unstable
+ [FFe] Please merge new upstream release 1.6.7-1 from Debian Unstable

The Debian package of wpasupplicant will remove smart card support in a next version. See
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=612715#25

The next upstream of pcsc-lite will use libudev instead of libhal.

So it should "soon" be possible to sync instead of merge from the Debian package.

Nicolas DERIVE (kalon33) wrote :

@Colin: In the branch attached I keep the Ubuntu delta of disabling hal support, replacing it with b-d on libusb-1.0-0-dev, and it builds fine (see buildlog in my previous comment), thats why I was requesting a merge of my bzr branch.

Nicolas DERIVE (kalon33) wrote :

@pitti: Is it possible to review my branch for including? I made the job to replace hal b-d with libusb one.

Martin Pitt (pitti) wrote :

Subscribing sponsors.

Colin Watson (cjwatson) wrote :

Nicolas: yes, as it turned out I was mostly talking to Martin, since he'd mistakenly turned this into a sync request.

I've added some review comments to your branch.

Colin Watson (cjwatson) wrote :

Ludovic: thanks, this will be great.

Colin Watson (cjwatson) wrote :

Unsubscribing ubuntu-sponsors, since it's enough to have just one entry on the sponsoring list (for the branch).

Nicolas DERIVE (kalon33) wrote :

Please, someone to review my branch ?

Nicolas DERIVE (kalon33) wrote :

Re-subscribing ubuntu-sponsors, because I've no news from cjwatson for a while (he may be very busy, so maybe someone else could help?)

Maybe you should consider using version 1.7.0-2. This version now uses libudev instead of libhal. So the only remaining difference is the more of the libpcsclite.so.1 library from /usr/lib to /lib

Also note that wpasupplicant in Debian experimental now loads libpcsclite.so.1 dynamically when needed. So no need to move libpcsclite.so.1 in /lib anymore. With this change the Ubuntu package should just be the same as the Debian one.

Nicolas DERIVE (kalon33) wrote :

@ludovic: It's done in my branch merge-1.7.0-2... Thanks for noticing it :)

Nicolas DERIVE (kalon33) wrote :

new branch tested and working (with package listed as build reference), builds and pcscd works.

Martin Pitt (pitti) wrote :

I reviewed the new MP, but this needs fixing I'm afraid.

Nicolas DERIVE (kalon33) wrote :

@pitti: I will do this asap, maybe tonight, if not this week end. Could you look at my comment in my MP?

Thanks a lot.

Nicolas DERIVE (kalon33) wrote :

@pitti: I made the fixes you asked, could you look at it please?

Thanks a lot.

Launchpad Janitor (janitor) wrote :
Download full text (4.5 KiB)

This bug was fixed in the package pcsc-lite - 1.7.0-2ubuntu1

---------------
pcsc-lite (1.7.0-2ubuntu1) natty; urgency=low

  * Merge from Debian Unstable (FFe LP: #723016). Remaining changes:
  * debian/rules: Keep moving runtime libraries to /lib, for the benefit of
    wpasupplicant.

pcsc-lite (1.7.0-2) unstable; urgency=low

  * Fix "fails to install" add a Depends: adduser so that addgroup is
    available (Closes: #617698)

pcsc-lite (1.7.0-1) unstable; urgency=low

  * New upstream release
  * Fix "uses deprecated HAL" fixed upstream by using libudev instead
    (Closes: #587979)
  * Fix "please drop dependency on pcscd". libpcsclite1 now Recommends:
    instead of Depends: on pcscd (Closes: #612971)
  * debian/control: add a Build-Depends: pkg-config since we use it to detect
    the presence of libudev

pcsc-lite (1.6.7-1) unstable; urgency=low

  * New upstream release
  * Fix "missing dependency for libccid > 1.4" pcscd now depends on version
    >= 1.4.1~ of libccid. Previous versions of libccid do not have the udev
    rule file to set the device permissions so the reader is not usable with
    the pcscd when run as NON root (Closes: #613404)
  * Fix "missing dependecy for libpcsclite1 in fiting version" libpcsclite1
    now depends on the exact same version of pcscd instead of just conflicting
    with a previous version of pcscd (Closes: #613405)

pcsc-lite (1.6.6-2) unstable; urgency=low

  * upload to unstable
  * pcscd.dirs: remove usr/share/lintian/overrides since the override file was
    removed in 1.6.5-1

pcsc-lite (1.6.6-1) experimental; urgency=low

  * New upstream release
  * Fix "Regression: My card{,-reader} fails with 1.6.5-1" bug fixed upstream
    (Closes: #606121)
  * Fix "pcscd - Unneeded high privileges" pcscd is now running as a normal
    user in the pcscd group (Closes: #606142)
    See http://ludovicrousseau.blogspot.com/2010/09/pcscd-auto-start.html
    The driver package shall privide a udev rule file to set the correct
    permissions on the device. libccid does that.

pcsc-lite (1.6.5-1) experimental; urgency=low

  * New upstream release
  * debian/rules: do not install pcscd suid root
  * debian/pcscd.lintian-overrides: removed since no more lintian warnings
  * debian/pcscd.init: create $IPCDIR with correct access rights
  * debian/pcscd.postinst: create the pcscd group and setgid pcscd to it
  * debian/pcscd.README.Debian: remove outdated "pscsd starts before usbmgr"
    section and add "pscsd sgid pcscd" section

pcsc-lite (1.6.4-1) experimental; urgency=low

  * New upstream release
  * debian/rules: install pcscd suid root. This was broken in previous
    packages.
  * debian/control: remove Conflicts: libccid (<= 1.0.0-1)
    stable (lenny) already has libccid 1.3.8
    lintian complained that Breaks should be used instead

pcsc-lite (1.6.3-1) experimental; urgency=low

  * New upstream release

pcsc-lite (1.6.2-1) experimental; urgency=low

  * New upstream release
  * debian/rules: use the minimal dh rules
  * debian/control: Standards-Version: 3.8.4 -> 3.9.1. No change needed.
  * Fix "depends on pcscd which is priority: extra". The 3 packages are now
    priority "optional" (Closes: #5...

Read more...

Changed in pcsc-lite (Ubuntu):
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

pretty please check for component matches, before submitting and accepting FFe's

 o ccid: libccid
   [Reverse-Depends: pcscd]

Changed in ccid (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-1
status: New → Confirmed
Martin Pitt (pitti) wrote :

I think at that point we should rather drop libpcsclite1's recommends to pcscd to suggests:, as pcscd itself is (and has always been) in universe.

Martin Pitt (pitti) wrote :

pcsc-lite (1.7.0-2ubuntu2) natty; urgency=low

  * debian/control: Drop pcscd Recommends to Suggests:, as pcscd (and its
    dependencies) is in universe.

 -- Martin Pitt <email address hidden> Tue, 22 Mar 2011 20:09:23 +0100

Fabrice Coutadeur (fabricesp) wrote :

Hi,

As there is nothing to sponsor. Dropping Ubuntu Sponsors from Subscribers. If this is not the case, please subscribe them again.

thanks,
Fabrice

Colin Watson (cjwatson) wrote :

We no longer need the ccid task on this bug following Martin's change (comment 25).

Changed in ccid (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → none
status: Confirmed → Won't Fix
Changed in ccid (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.