patch in bug LP: #183498 is wrong

Bug #240195 reported by Ludovic Rousseau on 2008-06-15
2
Affects Status Importance Assigned to Milestone
pcsc-lite (Ubuntu)
Undecided
Unassigned

Bug Description

According to http://patches.ubuntu.com/p/pcsc-lite/pcsc-lite_1.4.101-2ubuntu1.patch you patch pcsc-lite to add:

diff -pruN 1.4.101-2/debian/pcscd.init 1.4.101-2ubuntu1/debian/pcscd.init
--- 1.4.101-2/debian/pcscd.init 2008-05-13 17:14:22.000000000 +0100
+++ 1.4.101-2ubuntu1/debian/pcscd.init 2008-05-13 17:12:43.000000000 +0100
@@ -27,6 +27,11 @@ DAEMON=/usr/sbin/$NAME
 PIDFILE=/var/run/pcscd/$NAME.pid
 SCRIPTNAME=/etc/init.d/$NAME

+# Check if /var/run/pcscd exists, if not, create it.
+if [ ! -d /var/run/pcscd/ ]; then
+ mkdir -p -m 0755 /var/run/pcscd/
+fi
+
 # if you need to pass arguments to pcscd you should edit the file
 # /etc/default/pcscd and add a line
 # DAEMON_ARGS="--your-option"

I confirm (as Debian maintainer of pcsc-lite and also upstream author) that this patch is useless.
You can remove the patch and directly use the Debian package.

Related branches

Nick Ellery (nick.ellery) wrote :

Thanks for your report

Changed in pcsc-lite:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pcsc-lite - 1.5.3-1ubuntu1

---------------
pcsc-lite (1.5.3-1ubuntu1) karmic; urgency=low

  * Resynchronise with Debian (LP: #378309). Remaining changes:
    - Move runtime libraries to /lib, for the benefit of wpasupplicant.
  * Drop /var/run/pcscd creation in init script; the daemon seems to take
    care of this itself and I can't reproduce the original problem that
    prompted this Ubuntu-specific change (LP: #240195).

pcsc-lite (1.5.3-1) unstable; urgency=low

  * New upstream release

pcsc-lite (1.5.2-2) unstable; urgency=low

  * debian/rules: use symbolic links instead of copy to update config.sub and
    config.guess as suggested in /usr/share/doc/autotools-dev/README.Debian.gz
    Tries to limit difference with the Ubuntu package
  * Standards-Version: 3.7.3 -> 3.8.1
   - add support of noopt and parallel options in DEB_BUILD_OPTIONS
   - resynch pcscd.init with /etc/init.d/skeleton

pcsc-lite (1.5.2-1) unstable; urgency=low

  * New upstream release
  * debian/pcscd.postinst: do not use an absolute path for update-reader.conf
    lintian warning: command-with-path-in-maintainer-script
  * debian/control: update Build-Depends: for debhelper
    lintian warning: debhelper-script-needs-versioned-build-depends dh_lintian
    (>= 6.0.7~)

 -- Colin Watson <email address hidden> Tue, 02 Jun 2009 16:58:01 +0100

Changed in pcsc-lite (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers