pscsd doesn't start anymore

Bug #183498 reported by Stephan Ruegamer on 2008-01-16
4
Affects Status Importance Assigned to Milestone
pcsc-lite (Ubuntu)
Undecided
Stephan Ruegamer

Bug Description

hi,

the pcscd daemon which is installed for working with smartcards doesn't start after the upgrade from the last version in hardy to the new version in hardy (last sync).
The reason is, that upstream changed the default ipcdir from /var/run to /var/run/pcscd/, but this directory doesn't exists during startup.

Please fix,

\sh

Related branches

Stephan Ruegamer (sadig) wrote :

will fix it

Changed in pcsc-lite:
assignee: nobody → shermann
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pcsc-lite - 1.4.99-1ubuntu1

---------------
pcsc-lite (1.4.99-1ubuntu1) hardy; urgency=low

  * debian/pcscd.init: (LP: #183498)
    - Check if /var/run/pcscd/ directory exists, if not
      create it.

 -- Stephan Hermann <email address hidden> Sat, 19 Jan 2008 11:58:34 +0100

Changed in pcsc-lite:
status: Confirmed → Fix Released

If the directory does not exist the pcscd daemon creates it automatically when started.

What is the error message if you start pcscd as "pcscd --debug --foreground" and /var/run/pcscd does not exist?

Colin Watson (cjwatson) wrote :

I can't reproduce any problem here on karmic without Stephan's init script change; I'm going to revert this change at the next sync/merge, rather than carrying it forward.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers