Please sync newest pcsc-lite 1.8.14-1 to Ubuntu Wily from Debian Unstable

Bug #1483750 reported by Nicolas DERIVE on 2015-08-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pcsc-lite (Ubuntu)
Undecided
Unassigned

Bug Description

We currently have a one year old version of pcsc-lite in archive whereas 3 new versions have been uploaded to Debian Unstable since then.

This package is pretty easy to sync with only a small change in debian/rules kept, to allow its use by wpasupplicant.

Test build of ready-to-upload package is here: https://launchpad.net/~kalon33/+archive/ubuntu/rfid/+sourcepub/5293788/+listing-archive-extra

Thanks for syncing :)

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: pcscd 1.8.11-3ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-3.3-generic 4.2.0-rc5
Uname: Linux 4.2.0-3-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.2
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Aug 11 15:32:22 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-03-30 (134 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150317.1)
SourcePackage: pcsc-lite
UpgradeStatus: No upgrade log present (probably fresh install)

Nicolas DERIVE (kalon33) wrote :
summary: - Please sync newest pcsc-lite 1.8.14-1 to Ubuntu Wily
+ Please sync newest pcsc-lite 1.8.14-1 to Ubuntu Wily from Debian
+ Unstable
Nicolas DERIVE (kalon33) wrote :

Here is the debdiff to perform the sync of the package with Debian Unstable, keeping our changes.

Daniel Holbach (dholbach) wrote :

Thanks for your help. Just a quick note: if you say "sync", in Ubuntu we always mean "overwrite all Ubuntu changes, take as-is from Debian". Anything else we call "merge".

Taking a look at the diff now.

Daniel Holbach (dholbach) wrote :

Taking the liberty to add "(LP: #1483750)" to the d/changelog entry so the bug will be automatically closed on upload.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pcsc-lite - 1.8.14-1ubuntu1

---------------
pcsc-lite (1.8.14-1ubuntu1) wily; urgency=medium

  * Merge new upstream release from Debian Unstable (LP: #1483750).
    - debian/rules: Move runtime libraries to /lib, for the benefit of
      wpasupplicant. (See Debian #531592)

pcsc-lite (1.8.14-1) unstable; urgency=medium

  * New upstream release

pcsc-lite (1.8.13-1) unstable; urgency=medium

  * New upstream release
  * debian/control: Standards-Version: 3.9.5 -> 3.9.6. No change needed.
  * Fix "Socket activation not working on first try". Fixed upstream
    (Closes: #767862)

pcsc-lite (1.8.12-1) unstable; urgency=medium

  * New upstream release
  * Fix "Conflicting return types of function IsClientAuthorized"
    fixed upstream (Closes: #751517)

 -- Nicolas Derive <email address hidden> Tue, 11 Aug 2015 15:26:58 +0200

Changed in pcsc-lite (Ubuntu):
status: New → Fix Released
Nicolas DERIVE (kalon33) wrote :

thanks @dholbach :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers