pcmciautils should include driver firmware from pcmcia-cs

Bug #75423 reported by Daniel Brownlees on 2006-12-12
6
Affects Status Importance Assigned to Milestone
pcmciautils (Ubuntu)
Medium
Unassigned

Bug Description

Now that pcmcia-cs is deprecated, the firmware for various pcmcia devices is missing.

I got around the bug when using my compex linkport ethernet card by installing pcmcia-cs and then copying /etc/pcmcia/cis/tamarack.dat to /lib/firmware/tamarack.cis
However this is somewhat of a hack :)

OpenSUSE includes the firmwares in pcmciautils, not sure if it's the correct place under Ubuntu though...? See http://www.novell.com/products/linuxpackages/suselinux/pcmciautils.html

Revision history for this message
Eliseo D'Errico (eliseo-derrico) wrote :

Hello,

I'm new in Linux, and my english is bad, so please sorry in advance for the mistakes and thank you for your comprehension.

I would like to add a comment to this bug, because it seems that I have the same problem, and a wise guy on a forum adviced me to let a message here

Link to the forum (french): http://forum.ubuntu-fr.org/viewtopic.php?id=136134

I tried to install the alternate version of Ubuntu 7.04 on a Toshiba Tecra 8000 (an old one) :))
- Pentium II 266 Mhz
- 256 MB of RAM
- other old good things...
- no ethernet port, but a double pcmcia port

The problem is that when I inserted a wireless pcmcia card (or a pc card reader), the system didn't reacted at all (nothing new in dmesg) - the wireless card was operational under Windows 98.

As you can see, no CardBus seems to be listed in lspci:

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 03)
00:04.0 VGA compatible controller: Neomagic Corporation NM2200 [MagicGraph 256AV] (rev 12)
00:05.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:05.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:05.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:05.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:09.0 Communication controller: Toshiba America Info Systems FIR Port (rev 23)

We tried different things (modprobe pcmcia, ...), but still no changes in dmesg

Then, we found a guy that installed successfully breezy on the same machine : http://outlands.ca/linux/t8000.html

I also tried to install breezy, and to make the upgrades until feisty to see if it was a problem with the kernel or with the pcmciautils package (available only since dapper).

The result is that now the pcmcia port works perfectly, and with feisty!!! Youpi! That's the reason why, I suppose that the driver I need is no more available in pcmciautils, but I haven't idea how to be sure of that.

The lspci is still the same now, but these were the changes in dmesg when I inserted the wifi card, with the breezy live-CD:

[4295427.733000] cs: memory probe 0x0d0000-0x0dffff: clean.
[4295435.764000] orinoco 0.14alpha2 (David Gibson <email address hidden>, Pavel Roskin <email address hidden>, et al)
[4295435.793000] orinoco_cs 0.14alpha2 (David Gibson <email address hidden>, Pavel Roskin <email address hidden>, et al)
[4295435.894000] eth0: Hardware identity 0001:0001:0004:0002
[4295435.894000] eth0: Station identity 001f:0001:0006:0010
[4295435.894000] eth0: Firmware determined as Lucent/Agere 6.16
[4295435.894000] eth0: Ad-hoc demo mode supported
[4295435.894000] eth0: IEEE standard IBSS ad-hoc mode supported
[4295435.894000] eth0: WEP supported, 104-bit key
[4295435.894000] eth0: MAC address 00:02:A5:6F:4C:BA
[4295435.894000] eth0: Station name "HERMES I"
[4295435.895000] eth0: ready
[4295435.913000] eth0: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f

Hope that these informations are helpful, and will provide other ones with pleasure if needed.

Revision history for this message
Eliseo D'Errico (eliseo-derrico) wrote :

And I would be very grateful if you could give me a work around to make my pcmcia port operational in another way that installing breezy and then making the upgrades breezy -> dapper -> edgy -> feisty :))

Revision history for this message
Eliseo D'Errico (eliseo-derrico) wrote :

Hello,

I found the problem, the bridge that I tried to load with modprobe was the wrong one.

The right module was i82365. After a modprobe i82365, it worked perfectly!

PS: There is the same problem on the Debian Etch, and the solution is the same.

Revision history for this message
fmyhr (fmyhr) wrote :

I have a hard time understanding why this bug is still "New/Undecided" more than a year after it was reported, and with a working solution supplied by the reporter. I was bitten by the same bug today when I inserted a SOHOware ND5120 NE2K pcmcia card only to be greeted with
     error loading '/lib/firmware/NE2K.cis' for deice '/class/firmware/0.0' with driver '(unknown)'
Thanks to Daniel Brownless, I installed the deprecated pcmcia-cs package and copied /etc/pcmcia/cis/NE2K.dat to /lib/firmware/NE2K.cis then purged pcmcia-cs, and voila, the card works with pcmciautils.

I suggest that the pcmciautils maintainer simply copy the contents of pcmcia-cs /etc/pcmcia/cis/ to /lib/firmware/ (changing the file extensions from *.dat to *.cis) and include it in the pcmciautils package. Maybe that's a hack, but it's certainly better than the current situation where some cards fail to work, that has persisted for over a year.

I'm changing the status of this bug to "Confirmed" to hopefully get some attention.

Changed in pcmciautils:
status: New → Confirmed
Revision history for this message
Colin Watson (cjwatson) wrote :

The only real problem here is that I have no suitable hardware to test with - but I'll see what we can do. Thanks.

Changed in pcmciautils:
importance: Undecided → Medium
Revision history for this message
Christopher Tozzi (cjt34) wrote :

I'd like to bump this since it still seems unresolved. I was helping a user yesterday in the forums who couldn't get a SOHOware ND5120 PCMCIA ethernet card working because of the missing NE2K.cis file. I had to download the pcmcia-cs package for Dapper from http://packages.ubuntu.com, pull NE2k.cis out of it and upload it to the user (see this post http://ubuntuforums.org/showpost.php?p=6643210&postcount=49 for details). It took me a long time to figure out how to do that (it was fmyhr's post above that finally led to the answer), and I doubt that many new Ubuntu users would have any idea what to do.

NE2K.cis (and all other firmware) seems to no longer be included in the pcmcia-cs package for Intrepid. Is there a reason for this? PCMCIA devices are still widely used and Ubuntu would do a better job of working out-of-the-box if this firmware could be more easily installed.

Revision history for this message
Mark Lila (mark-lilas) wrote :

This looks like an easy fix. I confirm the above procedure works on debian Lenny on an old Toshiba 225cds laptop. It looks like it would work pulling the firmware from Gutsy packages too rather than earlier dapper packages but I didn't try it (they may or may not be the same firmware versions?). Do we need to ask debian to do this so it is part of what is upstream from Ubuntu? In debian Lenny, /lib/firmware was empty on a clean install but dropping NE2K.cis into /lib/firmware enabled the SOHOware ND5120-E PCMCIA ethernet card. Perhaps the other firmware packages could also be added for the other cards as well:
List from http://packages.ubuntu.com/gutsy/i386/pcmcia-cs/filelist
/etc/pcmcia/cis/3CCFEM556.dat
/etc/pcmcia/cis/3CXEM556.dat
/etc/pcmcia/cis/COMpad2.dat
/etc/pcmcia/cis/COMpad4.dat
/etc/pcmcia/cis/DP83903.dat
/etc/pcmcia/cis/E-CARD.dat
/etc/pcmcia/cis/LA-PCM.dat
/etc/pcmcia/cis/MT5634ZLX.dat
/etc/pcmcia/cis/NE2K.dat
/etc/pcmcia/cis/PCMLM28.dat
/etc/pcmcia/cis/PE-200.dat
/etc/pcmcia/cis/PE520.dat
/etc/pcmcia/cis/RS-COM-2P.dat
/etc/pcmcia/cis/tamarack.dat

NOTE: Toshiba 225cds laptop also needs i82365 added to /etc/modules to get pcmcia working prior to the above but that is another story unrelated to what card firmware is available

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers