wireless card stops working after installing pcmciautils on 2.6.12

Bug #42205 reported by Alex Fraser on 2006-04-30
10
Affects Status Importance Assigned to Milestone
pcmciautils (Ubuntu)
Medium
Unassigned

Bug Description

I installed a new version of pcmciautils without upgrading the kernel at the same time. My wireless card ceased to work after that. To fix it I revereted back to Breezy and then ran a full dist-upgrade.

I recommend adding a dependency on linux-image-* >= 2.6.13.

Thanks,
Alex

Alex Fraser (alex-phatcore) wrote :

More info:
After upgrading pcmciautils the first time, the service would fail to start. I don't remember seeing a related error message in /var/log/messages.

I was running linux-image-2.6.12-?-386, and pcmciautils version 012-1 (sorry, I've reinstalled since then so don't know the exact versions).

Colin Watson (cjwatson) wrote :

There is no need for such a dependency, and it would be actively harmful (not everyone uses a packaged kernel). pcmciautils silently does nothing on older kernels.

Could you please describe your problem in more detail, without specifying a solution in advance? :-) 'cardctl ident', 'lspci', and 'lspci -n' output would be useful. Thanks.

Changed in pcmciautils:
status: Unconfirmed → Needs Info

Output of cardctl command. `cardctl ident` didn't profivde much information, so I ran it with some other options too. The output is the same under linux 2.6.12 and 2.6.15.

lspci run with a few different options.

This varies slightly from the output under 2.6.15, although the wireless PCMCIA card is still listed. Only `lspci -vv` is included in this file.

Alex Fraser (alex-phatcore) wrote :

Sorry, I didn't mean to sound forceful - I just thought a suggestion would be useful. I intended to add those attachments with my last post but didn't have access to the laptop at the time.

My laptop is an old Sony Vaio (PCG-505TX). The wireless card is a Minitar MN54GCB-R with a Ralink chipset.

The network I'm connecting to uses WPA. I've installed wpasupplicant, but I don't think I'm using it - I'm specifying the extra settings for the card with iwpriv.

When running linux 2.6.15 and pcmciautils 012-1ubuntu4 it works fine. When running linux 2.6.12, pcmciautils fails to start, saying:
* Starting PCMCIA services... [fail]

lspci shows that the card is connected, though it differs slightly between 2.6.12 and 2.6.15. Attempts to bring up the interface fail:
$sudo ifup ra0
SIOCSIFADDR: No such device
ra0:ERROR while getting interface flags: No such device
SIOCSIFNETMASK: No such device
ra0:ERROR while getting interface flags: No such device
Failed to bring up ra0.

Please let me know if there's anything I can do to help. Cheers,
Alex

Paul Dufresne (paulduf) wrote :

Seems to me you had given all the requested information and the bug was forgotten in 'Incomplete' state.
I will keep it as 'Incomplete' however, because I am asking you:
Does this problem still happens with a more recent version?
Ideally, should be tried with Gutsy Tribe-2, for which you can have more info at:
http://www.ubuntu.com/testing/tribe2

Alex Fraser (alex-phatcore) wrote :

Hi, thanks for following this up. Sadly I don't have access to that laptop any more, so I'm unable to verify.

Is it possible to install a kernel << 2.6.15 on Gusty? I think this bug was pretty specific to the upgrade from Breezy.

Paul Dufresne (paulduf) wrote :

Probably what you are suggesting can be done with:
https://wiki.ubuntu.com/DebootstrapChroot (to 'simulate' an environment in an other)
but I am not personally much used with that.

Changing state from 'Incomplete to 'Confirmed', letting developers what to do.

Changed in pcmciautils:
status: Incomplete → Confirmed
Alex Fraser (alex-phatcore) wrote :

Since I can't reproduce this any more, can we change the status to 'needs info' so the bug will auto expire if no one else has the same problem?

dino99 (9d9) on 2012-08-30
Changed in pcmciautils (Ubuntu):
status: Confirmed → Incomplete

Thank you for your bug report. Kernel 2.6.12 is EOL in Ubuntu. Can you retry with a supported Ubuntu version?

Alex Fraser (alex-phatcore) wrote :

Hi Thomas, Thanks for responding. I don't have access to that laptop any more, nor even one with a PCMCIA slot. Can we just let this bug expire?

Yes, thank you for your reply.

Launchpad Janitor (janitor) wrote :

[Expired for pcmciautils (Ubuntu) because there has been no activity for 60 days.]

Changed in pcmciautils (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers