PCManFM reports closing unexpectedly after using update manager or synaptic

Bug #963605 reported by Greg Faith on 2012-03-24
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pcmanfm (Ubuntu)
Medium
Unassigned

Bug Description

Testing Alternate Lubuntu precise amd64 Beta 2

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: pcmanfm 0.9.10-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Fri Mar 23 19:20:00 2012
ExecutablePath: /usr/bin/pcmanfm
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha amd64 (20120323)
Pref_Config_System_lubuntu:
 [Preferred Applications]
 WebBrowser=firefox.desktop
 MailClient=
ProcCmdline: pcmanfm --desktop --profile lhostname
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis: Skipped: missing required field "Disassembly"
Signal: 11
SourcePackage: pcmanfm
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Greg Faith (gregfaith) wrote :
visibility: private → public

StacktraceTop:
 __GI___libc_free (mem=0xaaaaaaaaaaaaaaaa) at malloc.c:2968
 on_folder_view_sel_changed (fv=<optimized out>, files=0x81acd0, page=0x991160) at tab-page.c:148
 g_cclosure_marshal_VOID__POINTERv (closure=<optimized out>, return_value=<optimized out>, instance=<optimized out>, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0x9eea30) at /build/buildd/glib2.0-2.31.22/./gobject/gmarshal.c:1236
 _g_closure_invoke_va (closure=0x9b20a0, return_value=0x0, instance=0x9186b0, args=0x7fff72167f68, n_params=1, param_types=<optimized out>) at /build/buildd/glib2.0-2.31.22/./gobject/gclosure.c:840
 g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=0, var_args=<optimized out>) at /build/buildd/glib2.0-2.31.22/./gobject/gsignal.c:3207

Changed in pcmanfm (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/963605

tags: added: iso-testing
Greg Faith (gregfaith) wrote :

Got a repeat on this bug installing Lubuntu Precise desktop i386 iso. While doing post install tests using update manager.

Erick Brunzell (lbsolost) wrote :

Greg,

I'm having a bit of trouble understanding what you're reporting here. Do you mean you get the crash report, "The application File Manager has closed unexpectedly"?

If so I just noticed that after applying updates to a freshly installed Lubuntu i386 20120323.

For that matter I believe I had seen this while testing the first non-pae images, but not just relating to the update manager, maybe even after just using pcmanfm, deliberately closing it, and then a few seconds later seeing that warning.

Erick Brunzell (lbsolost) wrote :

If we're talking about the same thing, ie: "The application File Manager has closed unexpectedly" it appears that using Update Manager only causes that report if updates are available and actually applied.

But I found another way to reproduce it. Open synaptic, search for an app (I chose 'xfce4-screenshooter' and then deselected xfce-panel), install the app, and afterwards I get the same error report. Screenshot attached.

Erick Brunzell (lbsolost) wrote :

No doubt it's possibly unrelated, and I still need to know if Greg and I are looking at the same error, but I'm also encountering similar nonsensical crash reports with Chromium. Please see bug 963916.

Erick Brunzell (lbsolost) wrote :

If Greg and I are talking about the same behavior I've not been able to reproduce it with the Lubuntu i386 live 20120324 image.

Lance I have not been able to reproduce today either with the amd64
20120324 either.
I am testing them as we speak. It is not a critical bug anyway.
nm_geo Greg

On Sat, Mar 24, 2012 at 2:09 PM, Erick Brunzell <email address hidden> wrote:

> If Greg and I are talking about the same behavior I've not been able to
> reproduce it with the Lubuntu i386 live 20120324 image.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/963605
>
> Title:
> After new testing install using update manager
>
> Status in “pcmanfm” package in Ubuntu:
> New
>
> Bug description:
> Testing Alternate Lubuntu precise amd64 Beta 2
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: pcmanfm 0.9.10-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
> Uname: Linux 3.2.0-20-generic x86_64
> ApportVersion: 1.95-0ubuntu1
> Architecture: amd64
> Date: Fri Mar 23 19:20:00 2012
> ExecutablePath: /usr/bin/pcmanfm
> InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha amd64
> (20120323)
> Pref_Config_System_lubuntu:
> [Preferred Applications]
> WebBrowser=firefox.desktop
> MailClient=
> ProcCmdline: pcmanfm --desktop --profile lhostname
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis: Skipped: missing required field "Disassembly"
> Signal: 11
> SourcePackage: pcmanfm
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/963605/+subscriptions
>

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pcmanfm (Ubuntu):
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

Greg,

I'm just now getting around to testing the i386 20120325 live image and all appears good. Should we now mark this invalid ............... since it is no longer valid?

Yeah I will mark it invalid. I have been running through the pcmanfm tests
and have not encountered any weirdness other that Open as Root and no
yellow address bar.

Thanks,
nm_geo Greg

On Mon, Mar 26, 2012 at 11:28 AM, Erick Brunzell <email address hidden> wrote:

> Greg,
>
> I'm just now getting around to testing the i386 20120325 live image and
> all appears good. Should we now mark this invalid ............... since
> it is no longer valid?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/963605
>
> Title:
> After new testing install using update manager
>
> Status in “pcmanfm” package in Ubuntu:
> Confirmed
>
> Bug description:
> Testing Alternate Lubuntu precise amd64 Beta 2
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: pcmanfm 0.9.10-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
> Uname: Linux 3.2.0-20-generic x86_64
> ApportVersion: 1.95-0ubuntu1
> Architecture: amd64
> Date: Fri Mar 23 19:20:00 2012
> ExecutablePath: /usr/bin/pcmanfm
> InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha amd64
> (20120323)
> Pref_Config_System_lubuntu:
> [Preferred Applications]
> WebBrowser=firefox.desktop
> MailClient=
> ProcCmdline: pcmanfm --desktop --profile lhostname
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis: Skipped: missing required field "Disassembly"
> Signal: 11
> SourcePackage: pcmanfm
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/963605/+subscriptions
>

Changed in pcmanfm (Ubuntu):
status: Confirmed → Invalid

It appears we can no longer produce the bug so we are marking it invalid.

Erick Brunzell (lbsolost) wrote :

I changed this back to confirmed because I'm seeing it again with i386 20120328.

Changed in pcmanfm (Ubuntu):
status: Invalid → Confirmed
Erick Brunzell (lbsolost) wrote :

Greg,

Did I do OK with the rename?

summary: - After new testing install using update manager
+ PCManFM reports closing unexpectedly after using update manager or
+ synaptic

Good I saw it too while running post install tests on the amd64 20120328
desktop and alternates last night.

Thanks,
nm_geo Greg

On Wed, Mar 28, 2012 at 8:53 AM, Erick Brunzell <email address hidden> wrote:

> I changed this back to confirmed because I'm seeing it again with i386
> 20120328.
>
> ** Changed in: pcmanfm (Ubuntu)
> Status: Invalid => Confirmed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/963605
>
> Title:
> After new testing install using update manager
>
> Status in “pcmanfm” package in Ubuntu:
> Confirmed
>
> Bug description:
> Testing Alternate Lubuntu precise amd64 Beta 2
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: pcmanfm 0.9.10-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
> Uname: Linux 3.2.0-20-generic x86_64
> ApportVersion: 1.95-0ubuntu1
> Architecture: amd64
> Date: Fri Mar 23 19:20:00 2012
> ExecutablePath: /usr/bin/pcmanfm
> InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha amd64
> (20120323)
> Pref_Config_System_lubuntu:
> [Preferred Applications]
> WebBrowser=firefox.desktop
> MailClient=
> ProcCmdline: pcmanfm --desktop --profile lhostname
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis: Skipped: missing required field "Disassembly"
> Signal: 11
> SourcePackage: pcmanfm
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/963605/+subscriptions
>

Lance,

Yes sir you did good. i hope we have had the last of the respins as I will
be travel tomorrow and testing will be impossible for me.

nm_geo Greg

On Wed, Mar 28, 2012 at 9:06 AM, Erick Brunzell <email address hidden> wrote:

> Greg,
>
> Did I do OK with the rename?
>
> ** Summary changed:
>
> - After new testing install using update manager
> + PCManFM reports closing unexpectedly after using update manager or
> synaptic
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/963605
>
> Title:
> PCManFM reports closing unexpectedly after using update manager or
> synaptic
>
> Status in “pcmanfm” package in Ubuntu:
> Confirmed
>
> Bug description:
> Testing Alternate Lubuntu precise amd64 Beta 2
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: pcmanfm 0.9.10-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
> Uname: Linux 3.2.0-20-generic x86_64
> ApportVersion: 1.95-0ubuntu1
> Architecture: amd64
> Date: Fri Mar 23 19:20:00 2012
> ExecutablePath: /usr/bin/pcmanfm
> InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha amd64
> (20120323)
> Pref_Config_System_lubuntu:
> [Preferred Applications]
> WebBrowser=firefox.desktop
> MailClient=
> ProcCmdline: pcmanfm --desktop --profile lhostname
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis: Skipped: missing required field "Disassembly"
> Signal: 11
> SourcePackage: pcmanfm
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/963605/+subscriptions
>

Greg Faith (gregfaith) wrote :

The bug is still happening after new testing install Lubuntu precise 12.04 Desktop installing to full encrypted hard drive. Ran Update Manager installed updates and get crash report on pcmanfm.

Julien Lavergne (gilir) wrote :

Could someone test with pcmanfm version 0.9.10-0ubuntu2~ppa1 on https://launchpad.net/~lubuntu-dev/+archive/staging, once it's build ?

Greg Faith (gregfaith) wrote :

Yes sir we will get on it. I have been planning on doing some application
testing on pcmanfm anyway soon. We do have one little bug where the
description/instructions say "Open as Root" there is no yellow address bar
in 12.04.
nm_geo Greg

On Thu, Mar 29, 2012 at 5:10 PM, Julien Lavergne
<email address hidden>wrote:

> Could someone test with pcmanfm version 0.9.10-0ubuntu2~ppa1 on
> https://launchpad.net/~lubuntu-dev/+archive/staging<https://launchpad.net/%7Elubuntu-dev/+archive/staging>,
> once it's build ?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/963605
>
> Title:
> PCManFM reports closing unexpectedly after using update manager or
> synaptic
>
> Status in “pcmanfm” package in Ubuntu:
> Confirmed
>
> Bug description:
> Testing Alternate Lubuntu precise amd64 Beta 2
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: pcmanfm 0.9.10-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
> Uname: Linux 3.2.0-20-generic x86_64
> ApportVersion: 1.95-0ubuntu1
> Architecture: amd64
> Date: Fri Mar 23 19:20:00 2012
> ExecutablePath: /usr/bin/pcmanfm
> InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha amd64
> (20120323)
> Pref_Config_System_lubuntu:
> [Preferred Applications]
> WebBrowser=firefox.desktop
> MailClient=
> ProcCmdline: pcmanfm --desktop --profile lhostname
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis: Skipped: missing required field "Disassembly"
> Signal: 11
> SourcePackage: pcmanfm
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/963605/+subscriptions
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pcmanfm - 0.9.10-0ubuntu2

---------------
pcmanfm (0.9.10-0ubuntu2) precise; urgency=low

  * debian/patches:
   - Rename 91-integrate-lxshortcut.patch to 02-integrate-lxshortcut.patch.
   - 03_avoid_free.patch: Avoid a not necessary free (LP: #963605, #833987)
   - 90_french_desktop.patch: From upstream, fix the French name in the
     desktop file.
   - 101_crash_on_button_press_event.patch &
     103_drag_desktop_item.patch &
     104_fix_crash_desktop.patch :
     Add several patches from Vadim Ushakov to fix potential crashes.
   - 102_crash_on_refresh.patch: Fix crash on refresh (LP: #853507).
 -- Julien Lavergne <email address hidden> Tue, 03 Apr 2012 22:35:05 +0200

Changed in pcmanfm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers