Ubuntu

Restoring file from Trash Bin causes pcmanfm to Shut Down

Reported by Wei-Yee Chan on 2010-12-07
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pcmanfm (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: pcmanfm

Note: This applies to files on external USB drives only. Local files are *not* affected. This problem does not exist in the previous version of Ubuntu, that is 10.10.

Restoring file deleted by pcmanfm from the Trash Bin using pcmanfm causes the application to shut down. The files do not get restored as a result. Cutting and pasting the deleted files back to the original directory produces weird full path filenames.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: pcmanfm 0.9.8-1
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
Architecture: i386
Config_pcmanfm_System_LXDE: Error: [Errno 2] No such file or directory: '/etc/xdg/pcmanfm/pcmanfm.conf'
Date: Tue Dec 7 20:41:59 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
Pref_Config_Home_LXDE:
 [Preferred Applications]
 MailClient=thunderbird.desktop
ProcEnviron:
 LANG=en_HK.utf8
 SHELL=/bin/bash
RelatedPackageVersions:
 libmenu-cache1 0.3.2-2
 pcmanfm 0.9.8-1
 udisks 1.0.2-1
 gvfs 1.7.0-0ubuntu1
SourcePackage: pcmanfm

Wei-Yee Chan (chanweiyee) wrote :
Wei-Yee Chan (chanweiyee) wrote :
Wei-Yee Chan (chanweiyee) wrote :

Update: pcmanfm will crash when doing a restoration, regardless of whether the original files resided on a local or external disk. The full path filenames problem occurs only when the original files were on an external USB disk.

lainme (lainme) wrote :

I also encountered this problem

I don't know how to debug, but here is the bug report in pcmanfm bug tracker

http://sourceforge.net/support/tracker.php?aid=3132262

Changed in pcmanfm (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
Naveen Agarwal (nav.coder) wrote :

+ pcmanfm crashes when doing a restoration, regardless of location. The full path filenames problem occurs only when the original files were on an external USB disk.

Julien Lavergne (gilir) on 2011-03-11
Changed in pcmanfm (Ubuntu):
importance: Undecided → Medium
karl anliot (kanliot) wrote :

deleting this old bug to remove launchpad clutter

Changed in pcmanfm (Ubuntu):
status: Confirmed → Invalid
karl anliot (kanliot) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in pcmanfm (Ubuntu):
status: Invalid → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.