PCManFM not opening SFTP connection with keys

Bug #1227305 reported by Lars Noodén on 2013-09-18
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pcmanfm (Ubuntu)
Undecided
Unassigned

Bug Description

PCManFM works with SFTP with using a regular password. But it seems not to work with keys. I don't see a way to get it to prompt for a key, is there one? I've tried loading the key into the agent using ssh-add and while that works for the text-based sftp client, PCManFM seems to ignore the agent. Any attempts at connection to the remote hosts that need keys return only this error message:

"Permission denied"
"The specified location is not mounted"

What should happen is that PCManFM is aware of the key(s) in the agent and uses the right key to establish the remote connection.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: pcmanfm 1.1.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-7.14-generic 3.11.1
Uname: Linux 3.11.0-7-generic x86_64
ApportVersion: 2.12.1-0ubuntu4
Architecture: amd64
Config_pcmanfm_System_Lubuntu: Error: [Errno 2] No such file or directory: '/etc/xdg/pcmanfm/lubuntu.conf'
Date: Wed Sep 18 21:34:04 2013
InstallationDate: Installed on 2013-09-18 (0 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Alpha amd64+mac (20130917)
MarkForUpload: True
Pref_Config_System_Lubuntu:
 [Preferred Applications]
 WebBrowser=firefox.desktop
 MailClient=
SourcePackage: pcmanfm
UpgradeStatus: No upgrade log present (probably fresh install)

Lars Noodén (larsnooden) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1227305

tags: added: iso-testing
LStranger (andrej-rep) wrote :

This is not a PCManFM issue, you should add your key into ~/.ssh/authorized_keys file on another machine and PCManFM cannot help you with that.

Lars Noodén (larsnooden) wrote :

The key is already added to the other machine and the text utility sftp(1) works just fine with the key while in the same session PCManFM does not. What is the way to get verbose logging output from PCManFM? Running it in the terminal with no options provides no extra output when the login fails. The manual page for PCManFM lists no options for verbose output or logging to stderr, etc.

Lyn Perrine (walterorlin) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
4. Do you have any other programs for managing keys like ssh agent installed.
5. Have you logged out or restart since trying to use the agent if these were new keys and old were were stilll cached by ssh-agent?
6. A saucy is no longer uspported does this happen in a currently supported of lubuntu?

Changed in pcmanfm (Ubuntu):
status: New → Incomplete
Lars Noodén (larsnooden) wrote :

This seems to be fixed in vivid. The steps to test it are.

1 set up a machine with openssh-server and disallow password authentication. Then set up access using keys.

2. try connecting from the client machine using PCManFM and the URI for the remote machine: sftp://<email address hidden>/

PCManFM now triggers a query for the key's passphrase and then uses the key to log in. This is as it should be.

Changed in pcmanfm (Ubuntu):
status: Incomplete → Fix Released
Lars Noodén (larsnooden) wrote :

The fix is only for RSA keys and ed25519 keys are not found or accepted. However, I suspect that the problem is not that of PCManFM but of another component. That might be bug #1393531

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers