PCManFM deletes current directory when pressing cancel and nothing is selected

Bug #1071231 reported by Luca Borrione on 2012-10-25
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pcmanfm (Ubuntu)

Bug Description

Not sure if this is a bug or a wanted feature :)

1) Open a pcmanfm window and go wherever
2) press 'cancel' on your keyboard
3) a prompt will ask you if you want to trash selected items: select 'yes'
4) the current directory will be trashed and the current window will be closed.

I would have expected an alert saying me 'no item selected' or nothing at all,
but not to trash something I haven't selected.

On another hand this could be a keyboard shortcut to trash current directory,
but then the prompt is confusing (should be more clear as something like
'do you want to trash current directory?'), anyhow I would still find annoying the fact
that the window will shut down.

Luca Borrione (luca.borrione) wrote :

I fogot to mention: it's PCManFM 1.0.1 on Lubuntu 12.10

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pcmanfm (Ubuntu):
status: New → Confirmed
SteVe Cook (yorvyk) wrote :

That's a bit nasty. At least it's recoverable as they go to the bin.
If you select a file or two, then press delete only the files are deleted, even if you select all the files in the folder and pcmanfm remains open. Which is what one would expect.
Strangely, if you middle-click on a folder, to open it in a tab then press delete noting happens.

cancel = delete

LStranger (andrej-rep) wrote :

The bug is fixed in upstream. Thank you very much.

Sworddragon (sworddragon) wrote :

PCManFM 1.1.2 (with the fix applied) is now in the repositories so this ticket can be closed.

Changed in pcmanfm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers