lspci tool needs to be updated to support pci gen4 cards

Bug #1665436 reported by bugproxy on 2017-02-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pciutils (Ubuntu)
Undecided
Steve Langasek
Xenial
Undecided
Steve Langasek
Yakkety
Undecided
Steve Langasek

Bug Description

[SRU Justification]
hardware enablement for next-gen hardware in a common hardware utility.

[Test case]
1. On a system with a Mellanox CX5 card, run: lspci -vv -s 0001:01:00.2 | grep Speed
2. Verify that the output shows 'Speed unknown'.
3. Install pciutils from -proposed.
4. Run 'lspci -vv -s 0001:01:00.2 | grep Speed' again.
5. Verify that the output shows 'Speed 16GT/s'.

[Regression potential]
Minimal, and none on systems without the new hardware; this is a code change to trivially extend switch/case statements with a new value.

---Problem Description---
This bugzilla is for tracking that the pciutils tool needs to be updated to support pci gen4 cards. Mellanox CX5 card is a pci gen4 card and when I do the following commands I get error. I do not see these errors with Mellanox CX4 which is pci gen3 card.
In a system, with Mellanox CX4 and CX5 IB with SRIOV:
lspci | grep Mell
0001:01:00.0 Infiniband controller: Mellanox Technologies MT28800 Family [ConnectX-5 Ex]
0001:01:00.1 Infiniband controller: Mellanox Technologies MT28800 Family [ConnectX-5 Ex]
0001:01:00.2 Infiniband controller: Mellanox Technologies MT28800 Family [ConnectX-5 Virtual Function]
0002:01:00.0 Infiniband controller: Mellanox Technologies MT27700 Family [ConnectX-4]
0002:01:00.1 Infiniband controller: Mellanox Technologies MT27700 Family [ConnectX-4]
0002:01:00.2 Infiniband controller: Mellanox Technologies MT27700 Family [ConnectX-4 Virtual Function]
If I do this command with CX4 is ok
virsh nodedev-detach pci_0002_01_00_2
Device pci_0002_01_00_2 detached
but if I do this with CX5 it fails:
virsh nodedev-detach pci_0001_01_00_2
error: Failed to detach device pci_0001_01_00_2
error: malformed 'speed' attribute: (null)

This is what I see with CX5:
lspci -vv -s 0001:01:00.2 | grep Speed
LnkCap: Port #0, Speed unknown, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-

and this is what I see for CX4
lspci -vv -s 0002:01:00.2 | grep Speed
LnkCap: Port #0, Speed 8GT/s, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-

---Additional Hardware Info---
using Mellanox CX5 card that is pci gen4
 lspci -vv -s 0001:01:00.0 | grep Speed
                LnkCap: Port #0, Speed unknown, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
                LnkSta: Speed 8GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                LnkCtl2: Target Link Speed: Unknown, EnterCompliance- SpeedDis-

Machine Type = P8

---Steps to Reproduce---
 just plug a pci gen4 card to the system and do this command
lspci -vv -s 0001:01:00.0 | grep Speed
                LnkCap: Port #0, Speed unknown, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
                LnkSta: Speed 8GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                LnkCtl2: Target Link Speed: Unknown, EnterCompliance- SpeedDis-
Will see the speed unknown.

Userspace tool common name: pciutils

The patch is already in the pci utils tree:
commit 9628600bbbeffc4ec6dc48943ee091a5d3eca18b
Author: Gavin Shan <email address hidden>
Date: Wed Feb 15 10:53:45 2017 +1100

    lspci: Support GEN4 speed (16GT/s)

    This enables "lspci" to show GEN4 speed (16GT/s) properly according
    to the contents in register PCI_EXP_LNKCAP, PCI_EXP_LNKSTA and
    PCI_EXP_LNKCTL2.

IBM is asking for the patch to go into 17.04 as well s 16.04.3.

bugproxy (bugproxy) on 2017-02-16
tags: added: architecture-ppc64le bugnameltc-151418 severity-high targetmilestone-inin1704
Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)
affects: ubuntu → pciutils (Ubuntu)
Download full text (3.7 KiB)

pciutils bug affecting IBM Power systems - can someone from Foundations
please take a look.

Thanks.

                   Michael

On 02/16/2017 11:39 AM, Launchpad Bug Tracker wrote:
> bugproxy (bugproxy) has assigned this bug to you for Ubuntu:
>
> ---Problem Description---
> This bugzilla is for tracking that the pciutils tool needs to be updated to support pci gen4 cards. Mellanox CX5 card is a pci gen4 card and when I do the following commands I get error. I do not see these errors with Mellanox CX4 which is pci gen3 card.
> In a system, with Mellanox CX4 and CX5 IB with SRIOV:
> lspci | grep Mell
> 0001:01:00.0 Infiniband controller: Mellanox Technologies MT28800 Family [ConnectX-5 Ex]
> 0001:01:00.1 Infiniband controller: Mellanox Technologies MT28800 Family [ConnectX-5 Ex]
> 0001:01:00.2 Infiniband controller: Mellanox Technologies MT28800 Family [ConnectX-5 Virtual Function]
> 0002:01:00.0 Infiniband controller: Mellanox Technologies MT27700 Family [ConnectX-4]
> 0002:01:00.1 Infiniband controller: Mellanox Technologies MT27700 Family [ConnectX-4]
> 0002:01:00.2 Infiniband controller: Mellanox Technologies MT27700 Family [ConnectX-4 Virtual Function]
> If I do this command with CX4 is ok
> virsh nodedev-detach pci_0002_01_00_2
> Device pci_0002_01_00_2 detached
> but if I do this with CX5 it fails:
> virsh nodedev-detach pci_0001_01_00_2
> error: Failed to detach device pci_0001_01_00_2
> error: malformed 'speed' attribute: (null)
>
> This is what I see with CX5:
> lspci -vv -s 0001:01:00.2 | grep Speed
> LnkCap: Port #0, Speed unknown, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
> LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
>
> and this is what I see for CX4
> lspci -vv -s 0002:01:00.2 | grep Speed
> LnkCap: Port #0, Speed 8GT/s, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
> LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
>
> ---Additional Hardware Info---
> using Mellanox CX5 card that is pci gen4
> lspci -vv -s 0001:01:00.0 | grep Speed
> LnkCap: Port #0, Speed unknown, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
> LnkSta: Speed 8GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
> LnkCtl2: Target Link Speed: Unknown, EnterCompliance- SpeedDis-
>
>
>
> Machine Type = P8
>
> ---Steps to Reproduce---
> just plug a pci gen4 card to the system and do this command
> lspci -vv -s 0001:01:00.0 | grep Speed
> LnkCap: Port #0, Speed unknown, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
> LnkSta: Speed 8GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
> LnkCtl2: Target Link Speed: Unknown, EnterCompliance- SpeedDis-
> Will see the speed unknown.
>
> Userspace tool common name: pciutils
>
> The patch is already in the pci utils tree:
> commit 9628600bbbeffc4ec6dc48943ee091a5d3eca18b
> Author: Gavin Shan <email address hidden>
> Date: Wed Feb 15 10:53:45 2017 +1100
>
> lspci: Support GEN4 speed (16GT/s)...

Read more...

Steve Langasek (vorlon) on 2017-02-16
Changed in pciutils (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → Steve Langasek (vorlon)
status: New → Fix Committed
Changed in pciutils (Ubuntu Xenial):
assignee: nobody → Steve Langasek (vorlon)
Changed in pciutils (Ubuntu Yakkety):
assignee: nobody → Steve Langasek (vorlon)
Steve Langasek (vorlon) on 2017-02-16
Changed in pciutils (Ubuntu Xenial):
status: New → In Progress
Changed in pciutils (Ubuntu Yakkety):
status: New → In Progress
description: updated

Hello bugproxy, or anyone else affected,

Accepted pciutils into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pciutils/1:3.3.1-1.1ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in pciutils (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in pciutils (Ubuntu Xenial):
status: In Progress → Fix Committed
Andy Whitcroft (apw) wrote :

Hello bugproxy, or anyone else affected,

Accepted pciutils into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pciutils/1:3.3.1-1.1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pciutils - 1:3.3.1-1.1ubuntu8

---------------
pciutils (1:3.3.1-1.1ubuntu8) zesty; urgency=medium

  * debian/patches/lspci-Support-GEN4-speed-16GT-s.patch: Cherry-pick from
    upstream to support PCI gen4 cards in lspci. Closes LP: #1665436.

 -- Steve Langasek <email address hidden> Thu, 16 Feb 2017 14:12:21 -0800

Changed in pciutils (Ubuntu):
status: Fix Committed → Fix Released
bugproxy (bugproxy) on 2017-02-20
tags: added: verification-done-xenial

------- Comment From <email address hidden> 2017-02-20 20:23 EDT-------
Making Carol's comment public:

-------------------------------------

Verified with Xenial
dpkg --list | grep pci
ii libpci3:ppc64el 1:3.3.1-1.1ubuntu4.1 ppc64el Linux PCI Utilities (shared library)
ii libpciaccess0:ppc64el 0.13.4-1 ppc64el Generic PCI access library for X
ii pciutils 1:3.3.1-1.1ubuntu4.1 ppc64el Linux PCI Utilities

lspci | grep Mellanox
0001:01:00.0 Infiniband controller: Mellanox Technologies MT28800 Family [ConnectX-5 Ex]

lspci -vv -s 0001:01:00.0 | grep Speed
LnkCap: Port #0, Speed 16GT/s, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
LnkSta: Speed 8GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
LnkCtl2: Target Link Speed: 16GT/s, EnterCompliance- SpeedDis-

Steve Langasek (vorlon) wrote :

Thanks. Could you please also verify this fix for 16.10 (yakkety)?

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2017-02-21 11:33 EDT-------
(In reply to comment #19)
> Thanks. Could you please also verify this fix for 16.10 (yakkety)?

Actually I did a mistake in my comment yesterday. that was yakkety not xenial.
Here is the output from both.

Xenial
# dpkg --list | grep pciutils
ii pciutils 1:3.3.1-1.1ubuntu1.1 ppc64el Linux PCI Utilities
# lspci | grep Mellanox | grep X-5
0008:01:00.0 Infiniband controller: Mellanox Technologies MT28800 Family [ConnectX-5]
# lspci -vv -s 0008:01:00.0 | grep Speed
LnkCap: Port #0, Speed 16GT/s, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
LnkSta: Speed 8GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
LnkCtl2: Target Link Speed: 16GT/s, EnterCompliance- SpeedDis-

Yaketty
dpkg --list | grep pciutils
ii pciutils 1:3.3.1-1.1ubuntu4.1 ppc64el Linux PCI Utilities
# lspci | grep Mellanox | grep X-5
0001:01:00.0 Infiniband controller: Mellanox Technologies MT28800 Family [ConnectX-5 Ex]
0001:01:00.1 Infiniband controller: Mellanox Technologies MT28800 Family [ConnectX-5 Ex]
# lspci -vv -s 0001:01:00.0 | grep Speed
LnkCap: Port #0, Speed 16GT/s, Width x16, ASPM not supported, Exit Latency L0s unlimited, L1 unlimited
LnkSta: Speed 8GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
LnkCtl2: Target Link Speed: 16GT/s, EnterCompliance- SpeedDis-

tags: added: verification-done-yakkety
removed: verification-needed
Robie Basak (racb) wrote :

I see some autopkgtest failures against this update in http://people.canonical.com/~ubuntu-archive/pending-sru.html. I don't think they're related, but could somebody please double check? In particular the kernel version mismatch looks like a test issue, but I don't know if PCI changes are kernel-version-sensitive.

Changed in pciutils (Ubuntu Yakkety):
status: Fix Committed → Incomplete
Robie Basak (racb) wrote :

The current status is the same for both Xenial and Yakkety - both blocked on checking the autopkgtest results.

Changed in pciutils (Ubuntu Xenial):
status: Fix Committed → Incomplete
Steve Langasek (vorlon) wrote :

The linux autopkgtest failures are unrelated. They fall into two broad categories:
 - timeouts building on armhf. These are not regressions; they are seen consistently with any autopkgtest runs other than for linux-meta, which is a false-negative because the rebuild test is skipped for linux-meta as the trigger.
 - failures to run the ubuntu-regression-suite because the source package version does not match the running kernel version. This will always fail for kernels other than the default 'linux' source package because the kernels don't get booted into.

Neither of these are regressions caused by pciutils, they are bugs in the linux autopkgtests and/or the infrastructure. They should not block release of this SRU.

Changed in pciutils (Ubuntu Xenial):
status: Incomplete → Fix Committed
Changed in pciutils (Ubuntu Yakkety):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pciutils - 1:3.3.1-1.1ubuntu1.1

---------------
pciutils (1:3.3.1-1.1ubuntu1.1) xenial; urgency=medium

  * debian/patches/lspci-Support-GEN4-speed-16GT-s.patch: Cherry-pick from
    upstream to support PCI gen4 cards in lspci. Closes LP: #1665436.

 -- Steve Langasek <email address hidden> Thu, 16 Feb 2017 14:20:09 -0800

Changed in pciutils (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for pciutils has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pciutils - 1:3.3.1-1.1ubuntu4.1

---------------
pciutils (1:3.3.1-1.1ubuntu4.1) yakkety; urgency=medium

  * debian/patches/lspci-Support-GEN4-speed-16GT-s.patch: Cherry-pick from
    upstream to support PCI gen4 cards in lspci. Closes LP: #1665436.

 -- Steve Langasek <email address hidden> Thu, 16 Feb 2017 14:22:34 -0800

Changed in pciutils (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers