Please update pciutils for 12.04.3

Bug #1207387 reported by Kent Baxley on 2013-08-01
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Dell-poweredge project
High
Kent Baxley
pciutils (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Tim Gardner

Bug Description

Please consider updating the pciutils database for the 12.04.3 LTS point release.

12.04.3 with the 3.8 raring-lts kernel is the minimum supported release and kernel combination for Intel Ivy Bridge server CPUs and chipsets. Some OEMs will be refreshing their server hardware with these new components.

Currently, if lspci is run against these machines, we are presented with some very generic information. For example:

System peripheral: Intel Corporation Device 0e80 (rev 04)

If the 'update-pciids' utility is run against these systems, then some more detailed information is presented on subsequent runs of lspci:

System peripheral: Intel Corporation Ivytown QPI Link 0 (rev 04)

Although update-pciids is a simple enough solution to get the proper information from these machines, it'd be more convenient to update pciutils if at all possible in order to avoid any confusion and possible support calls once customers start installing Ubuntu on these machines.

Kent Baxley (kentb) on 2013-08-01
Changed in dell-poweredge:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Kent Baxley (kentb)
Tim Gardner (timg-tpi) on 2013-08-01
Changed in pciutils (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Kent Baxley (kentb) on 2013-08-01
Changed in dell-poweredge:
status: Confirmed → In Progress

Hello Kent, or anyone else affected,

Accepted pciutils into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/pciutils/1:3.1.8-2ubuntu6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in pciutils (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Kent Baxley (kentb) wrote :

Tested pciutils 1:3.18-2ubuntu6 on affected hardware. lspci output looks good. Thanks!

tags: added: verification-done
removed: verification-needed
Kent Baxley (kentb) wrote :

whoops, that should be 1:3.1.8-2ubuntu6 instead of 1:3.18-2ubuntu6

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pciutils (Ubuntu):
status: New → Confirmed
Adam Conrad (adconrad) on 2013-08-26
Changed in pciutils (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pciutils - 1:3.1.8-2ubuntu6

---------------
pciutils (1:3.1.8-2ubuntu6) precise; urgency=low

  * Downloaded daily snapshot dated 2013-07-26 03:15:02
    -LP: #1207387
 -- Tim Gardner <email address hidden> Thu, 01 Aug 2013 09:36:28 -0600

Changed in pciutils (Ubuntu Precise):
status: Fix Committed → Fix Released
Kent Baxley (kentb) on 2013-10-31
Changed in dell-poweredge:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers