pay-service needs restart after account creation

Bug #1348231 reported by dobey on 2014-07-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pay-service (Ubuntu)
Critical
Ted Gould

Bug Description

Currently, if no U1 account is present, or if the account is deleted and recreated in online-accounts, pay-service must be restarted to pick up the new account.

Related branches

dobey (dobey) on 2014-07-30
tags: added: rtm14
Alejandro J. Cura (alecu) wrote :

Ted: this is why the first purchase is not working for you.

If you re-run the script to setup staging after you've logged in, then the pay-service gets restarted, and everything seems to work ok.

Changed in pay-service (Ubuntu):
importance: High → Critical
assignee: nobody → Ted Gould (ted)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pay-service - 2.0.0+14.10.20140807.1-0ubuntu1

---------------
pay-service (2.0.0+14.10.20140807.1-0ubuntu1) utopic; urgency=low

  [ Ted Gould ]
  * Switch to using UAL untrusted helpers and Mir trusted prompt
    sessions
  * Include pay-test-app in the pay-service repository
  * Use libaccounts to get signals on account creation or deletion to
    update the stored token (LP: #1348231)

  [ Diego Sarmentero ]
  * Update testing plan .
 -- Ubuntu daily release <email address hidden> Thu, 07 Aug 2014 18:50:14 +0000

Changed in pay-service (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers