Pulseaudio didn't play to the "Low Frequency Effects" (LFE) channel via "Analog Surround 5.1 output"

Bug #486602 reported by Murz on 2009-11-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pavucontrol (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pavucontrol

I have an analog 5.1 speakers with the Intel HDA audio (Realtek ALC662 rev1 - HDA ATI SB) device.
Alsa is configured to use 5.1 speakers, in alsamixer I see the LFE regulator, that sets to 100%.
I have the pavucontrol (pulseaudio volume control) tool that can chage the pulseadio configuration

When i set the pulseadio to any 5.1 in Profile selectlist, I hear the sound, can control volume of each speaker.
When I looking any video with 5.1 sound, I hear the sound normally, with using LFE "Low Frequency Effects".
But when I listen the stereo (2-channel) music, I hear nothing in LFE speaker!!
If I set the pulseadio profile to "Analog stereo", I hear the sound from it, but when I goes back to any 5.1 profile, the LFE goes off.

And I didn't see the "Low Frequency Effects" volume regulator in the device, I see strange string "Rear center".
Here is my pulseadio settings screenshots:
http://yfrog.com/9fsnapshot1ip
http://yfrog.com/bhsnapshot2qp
http://yfrog.com/j7snapshot3lp

How I can bring the LFE work when playing 2-channel music?

ProblemType: Bug
Architecture: amd64
Date: Sun Nov 22 13:10:07 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: pavucontrol 0.9.8+git20090701-0ubuntu2
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: pavucontrol
Uname: Linux 2.6.31-14-generic x86_64
XsessionErrors:
 (polkit-gnome-authentication-agent-1:21137): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (npviewer.bin:15135): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64
 (npviewer.bin:31986): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64
 (npviewer.bin:8461): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64

Murz (murznn) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pavucontrol (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers